Camera object display weirdly broken #111161

Closed
opened 2023-08-16 05:32:36 +02:00 by hxorasani · 13 comments

System Information
Operating system: Linux-6.2.0-27-generic-x86_64-with-glibc2.37 64 Bits, WAYLAND UI
Graphics card: Mesa Intel(R) HD Graphics 4400 (HSW GT2) Intel 4.6 (Core Profile) Mesa 23.0.4-0ubuntu1~23.04.1

Blender Version
Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Worked: used to work on 3.5

Short description of error
cameras look like square boxes no matter what mode it is.

图片

Exact steps for others to reproduce the error
Literally all cameras no matter what file it is look weird.
I've described it on stackoverflow

**System Information** Operating system: Linux-6.2.0-27-generic-x86_64-with-glibc2.37 64 Bits, WAYLAND UI Graphics card: Mesa Intel(R) HD Graphics 4400 (HSW GT2) Intel 4.6 (Core Profile) Mesa 23.0.4-0ubuntu1~23.04.1 **Blender Version** Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Worked: used to work on 3.5 **Short description of error** cameras look like square boxes no matter what mode it is. ![图片](/attachments/6190906d-0598-487b-88fe-3dce93735a1f) **Exact steps for others to reproduce the error** Literally all cameras no matter what file it is look weird. I've described it on [stackoverflow](https://blender.stackexchange.com/questions/298683/what-has-happened-to-my-camera-in-blender-3-6)
187 KiB
hxorasani added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-16 05:32:37 +02:00
Member

It's likely the driver's issue. Could you try a different version of intel driver?

Since it reports OpenGL 4.6 and a few previous reports also shows this kind of overlay wire drawing weirdness, I think there might be some thing going on probably with the matrices. Will look for those reports and try to categorize.

It's likely the driver's issue. Could you try a different version of intel driver? Since it reports OpenGL 4.6 and a few previous reports also shows this kind of overlay wire drawing weirdness, I think there might be some thing going on probably with the matrices. Will look for those reports and try to categorize.
YimingWu added the
Interest
EEVEE & Viewport
Interest
OpenGL
labels 2023-08-16 05:39:37 +02:00
YimingWu changed title from Cameras are broken to Camera object display weirdly broken 2023-08-16 05:39:58 +02:00
Author

It's likely the driver's issue. Could you try a different version of intel driver?

Sadly i can't switch driver versions :(

> It's likely the driver's issue. Could you try a different version of intel driver? Sadly i can't switch driver versions :(
Member

Upgrading mesa rivers may fix the problem, see: #106445 / https://gitlab.freedesktop.org/mesa/mesa/-/issues/9290

Sadly i can't switch driver versions

why? :/

Upgrading mesa rivers may fix the problem, see: #106445 / https://gitlab.freedesktop.org/mesa/mesa/-/issues/9290 > Sadly i can't switch driver versions why? :/
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-08-16 05:50:49 +02:00
Author

Upgrading mesa rivers may fix the problem, see: #106445 / https://gitlab.freedesktop.org/mesa/mesa/-/issues/9290

Sadly i can't switch driver versions

why? :/

i recently upgraded my Ubuntu to 23.04; it's already pretty unstable and i've barely gotten it to work;
can't afford to have more probs if i accidentally end up doing something wrong experimenting with mesa;
although im tempted to test it; idk how to safely do it? can someone point me in the right direction, please?

> Upgrading mesa rivers may fix the problem, see: #106445 / https://gitlab.freedesktop.org/mesa/mesa/-/issues/9290 > > > Sadly i can't switch driver versions > > why? :/ i recently upgraded my Ubuntu to 23.04; it's already pretty unstable and i've barely gotten it to work; can't afford to have more probs if i accidentally end up doing something wrong experimenting with mesa; although im tempted to test it; idk how to safely do it? can someone point me in the right direction, please?
Author

mesa version 23.1.5

Okay i upgraded mesa to 23.1.5 but the problem still persists on Blender 3.6.0;
and i dont wanna upgrade blender to 4.0 yet, until it's stable and actually released.
:(

![mesa version 23.1.5](/attachments/7e5a8975-2c5d-401e-bad0-e2a4c5519f1a) Okay i upgraded mesa to 23.1.5 but the problem still persists on Blender 3.6.0; and i dont wanna upgrade blender to 4.0 yet, until it's stable and actually released. :(
Pratik Borhade added
Status
Needs Triage
and removed
Status
Needs Information from User
labels 2023-08-30 06:00:09 +02:00
Member

This problem should have been resolved, see #111162. Will close the report

This problem should have been resolved, see #111162. Will close the report
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-08-31 11:02:42 +02:00
Author

I tried Blender 4.0alpha with the Mesa 23.1.6 drivers
Mesa 23.1.6
and not only does this problem persists but I discovered another bug:
#111587

I wish blender devs would support this 10 year old chip, some of us can't afford to upgrade just yet. 😢

blender 4 workbench broken on intel haswell 4400

I tried Blender 4.0alpha with the Mesa 23.1.6 drivers ![Mesa 23.1.6](/attachments/ceb62394-4f33-4baa-8181-b41190e8ce14) and not only does this problem persists but I discovered another bug: https://projects.blender.org/blender/blender/issues/111587 I wish blender devs would support this 10 year old chip, some of us can't afford to upgrade just yet. 😢 ![blender 4 workbench broken on intel haswell 4400](/attachments/6743b892-1d3f-4b24-851c-0d24ea63c64c)
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2023-09-01 12:39:48 +02:00
Member

@alba-delba please try using this build: https://builder.blender.org/download/patch/PR111708/ (see #111162 (comment)) and check if the problem still exists. Thanks!

@alba-delba please try using this build: https://builder.blender.org/download/patch/PR111708/ (see https://projects.blender.org/blender/blender/issues/111162#issuecomment-1009633) and check if the problem still exists. Thanks!
Author

@ChengduLittleA the patch build doesn't fix it either 😢

blender 4 PR111708 probs

@ChengduLittleA the patch build doesn't fix it either 😢 ![blender 4 PR111708 probs](/attachments/130869f6-7339-4b7e-ac8a-df2ee8fbe665)
151 KiB
YimingWu added
Status
Needs Info from Developers
Module
EEVEE & Viewport
and removed
Status
Needs Triage
labels 2023-09-05 06:58:59 +02:00

@alba-delba

  1. Have you tried clearing mesa cache before running Blender?: on my distrib (Manjaro) it's in ~/.cache/mesa_shader_cache/, so I run this:
    rm -rf ~/.cache/mesa_shader_cache/*

  2. If 1. doesn't work can you post the file "blender-libs.txt" created with this command (run it in the folder of the 4.0 alpha PR111708):
    LD_DEBUG=libs ./blender 2>./blender-libs.txt

@alba-delba 1. Have you tried clearing mesa cache before running Blender?: on my distrib (Manjaro) it's in ~/.cache/mesa_shader_cache/, so I run this: `rm -rf ~/.cache/mesa_shader_cache/*` 2. If 1. doesn't work can you post the file "blender-libs.txt" created with this command (run it in the folder of the 4.0 alpha PR111708): `LD_DEBUG=libs ./blender 2>./blender-libs.txt`
Author

tried deleting the mesa cache (which i had also done before), it fixed the camera bug,

but the other bug (no shader storage buffer support) is still there.

image

i've attached the blender libs file.

tried deleting the mesa cache (which i had also done before), it fixed the camera bug, but the other bug (no shader storage buffer support) is still there. ![image](/attachments/0f0d9115-6532-4652-b78c-9a5fe0cc3060) i've attached the blender libs file.

tried deleting the mesa cache (which i had also done before), it fixed the camera bug,

Ok great, thanks !

but the other bug (no shader storage buffer support) is still there.

For me it has been fixed since then (you can try a more recent build of 4.0 alpha). If not please open an other ticket.

> tried deleting the mesa cache (which i had also done before), it fixed the camera bug, Ok great, thanks ! > but the other bug (no shader storage buffer support) is still there. For me it has been fixed since then (you can try [a more recent build of 4.0 alpha](https://builder.blender.org/download/daily/)). If not please open an other ticket.
Author

@aperitero tysm for suggesting that ❤️

i tried blender-4.0.0-alpha+main.8c826afc7ba1-linux.x86_64-release
and both bugs are fixed there. can't wait for it to stabilize.

i can't go back to blender 3.5- because all my files are in 3.6+ format :(

blender-4.0.0-alpha+main.8c826afc7ba1-linux.x86_64-release

@aperitero tysm for suggesting that ❤️ i tried `blender-4.0.0-alpha+main.8c826afc7ba1-linux.x86_64-release` and both bugs are fixed there. can't wait for it to stabilize. i can't go back to blender 3.5- because all my files are in 3.6+ format :( ![blender-4.0.0-alpha+main.8c826afc7ba1-linux.x86_64-release](/attachments/c3a41c69-1a5d-4059-894e-9220ef6881bc)
509 KiB
Blender Bot added
Status
Archived
and removed
Status
Needs Info from Developers
labels 2023-09-05 20:50:18 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111161
No description provided.