Vertex weights incorrectly display as all the same #111405

Closed
opened 2023-08-22 20:49:07 +02:00 by Tiffany · 1 comment

System Information
Operating system: Ubuntu MATE 22.04.3 LTS
Graphics card: Intel i3 10th Gen

Blender Version
Broken: 3.6.2, also 4.0.0 Aug 22 commit d45f47a809
Worked: 3.3.11 Aug 21 commit 7311c9d51e
I'd check more versions but the site is only giving them at 200 kb/sec and it's taking 20 minutes to download each one.

Short description of error
Vertex weights are shown inaccurately in the transform menu. The same weight value is shown for all vertex groups, even when the actual weights are different.

Exact steps for others to reproduce the error

  1. Start with the attached file, OR
    1a. Start with the default cube, add an armature, add a second bone to the armature, parent the mesh to the armature with automatic weights
    1b. Enter edit mode, select a vertex influenced by at least 2 bones, and press N to open the transform info.
  2. Look at vertex weights shown. Observe the same value is shown for all weights.
  3. Type in a different value for the bottom weight. Observe the value shown for the top weight changes to match it.
  4. Type in a different value for the top weight. Observe there is no visible effect and the same value is still shown as before.
    5 (optional). Pose the bones. Go back and adjust the weights again, noting that the actual position matches what you typed in and not the value shown.
**System Information** Operating system: Ubuntu MATE 22.04.3 LTS Graphics card: Intel i3 10th Gen **Blender Version** Broken: 3.6.2, also 4.0.0 Aug 22 commit d45f47a809dd Worked: 3.3.11 Aug 21 commit 7311c9d51e1e I'd check more versions but the site is only giving them at 200 kb/sec and it's taking 20 minutes to download each one. **Short description of error** Vertex weights are shown inaccurately in the transform menu. The same weight value is shown for all vertex groups, even when the actual weights are different. **Exact steps for others to reproduce the error** 1. Start with the attached file, OR 1a. Start with the default cube, add an armature, add a second bone to the armature, parent the mesh to the armature with automatic weights 1b. Enter edit mode, select a vertex influenced by at least 2 bones, and press N to open the transform info. 2. Look at vertex weights shown. Observe the same value is shown for all weights. 3. Type in a different value for the bottom weight. Observe the value shown for the top weight changes to match it. 4. Type in a different value for the top weight. Observe there is no visible effect and the same value is still shown as before. 5 (optional). Pose the bones. Go back and adjust the weights again, noting that the actual position matches what you typed in and not the value shown.
Tiffany added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-22 20:49:08 +02:00

This is a duplicate of #111273. Feel free to subscribe to that one for additional information and status updates.

This is a duplicate of #111273. Feel free to subscribe to that one for additional information and status updates.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-08-22 20:56:37 +02:00
Jesse Yurkovich added
Status
Duplicate
and removed
Status
Archived
labels 2023-08-22 20:56:43 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111405
No description provided.