Regression: Vertex Weights Panel is Broken #111454

Closed
opened 2023-08-24 01:53:52 +02:00 by Kevin C. Burke · 3 comments
Contributor

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.99

Blender Version
Broken: version: 3.6.2, branch: blender-v3.6-release, commit date: 2023-08-16 16:43, hash: e53e55951e7a
Worked: 3.6.1

Short description of error
The Vertex Weights Panel appears to be broken in 3.6.2

Exact steps for others to reproduce the error

  1. In the attached .blend file, select a vertex in Edit Mode
  2. In Object Data Properties, go to the Vertex Groups Panel and set a weight with the Weight slider
  3. Use the 'Assign' to execute the bpy.ops.object.vertex_group_assign() operator, assigning a weight to the selected vertices
  4. In the Item > Vertex Weights panel, if there are multiple Vertex Groups, the same weight will be displayed for all the vertex groups.
  5. Either open the Spreadsheet Editor to see the correct weights or run the below script in the Text Editor to print them in the System Console. You will see that the Item > Vertex Weights panel is incorrect.
import bpy

context = bpy.context
active_obj = context.active_object
previous_mode = context.object.mode
bpy.ops.object.mode_set(mode="OBJECT")

if active_obj.type == 'MESH':
    vertices = active_obj.data.vertices

    for vi,vert in enumerate(vertices):
        if vert.select:
            print("#"*20,vi,"#"*20)
            weights = [g.weight for g in vert.groups]
            for i,w in enumerate(weights):
                print(i,w)
            total_weight = sum(weights)
            print("total_weight",total_weight)

bpy.ops.object.mode_set(mode=previous_mode)
**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.99 **Blender Version** Broken: version: 3.6.2, branch: blender-v3.6-release, commit date: 2023-08-16 16:43, hash: `e53e55951e7a` Worked: 3.6.1 **Short description of error** The Vertex Weights Panel appears to be broken in 3.6.2 **Exact steps for others to reproduce the error** 1. In the attached .blend file, select a vertex in Edit Mode 2. In Object Data Properties, go to the Vertex Groups Panel and set a weight with the Weight slider 3. Use the 'Assign' to execute the bpy.ops.object.vertex_group_assign() operator, assigning a weight to the selected vertices 4. In the Item > Vertex Weights panel, if there are multiple Vertex Groups, the same weight will be displayed for all the vertex groups. 5. Either open the Spreadsheet Editor to see the correct weights or run the below script in the Text Editor to print them in the System Console. You will see that the Item > Vertex Weights panel is incorrect. ```Py import bpy context = bpy.context active_obj = context.active_object previous_mode = context.object.mode bpy.ops.object.mode_set(mode="OBJECT") if active_obj.type == 'MESH': vertices = active_obj.data.vertices for vi,vert in enumerate(vertices): if vert.select: print("#"*20,vi,"#"*20) weights = [g.weight for g in vert.groups] for i,w in enumerate(weights): print(i,w) total_weight = sum(weights) print("total_weight",total_weight) bpy.ops.object.mode_set(mode=previous_mode) ```
Kevin C. Burke added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-24 01:53:52 +02:00
Iliya Katushenock added the
Interest
Modeling
Interest
Python API
labels 2023-08-24 01:54:49 +02:00
Iliya Katushenock changed title from Item > Vertex Weights Panel is Broken to Regression: Vertex Weights Panel is Broken 2023-08-24 01:55:15 +02:00
Author
Contributor

Here is a video demonstrating the above steps.

Here is a video demonstrating the above steps.

Seems duplicate of #111273

Seems duplicate of https://projects.blender.org/blender/blender/issues/111273
Member

Looks like the fix #111421 doesn't touch any part that's gonna fix the bpy side of thing, I guess we could keep this open until we tested the patch.

Oh ok I understood it now, it's indeed the same as #111273 which will be fixed by #111421. The python output is correct. Will close the report as duplicate.

~~Looks like the fix #111421 doesn't touch any part that's gonna fix the bpy side of thing, I guess we could keep this open until we tested the patch.~~ Oh ok I understood it now, it's indeed the same as #111273 which will be fixed by #111421. The python output is correct. Will close the report as duplicate.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-08-24 04:43:46 +02:00
YimingWu added
Status
Duplicate
and removed
Status
Archived
labels 2023-08-24 04:43:55 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111454
No description provided.