Each Vertex Shows The Same Weight For Each Bone #111543

Closed
opened 2023-08-26 00:56:01 +02:00 by Stanley · 4 comments

System Information
Operating system: Linux-5.15.0-79-generic-x86_64-with-glibc2.31 64 Bits, X11 UI
Graphics card: AMD JUNIPER (DRM 2.50.0 / 5.15.0-79-generic, LLVM 12.0.0) X.Org 3.3 (Core Profile) Mesa 21.2.6

Blender Version
Broken: version: 3.6.2, branch: blender-v3.6-release, commit date: 2023-08-16 16:43, hash: e53e55951e7a
Worked: (newest version of Blender that worked as expected)

Short description of error
See attached pic.
If I click on any vertex, every bone weight for that vertex is the same.
I can't change any of the weights.
I opened a file in both Blender 3.6.1 and 3.6.2 at the same time, and the weights are correct in 3.6.1.

As far as I know, if you save the file in Blender 3.6.2 (with wrong weights displayed), the correct weights will still be displayed if you open the same file in 3.6.1.

This has not been fixed in 3.6.3 release candidate.

Exact steps for others to reproduce the error
Use Blender 3.6.2 to open any file that has different weights assigned to a vertex.

**System Information** Operating system: Linux-5.15.0-79-generic-x86_64-with-glibc2.31 64 Bits, X11 UI Graphics card: AMD JUNIPER (DRM 2.50.0 / 5.15.0-79-generic, LLVM 12.0.0) X.Org 3.3 (Core Profile) Mesa 21.2.6 **Blender Version** Broken: version: 3.6.2, branch: blender-v3.6-release, commit date: 2023-08-16 16:43, hash: `e53e55951e7a` Worked: (newest version of Blender that worked as expected) **Short description of error** See attached pic. If I click on any vertex, every bone weight for that vertex is the same. I can't change any of the weights. I opened a file in both Blender 3.6.1 and 3.6.2 at the same time, and the weights are correct in 3.6.1. As far as I know, if you save the file in Blender 3.6.2 (with wrong weights displayed), the correct weights will still be displayed if you open the same file in 3.6.1. This has *not* been fixed in 3.6.3 release candidate. **Exact steps for others to reproduce the error** Use Blender 3.6.2 to open any file that has different weights assigned to a vertex.
Stanley added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-08-26 00:56:02 +02:00

Hi, this look like duplicate of #111273. This was fixed today. Can you check last 4.0 build and confirm?

Hi, this look like duplicate of https://projects.blender.org/blender/blender/issues/111273. This was fixed today. Can you check last 4.0 build and confirm?
Author

Hi, this look like duplicate of #111273. This was fixed today. Can you check last 4.0 build and confirm?

Yeah, mine's a duplicate. Sorry, I couldn't find the post before posting my own.

Blender 4 alpha isn't opening on my Pc (hopefully the stable version will work for me).
So I can't test the problem there.

Can Blender devs please fix this for Blender 3.6 lts?

> Hi, this look like duplicate of https://projects.blender.org/blender/blender/issues/111273. This was fixed today. Can you check last 4.0 build and confirm? Yeah, mine's a duplicate. Sorry, I couldn't find the post before posting my own. Blender 4 alpha isn't opening on my Pc (hopefully the stable version will work for me). So I can't test the problem there. Can Blender devs please fix this for Blender 3.6 lts?

I realized it was in 3.6 only after writing the comment, sorry. Most likely, when Jacques is online, he will add the fix to the list for 3.6.4.

I realized it was in 3.6 only after writing the comment, sorry. Most likely, when Jacques is online, he will add the fix to the list for 3.6.4.
Member

Yes, same as #111273, closing.

I realized it was in 3.6 only after writing the comment, sorry.

Why Jacques pushed the fix to "main" branch then? 😅
(I have not checked the problem locally yet, will do)

Yes, same as #111273, closing. > I realized it was in 3.6 only after writing the comment, sorry. Why Jacques pushed the fix to "main" branch then? 😅 (I have not checked the problem locally yet, will do)
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-08-26 07:03:25 +02:00
Pratik Borhade added
Status
Duplicate
and removed
Status
Archived
labels 2023-08-26 07:03:32 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111543
No description provided.