"Illegal address in CUDA queue" error occurs when I use both Principled BSDF and Adaptive Subdivision #111639

Open
opened 2023-08-29 01:49:44 +02:00 by Ian-Ambrose · 4 comments

System Information
Operating system: Windows 11 Pro 64 Bits
Graphics card: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.99

Blender Version
Broken: version: 3.6.2, branch: blender-v3.6-release, commit date: 2023-08-16 16:43, hash: e53e55951e7a
Worked: (newest version of Blender that worked as expected)

Short description of error
-"Illegal address in CUDA queue" error occurs when I activate both Principled BSDF and Adaptive Subdivision at the same time.
-It would work fine if I don't use both at the same time.
-Here are the possibilities of the error occurring when I use different settings:

  1. Principled BSDF + Adaptive Subdivision = error
  2. Texture Coordinate surface + Adaptive Subdivision = no error
  3. Principled BSDF + NO Adaptive Subdivision = no error

-I can use a high poly count without Adaptive Subdivision (e.g. Level viewport = 7), works fine. But as soon as I turn it on (even with low poly count, e.g. Dicing scale = 1) combined with Principled BSDF, the error occurs.

Exact steps for others to reproduce the error
In the file I sent, I've already activated Principled BSDF + Adaptive Subdivision, you need to turn on the "Rendered Viewport Shading" and then slide the Scale parameter of the Noise Texture very quickly and the error should occur.

**System Information** Operating system: Windows 11 Pro 64 Bits Graphics card: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.99 **Blender Version** Broken: version: 3.6.2, branch: blender-v3.6-release, commit date: 2023-08-16 16:43, hash: `e53e55951e7a` Worked: (newest version of Blender that worked as expected) **Short description of error** -**"Illegal address in CUDA queue"** error occurs when I activate both Principled BSDF and Adaptive Subdivision at the same time. -It would work fine if I don't use both at the same time. -Here are the possibilities of the error occurring when I use different settings: 1. Principled BSDF + Adaptive Subdivision = **error** 2. Texture Coordinate surface + Adaptive Subdivision = **no error** 3. Principled BSDF + NO Adaptive Subdivision = **no error** -I can use a high poly count without Adaptive Subdivision *(e.g. Level viewport = 7)*, works fine. But as soon as I turn it on *(even with low poly count, e.g. Dicing scale = 1)* combined with Principled BSDF, the error occurs. **Exact steps for others to reproduce the error** In the file I sent, I've already activated Principled BSDF + Adaptive Subdivision, you need to turn on the "Rendered Viewport Shading" and then slide the Scale parameter of the Noise Texture very quickly and the error should occur.
Ian-Ambrose added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-08-29 01:49:45 +02:00
Member

Thanks for the report. I can confirm

Thanks for the report. I can confirm
Pratik Borhade added
Module
Render & Cycles
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-08-29 07:21:11 +02:00
Member

I can't reproduce this anymore, do you still get the error on recent builds?

I can't reproduce this anymore, do you still get the error on recent builds?
Author

@LukasStockner
@PratikPB2123
Hi! With 3.6.4, the old file (aka the file that I attached above) could still produce the error.
But, when I created a new file and manually recreated the node tree in that new file, the problem disappears.

I'm not sure what's happening, the main problem might be inside the old file itself. But thank you, the developers, for your help.

@LukasStockner @PratikPB2123 Hi! With 3.6.4, the old file (aka the file that I attached above) could still produce the error. But, when I created a new file and manually recreated the node tree in that new file, the problem disappears. I'm not sure what's happening, the main problem might be inside the old file itself. But thank you, the developers, for your help.
Member

Unable to confirm either in current main. (Can still redo in 3.6 with provided file)

Unable to confirm either in current main. (Can still redo in 3.6 with provided file)
Pratik Borhade added this to the 3.6 LTS milestone 2023-11-13 11:00:37 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111639
No description provided.