Blender just crashes for no reason, and the crash report is empty. (Segmentation fault) #111834

Open
opened 2023-09-02 20:11:41 +02:00 by Jackson-Novak-1 · 9 comments

System Information
Operating system: Arch Linux x86_64
Graphics card: AMD Radeon RX 6900 XT

Blender Version
Broken: (example: 3.6.2, ffe9313875, master, 2023-08-31, as found on the splash screen)
Worked: (No idea when this error started happening.)

Short description of error
Blender does not start up. When I start it via the command line, I get this error:

Writing: /tmp/blender.crash.txt
Segmentation fault (core dumped)

/tmp/blender.crash.txt:

# Blender 3.6.2, Commit date: 2023-08-14 14:05, Hash ffe93138751e

# backtrace

# Python backtrace

Exact steps for others to reproduce the error
Trying to open Blender.

**System Information** Operating system: Arch Linux x86_64 Graphics card: AMD Radeon RX 6900 XT **Blender Version** Broken: (example: 3.6.2, ffe93138751e, master, 2023-08-31, as found on the splash screen) Worked: (No idea when this error started happening.) **Short description of error** Blender does not start up. When I start it via the command line, I get this error: ``` Writing: /tmp/blender.crash.txt Segmentation fault (core dumped) ``` `/tmp/blender.crash.txt`: ``` # Blender 3.6.2, Commit date: 2023-08-14 14:05, Hash ffe93138751e # backtrace # Python backtrace ``` **Exact steps for others to reproduce the error** Trying to open Blender.
Jackson-Novak-1 added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-09-02 20:11:42 +02:00

Same here, the log is just in blank with no stack trace like the OP

System Information
Operating system: Endeavour OS x86_64
Graphics card: AMD Radeon RX 6700 XT
CPU: Intel Core i7-4790

Same here, the log is just in blank with no stack trace like the OP System Information Operating system: Endeavour OS x86_64 Graphics card: AMD Radeon RX 6700 XT CPU: Intel Core i7-4790

Experienced this too, running Manjaro Linux, 32GB ram and Nvidia RTX 3060ti with 8GB Vram

Experienced this too, running Manjaro Linux, 32GB ram and Nvidia RTX 3060ti with 8GB Vram

Can you check blender 4.0?

Can you check blender 4.0?

Same experience with Blender 4.0

Same experience with Blender 4.0

The Arch maintainers are aware of this: https://bugs.archlinux.org/task/79506 -- you can add votes to that bug.

It seems to have something to do with OpenShadingLanguage not supporting LLVM 16, although for all I know it's potentially related to blender/blender#111820.

The Arch maintainers are aware of this: https://bugs.archlinux.org/task/79506 -- you can add votes to that bug. It seems to have something to do with OpenShadingLanguage not supporting LLVM 16, although for all I know it's potentially related to blender/blender#111820.
Member

It seems to have something to do with OpenShadingLanguage not supporting LLVM 16

I guess it is possible, maybe the binaries are compiled differently. Are you using your own compilation of blender?

> It seems to have something to do with OpenShadingLanguage not supporting LLVM 16 I guess it is possible, maybe the binaries are compiled differently. Are you using your own compilation of blender?

It seems to have something to do with OpenShadingLanguage not supporting LLVM 16

I guess it is possible, maybe the binaries are compiled differently. Are you using your own compilation of blender?

I've tried (1) Arch's precompiled package, and (2) my own compilation.

(1) Arch's Blender package will launch if I use the trick of specifying drivers and libraries from the LLVM 15 version of Mesa (as noted in the Arch bug discussion), although Cycles will sometimes (but not always) crash. Arch appears to compile Blender and OpenShadingLanguage and other components with LLVM 15, but Mesa with LLVM 16. If you look through the Arch bug discussion, there are some stacktraces there, and one of the comments notes that the "Common factor seems to be radeonsi driver and aforementioned LLVM conflict."

(2) My own compilation is not a "controlled experiment" due to #111820, but it does launch fine if I compile it using LLVM 16 and without OpenShadingLanguage support. On the whole, I question whether this is really a Blender bug rather than an issue with OpenShadingLanguage not yet supporting LLVM 16 and/or Arch deciding to move to LLVM 16.

> > It seems to have something to do with OpenShadingLanguage not supporting LLVM 16 > > I guess it is possible, maybe the binaries are compiled differently. Are you using your own compilation of blender? I've tried (1) Arch's precompiled package, and (2) my own compilation. (1) Arch's Blender package will launch if I use the trick of specifying drivers and libraries from the LLVM 15 version of Mesa (as noted in the Arch bug discussion), although Cycles will sometimes (but not always) crash. Arch appears to compile Blender and OpenShadingLanguage and other components with LLVM 15, but Mesa with LLVM 16. If you look through the Arch bug discussion, there are some stacktraces there, and one of the comments notes that the "Common factor seems to be radeonsi driver and aforementioned LLVM conflict." (2) My own compilation is not a "controlled experiment" due to #111820, but it does launch fine _if_ I compile it using LLVM 16 and without OpenShadingLanguage support. On the whole, I question whether this is really a Blender bug rather than an issue with OpenShadingLanguage not yet supporting LLVM 16 and/or Arch deciding to move to LLVM 16.

Also crashing on Arch. The log isn't completely empty though. I've attached it.

Also crashing on Arch. The log isn't completely empty though. I've attached it.

Here's the new bug report since they've migrated to Gitlab based system

https://gitlab.archlinux.org/archlinux/packaging/packages/blender/-/issues/2

Here's the new bug report since they've migrated to Gitlab based system https://gitlab.archlinux.org/archlinux/packaging/packages/blender/-/issues/2
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
7 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111834
No description provided.