Vertex weights not editable or displaying properly in edit mode #112007

Closed
opened 2023-09-06 09:40:28 +02:00 by Beorn Leonard · 4 comments

System Information
Operating system: Windows 10
Graphics card: NVIDIA GForce GTX 1080

Blender Version
Broken: 3.6.2
Worked: 3.6.1

Vertex weights no longer display properly, or are editable in Edit mode.
In the "Vertex Weights" section of the "Item" tab of the N panel, the vertex weights of different groups all display the same value, regardless of the value that was set. When attempting to edit the values, the value entry doesn't work, except for the last group in the list, which changes all values.

Exact steps for others to reproduce the error
Select the default cube.
Add some vertex groups in the Properties>Object Data panel.
Enter edit mode and select a vertex.
Assign it to several of the vertex groups.
Attempt to adjust the vertex weight values in the N panel.

**System Information** Operating system: Windows 10 Graphics card: NVIDIA GForce GTX 1080 **Blender Version** Broken: 3.6.2 Worked: 3.6.1 Vertex weights no longer display properly, or are editable in Edit mode. In the "Vertex Weights" section of the "Item" tab of the N panel, the vertex weights of different groups all display the same value, regardless of the value that was set. When attempting to edit the values, the value entry doesn't work, except for the last group in the list, which changes all values. **Exact steps for others to reproduce the error** Select the default cube. Add some vertex groups in the Properties>Object Data panel. Enter edit mode and select a vertex. Assign it to several of the vertex groups. Attempt to adjust the vertex weight values in the N panel.
Beorn Leonard added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-09-06 09:40:29 +02:00
Author

Here is a GIF of the bug.

Here is a GIF of the bug.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-09-06 09:41:15 +02:00
Beorn Leonard changed title from Vertex weights not editable or displaying properly in edit mode to Vertex weights not editable or displaying properly in edit mode 2023-09-06 09:41:55 +02:00
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2023-09-06 09:42:09 +02:00
Author

Sorry, didn't mean to close it.
This is actually a major bug for riggers, and shouldn't exist in an LTS release.

Sorry, didn't mean to close it. This is actually a major bug for riggers, and shouldn't exist in an LTS release.

This is a duplicate of #111273. There's a fix that should make its way into 3.6.3 when that releases.

This is a duplicate of #111273. There's a fix that should make its way into 3.6.3 when that releases.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-09-06 09:56:41 +02:00
Jesse Yurkovich added
Status
Duplicate
and removed
Status
Archived
labels 2023-09-06 09:56:49 +02:00
Author

Ok, thanks mate.

Ok, thanks mate.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#112007
No description provided.