Graphical issues with drawing objects in the viewport due to opengl driver #112098

Closed
opened 2023-09-07 19:37:57 +02:00 by m1lkweed · 8 comments

System Information
Operating system: Debian GNU/Linux trixie/sid x86_64 (6.4.0-3-amd64)
Graphics card: Intel Haswell-ULT (Intel i7-4600U (4) @ 3.300GHz)

Blender Version
Broken: 3.4 and all later versions (tested on 3.5, 3.6, and 4.0.0 alpha 8f21353b5dc8)
Worked: 3.3.1, 3.3.11 release candidate ae9665bc449f
All cameras and lights are misrendered, even after being deleted and re-added to a scene. This happens even on fresh installs (screenshot shows a version where 3.3.1 was already installed) with default settings and the default startup .blend. I've been told this may be a MESA bug, but Blender 3.3.1 works without issues.

Exact steps for others to reproduce the error
Unsure, it may be specific to Intel Integrated Graphics on Debian but it occurs as soon as Blender is run.
I'm happy to provide more info if needed. Apologies if this is a duplicate, this isn't the easiest bug to search Issues for.

**System Information** Operating system: `Debian GNU/Linux trixie/sid x86_64 (6.4.0-3-amd64)` Graphics card: `Intel Haswell-ULT (Intel i7-4600U (4) @ 3.300GHz)` **Blender Version** Broken: 3.4 and all later versions (tested on 3.5, 3.6, and 4.0.0 alpha `8f21353b5dc8`) Worked: 3.3.1, 3.3.11 release candidate `ae9665bc449f` All cameras and lights are misrendered, even after being deleted and re-added to a scene. This happens even on fresh installs (screenshot shows a version where 3.3.1 was already installed) with default settings and the default startup .blend. I've been told this may be a MESA bug, but Blender 3.3.1 works without issues. **Exact steps for others to reproduce the error** Unsure, it may be specific to Intel Integrated Graphics on Debian but it occurs as soon as Blender is run. I'm happy to provide more info if needed. Apologies if this is a duplicate, this isn't the easiest bug to search Issues for.
m1lkweed added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-09-07 19:37:58 +02:00

Yeah this is the same as #102024 and #106445 which were also filed as the following 3 MESA bugs:
https://gitlab.freedesktop.org/mesa/mesa/-/issues/8789
https://gitlab.freedesktop.org/mesa/mesa/-/issues/9290
https://gitlab.freedesktop.org/mesa/mesa/-/issues/9656

There does not seem like a good path forward for Mesa + that specific era GPU as there's been no satisfying resolution to the problems. Some say it's fixed with MESA 23.1.4 and using Blender 4.0 but not if using 3.6 ...

Yeah this is the same as #102024 and #106445 which were also filed as the following 3 MESA bugs: https://gitlab.freedesktop.org/mesa/mesa/-/issues/8789 https://gitlab.freedesktop.org/mesa/mesa/-/issues/9290 https://gitlab.freedesktop.org/mesa/mesa/-/issues/9656 There does not seem like a good path forward for Mesa + that specific era GPU as there's been no satisfying resolution to the problems. Some say it's fixed with MESA 23.1.4 and using Blender 4.0 but not if using 3.6 ...

Actually, there is some hope with #111162 where an incompatibility was found, but if you say it still doesn't work with 4.0 then not sure.

Actually, there is some hope with #111162 where an incompatibility was found, but if you say it still doesn't work with 4.0 then not sure.
Author

Interestingly, that issue mentions

Likely broken between 3.5 to 3.6 since 3.5 worked fine on those supposedly "broken" mesa drivers.

Which is interesting because I still see the issue on 3.4. Still, this does seem to be related to #111162 and the other issues mentioned in that one

Interestingly, that issue mentions > Likely broken between 3.5 to 3.6 since 3.5 worked fine on those supposedly "broken" mesa drivers. Which is interesting because I still see the issue on 3.4. Still, this does seem to be related to #111162 and the other issues mentioned in that one
Member

Guess we close this as duplicate then.
@ChengduLittleA ^

Guess we close this as duplicate then. @ChengduLittleA ^
Member

Let's keep this separate as said in #111162 (comment)

As Jesse said, newer mesa drivers fixed the problem: #106445 (comment)
Could you update them?

Also share system info: Help > Save System info

Let's keep this separate as said in https://projects.blender.org/blender/blender/issues/111162#issuecomment-1013600 As Jesse said, newer mesa drivers fixed the problem: https://projects.blender.org/blender/blender/issues/106445#issuecomment-985400 Could you update them? Also share system info: `Help > Save System info`
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-09-08 06:23:06 +02:00
Member

looks to me this is the same as #111162, you can test this build: #111162 (comment) , but be sure to remove shader cache first (instructions are in that thread as well), otherwise it won't work.

looks to me this is the same as #111162, you can test this build: https://projects.blender.org/blender/blender/issues/111162#issuecomment-1009633 , but be sure to remove shader cache first (instructions are in that thread as well), otherwise it won't work.
Author

I tested that build and cleared my shader cache and it seems to work now Should I close this issue?
I spoke too soon. Solid objects no longer render but that probably needs its own issue

~~I tested that build and cleared my shader cache and it seems to work now Should I close this issue?~~ I spoke too soon. Solid objects no longer render but that probably needs its own issue
Member

Yeah, would be good to have a separate report for that. I'll close this for now.

Yeah, would be good to have a separate report for that. I'll close this for now.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-09-09 07:17:55 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#112098
No description provided.