Transfer shape key is only working for meshes #112230

Open
opened 2023-09-11 15:11:26 +02:00 by jack conradsen · 6 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.23

Blender Version
Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Worked: Never

Short description of error
Transfering shape keys is option in panel menu, but it only works for meshes. This is not mentioned in documentation and only evident after running the operator.

Exact steps for others to reproduce the error

Duplicate object in provided file and try to transfer shape keys.

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.23 **Blender Version** Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Worked: Never **Short description of error** Transfering shape keys is option in panel menu, but it only works for meshes. This is not mentioned in documentation and only evident after running the operator. **Exact steps for others to reproduce the error** Duplicate object in provided file and try to transfer shape keys.
jack conradsen added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-09-11 15:11:27 +02:00
Author

my own project, i am trying to align eyelashes, but the option doesn't do anything. Making it a harder process

my own project, i am trying to align eyelashes, but the option doesn't do anything. Making it a harder process
Author

transfer shape key, does not work on non meshes either. The appeal is that nurbs have way less points, making them easier to work with than regular meshes. So the fact you can only use most shapekey options on meshes is a big limitation i think

transfer shape key, does not work on non meshes either. The appeal is that nurbs have way less points, making them easier to work with than regular meshes. So the fact you can only use most shapekey options on meshes is a big limitation i think
Iliya Katushenock added the
Interest
Modeling
label 2023-09-11 15:25:57 +02:00

The shape key edit mode is for meshes only as suggested by button tooltip. I can look into transfer shape key function to see if it is limited as well. If that is a bug I will edit the report.

The shape key edit mode is for meshes only as suggested by button tooltip. I can look into transfer shape key function to see if it is limited as well. If that is a bug I will edit the report.
Author

The shape key edit mode is for meshes only as suggested by button tooltip. I can look into transfer shape key function to see if it is limited as well. If that is a bug I will edit the report.

even if it's intended not to work, it feels like something that should be possible

> The shape key edit mode is for meshes only as suggested by button tooltip. I can look into transfer shape key function to see if it is limited as well. If that is a bug I will edit the report. even if it's intended not to work, it feels like something that should be possible

I see, that key transfer is explicitly designed for meshes, but then this should be either disabled or not present in menus for other objects.

I see, that key transfer is explicitly designed for meshes, but then this should be either disabled or not present in menus for other objects.

The shape key edit mode is for meshes only as suggested by button tooltip. I can look into transfer shape key function to see if it is limited as well. If that is a bug I will edit the report.

even if it's intended not to work, it feels like something that should be possible

Sure, but this is bug tracker, here we handle only problems with existing code. For user requests and feedback, please use other channels: https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests
For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug

> > The shape key edit mode is for meshes only as suggested by button tooltip. I can look into transfer shape key function to see if it is limited as well. If that is a bug I will edit the report. > > even if it's intended not to work, it feels like something that should be possible Sure, but this is bug tracker, here we handle only problems with existing code. For user requests and feedback, please use other channels: https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug
Richard Antalik changed title from Shape key edit mode, doesn't work for nurbs to Transfer shape key is only working for meshes 2023-09-11 16:14:08 +02:00
Richard Antalik added
Module
Animation & Rigging
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-09-11 16:18:24 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#112230
No description provided.