Node tools: tool operators missing when file was re-loaded #113237

Open
opened 2023-10-04 07:54:03 +02:00 by Sun Kim · 2 comments
Contributor

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 536.40

Blender Version
Broken: version: 4.1.0 Alpha, branch: main, commit date: 2023-10-02 08:29, hash: 7f7e1ab08842
Worked: n/a

Short description of error
If you re-load (via Revert or opening it again) blend file in the same Blender instance node tools operators are missing in the menu.

This happens if there's a node tool that is marked as asset and given a category in the asset library. This does not happen if the file only has non-asset and uncategorized node tools.

The node tools operators re-appear if you do certain actions (clicking other categories in asset browser, creating a new geometry nodes).

Exact steps for others to reproduce the error

From scratch

  • Add a node tool. Mark it asset. In the asset browser give it a category
  • See if the operator is in the menu
  • Save the blend file
  • Revert or opening it again
  • The operator is missing in the menu

With test file

node_tools_missing.blend
blender_assets.cats.txt

  • Download both and put it in the same folder
  • Open blend file. See if the operator is in the menu
  • Revert or opening it again
  • The operator is missing in the menu
**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 536.40 **Blender Version** Broken: version: 4.1.0 Alpha, branch: main, commit date: 2023-10-02 08:29, hash: `7f7e1ab08842` Worked: n/a **Short description of error** If you re-load (via `Revert` or opening it again) blend file in the same Blender instance node tools operators are missing in the menu. This happens if there's a node tool that is marked as asset and given a category in the asset library. This does not happen if the file only has non-asset and uncategorized node tools. The node tools operators re-appear if you do certain actions (clicking other categories in asset browser, creating a new geometry nodes). <video src="/attachments/18a2cbfa-6aa3-49ff-8cd2-c755174d1a3a" title="node_tools_missing.mp4" controls></video> **Exact steps for others to reproduce the error** ### From scratch - Add a node tool. Mark it asset. In the asset browser give it a category - See if the operator is in the menu - Save the blend file - Revert or opening it again - The operator is missing in the menu ### With test file [node_tools_missing.blend](/attachments/e11d008d-c505-4457-9be2-9536267d539b) [blender_assets.cats.txt](/attachments/dab0a494-0d82-4577-bcf6-2415d5f540bc) - Download both and put it in the same folder - Open blend file. See if the operator is in the menu - Revert or opening it again - The operator is missing in the menu
Sun Kim added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-10-04 07:54:04 +02:00
Iliya Katushenock added the
Interest
Asset System
label 2023-10-04 11:39:08 +02:00
Member

Can confirm.

CC @HooglyBoogly

Can confirm. CC @HooglyBoogly
Philipp Oeser added
Status
Confirmed
Module
Nodes & Physics
and removed
Status
Needs Triage
labels 2023-10-04 13:39:53 +02:00
Hans Goudey added
Type
Bug
and removed
Type
Report
labels 2023-10-31 23:05:22 +01:00
Member

@HooglyBoogly looks like this is the issue that we couldn't find when I mentioned this problem. I closed my report here #115303
Would be much appreciated if you could take a look at this!

@HooglyBoogly looks like this is the issue that we couldn't find when I mentioned this problem. I closed my report here #115303 Would be much appreciated if you could take a look at this!
Hans Goudey self-assigned this 2024-01-03 23:59:10 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#113237
No description provided.