Keymap: 4.0 Grease Pencil shortcuts problems #113920

Closed
opened 2023-10-19 09:09:20 +02:00 by Mohamed · 6 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 536.23

Blender Version
Broken: version: 4.0.0 Beta, branch: blender-v4.0-release, commit date: 2023-10-18 20:17, hash: e11f031d62cc

Short description of error
I took the time to test all shortcuts related to Grease Pencil in the 4.0 release notes and here is a list all the issues I found.

Exact steps for others to reproduce the error
Enable the relevant keymap and test these shortcuts:

Default

  • X = flip primary and secondary color - Works in Vertex paint mode but not Draw mode
  • Alt+I = deletes active GP keyframe but Shift+Del deletes all active keyframes (very different shortcuts for similar actions)

Industry Compatible

  • not sure what the removed GP Line Session drawing means? or what shortcut it used before?
  • Ctrl+A = Mask/Select Pie Menu - Works only in mesh sculpt mode
  • Alt+A = Auto-Masking Pie Menu - Works only in mesh sculpt mode
  • Shift+S = replaces I for the Animation Menu - Not added to Edit mode
  • Shift+Alt+S = Insert Blank Keyframe - Not added to Edit mode
  • Y = Active Layer Menu - Not added to Edit mode
  • Shift Y = Merge Layer - Does not exist
  • Alt Backspace/Delete = Delete Active Keyframe (Previously on D Backspace/Delete) - Alt Backspace/Delete doesn't exist, only Shift Backspace/Delete = Delete all active keyframes & works only in Edit & Object modes. Strangely 3.6 has both Shift Backspace/Delete & D Backspace/Delete to do the same thing
  • L = Toggle Stabilize Stroke - Does not exist
  • Ctrl+L seems to be mentioned in "Brush Size & Select Linked" then again under "Other"
  • [ = Toggle Toolbar/Channels - It's Ctrl+[
  • ] = Toggle Sidebar - It's Ctrl+]
  • 1,2,3 don't switch selection mode when in GP Edit mode (they work in GP vertex paint and sculpt modes. In object mode they switch to Edit but then don't switch selection)
**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 536.23 **Blender Version** Broken: version: 4.0.0 Beta, branch: blender-v4.0-release, commit date: 2023-10-18 20:17, hash: `e11f031d62cc` **Short description of error** I took the time to test all shortcuts related to Grease Pencil in the 4.0 release notes and here is a list all the issues I found. **Exact steps for others to reproduce the error** Enable the relevant keymap and test these shortcuts: Default ====== * X = flip primary and secondary color - Works in Vertex paint mode but not Draw mode * Alt+I = deletes active GP keyframe but Shift+Del deletes all active keyframes (very different shortcuts for similar actions) Industry Compatible ================ * not sure what the removed GP Line Session drawing means? or what shortcut it used before? * Ctrl+A = Mask/Select Pie Menu - Works only in mesh sculpt mode * Alt+A = Auto-Masking Pie Menu - Works only in mesh sculpt mode * Shift+S = replaces I for the Animation Menu - Not added to Edit mode * Shift+Alt+S = Insert Blank Keyframe - Not added to Edit mode * Y = Active Layer Menu - Not added to Edit mode * Shift Y = Merge Layer - Does not exist * Alt Backspace/Delete = Delete Active Keyframe (Previously on D Backspace/Delete) - Alt Backspace/Delete doesn't exist, only Shift Backspace/Delete = Delete all active keyframes & works only in Edit & Object modes. Strangely 3.6 has both Shift Backspace/Delete & D Backspace/Delete to do the same thing * L = Toggle Stabilize Stroke - Does not exist * Ctrl+L seems to be mentioned in "Brush Size & Select Linked" then again under "Other" * [ = Toggle Toolbar/Channels - It's Ctrl+[ * ] = Toggle Sidebar - It's Ctrl+] * 1,2,3 don't switch selection mode when in GP Edit mode (they work in GP vertex paint and sculpt modes. In object mode they switch to Edit but then don't switch selection)
Mohamed added the
Priority
Normal
Status
Needs Triage
Type
Report
labels 2023-10-19 09:09:21 +02:00
Iliya Katushenock added the
Interest
Grease Pencil
label 2023-10-19 19:00:26 +02:00

Thanks for the report, @MumuMundo. We appreciate you taking the time to test the Grease Pencil shortcuts in the 4.0 release and providing us with a detailed list of the issues you encountered.

I tested the "flip primary and secondary color" X key and can confirm that it does not work in Draw Mode.

According to the description in !108791, this should work for Draw, Paint & Sculpt modes.

Therefore I can confirm it as a bug.

Cc. @JulienKaspar @ideasman42

Thanks for the report, @MumuMundo. We appreciate you taking the time to test the Grease Pencil shortcuts in the 4.0 release and providing us with a detailed list of the issues you encountered. I tested the "flip primary and secondary color" `X` key and can confirm that it does not work in Draw Mode. According to the description in !108791, this should work for Draw, Paint & Sculpt modes. Therefore I can confirm it as a bug. Cc. @JulienKaspar @ideasman42
Germano Cavalcante added
Module
Sculpt, Paint & Texture
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-10-20 19:11:15 +02:00
Member

I'll have a look at these. Most issues mentioned in this report are a problem with the release notes, not the keymap.
Not all modes are 100% consistent with their shortcuts.

X for color flipping in Draw mode is conflicting with deleting the current frame, yes.
There's no bug here. The shortcut is working just like in previous releases.
But I'll check with the grease pencil module if the shortcut conflict could be resolved so color flipping can be supported for painting.

I'll have a look at these. Most issues mentioned in this report are a problem with the release notes, not the keymap. Not all modes are 100% consistent with their shortcuts. `X` for color flipping in Draw mode is conflicting with deleting the current frame, yes. There's no bug here. The shortcut is working just like in previous releases. But I'll check with the grease pencil module if the shortcut conflict could be resolved so color flipping can be supported for painting.
Member

I checked again about the missing grease pencil shortcuts in the IC keymap. Can confirm.

I update the release notes to fix incorrect information. Other fixes that I'll do for the keymap from this list are:

  • Alt A = Missing from GP sculpt mode
  • Shift S = 'Animation' menu in GP edit mode is using I instead
  • Shift Alt S = Insert Blank Keyframe - Not added to Edit mode
  • Y = Active Layer Menu - Not added to Edit mode
  • Shift Y = Merge Down - Does not exist
  • Shift Backspace/Delete = Delete All Active Frames is missing from every mode except Draw
  • Backspace/Delete = Delete Menu is missing from all modes except Edit

The support for color flipping in Draw mode is a to do. That can be handled afterwards for 4.1.
Same for 123 keys for non mesh objects.

I checked again about the missing grease pencil shortcuts in the IC keymap. Can confirm. I update the release notes to fix incorrect information. Other fixes that I'll do for the keymap from this list are: - `Alt A` = Missing from GP sculpt mode - `Shift S` = 'Animation' menu in GP edit mode is using `I` instead - `Shift Alt S` = Insert Blank Keyframe - Not added to Edit mode - `Y` = Active Layer Menu - Not added to Edit mode - `Shift Y` = Merge Down - Does not exist - `Shift Backspace/Delete` = Delete All Active Frames is missing from every mode except Draw - `Backspace/Delete` = Delete Menu is missing from all modes except Edit The support for color flipping in Draw mode is a to do. That can be handled afterwards for 4.1. Same for `123` keys for non mesh objects.
Julien Kaspar self-assigned this 2023-10-23 12:45:06 +02:00
Julien Kaspar added
Type
Bug
and removed
Type
Report
labels 2023-10-23 12:45:13 +02:00
Author

Thanks for fixing! Just note that the release notes still say Shift Backspace/Delete = Delete Active Keyframe (it should be All Active Keyframes)

Thanks for fixing! Just note that the release notes still say **Shift Backspace/Delete = Delete Active Keyframe** (it should be All Active Keyframes)

Fixed ef0b7337a6

Fixed ef0b7337a6207ce33bf7d7ddc0244a307d106821
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2023-10-31 06:05:19 +01:00
Member

@MumuMundo Should be all done now. If you find something else, feel free to report it or reach out in blender.chat 👍

@MumuMundo Should be all done now. If you find something else, feel free to report it or reach out in blender.chat 👍
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#113920
No description provided.