Overlay Next: Outline of selected objects not appearing, selection crashes #114543

Open
opened 2023-11-06 17:13:52 +01:00 by Renaldo · 8 comments

System Information
Operating system: Windows-10-10.0.19044-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3060/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 546.01

Blender Version
Broken: version: 4.1.0 Alpha, branch: main, commit date: 2023-11-06 10:24, hash: e5327fa5b7c8
Worked: (newest version of Blender that worked as expected)

Short description of error
In Blender v4.1 and newly downloaded 4.2 today has an issue with displaying outline of selected objects. In the overlay tab I have outline selected checked and even wireframe. Both aren't showing.

Exact steps for others to reproduce the error

  • On Blender Preferences > Experimental, enable Overlay Next
  • Selecting any object
**System Information** Operating system: Windows-10-10.0.19044-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3060/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 546.01 **Blender Version** Broken: version: 4.1.0 Alpha, branch: main, commit date: 2023-11-06 10:24, hash: `e5327fa5b7c8` Worked: (newest version of Blender that worked as expected) **Short description of error** In Blender v4.1 and newly downloaded 4.2 today has an issue with displaying outline of selected objects. In the overlay tab I have outline selected checked and even wireframe. Both aren't showing. <video src="/attachments/78ac366d-2d2c-47c5-88cd-a70efad462bf" controls></video> **Exact steps for others to reproduce the error** - On `Blender Preferences` > `Experimental`, enable `Overlay Next` - Selecting any object
Renaldo added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-11-06 17:13:53 +01:00

Thanks for the report, @R3NALDO.

I tested on a similar setup, but I still can't replicate the bug.

**System Information**
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 537.13
version: 4.1.0 Alpha

To better understand the problem, could you please provide some additional information? Here are a few questions:

  • Are you experiencing this issue with all objects in Blender, or only specific ones?
  • Did you double check that the same issue doesn't happen in 3.6?
  • Have you made any recent changes to your system or graphics card drivers?

Possible causes of the problem could include a bug in the software, a compatibility issue with your graphics card, or a misconfiguration in the settings.

Thanks for the report, @R3NALDO. I tested on a similar setup, but I still can't replicate the bug. ``` **System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 537.13 version: 4.1.0 Alpha ``` To better understand the problem, could you please provide some additional information? Here are a few questions: - Are you experiencing this issue with all objects in Blender, or only specific ones? - Did you double check that the same issue doesn't happen in 3.6? - Have you made any recent changes to your system or graphics card drivers? Possible causes of the problem could include a bug in the software, a compatibility issue with your graphics card, or a misconfiguration in the settings.
Germano Cavalcante added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-11-06 19:07:39 +01:00
Author

All objects, All scenes.
I have double clicked and nothing. Even when going into edit mode, I can't see verts, edges or faces. No updates have been made to my graphics card.
Blender 3.6 shows these perfectly but the problem is that my project has been updated to 4.1 now and I can't go back.

All objects, All scenes. I have double clicked and nothing. Even when going into edit mode, I can't see verts, edges or faces. No updates have been made to my graphics card. Blender 3.6 shows these perfectly but the problem is that my project has been updated to 4.1 now and I can't go back.

It may be useful to make a screen recording showing the problem.
And show all the places where this is broken:

  • Mesh Selection in Solid View
  • Mesh Selection in Wireframe VIew
  • Selection of elements in Edit mode
  • Selection of elements in some Paint mode
  • Selection of UVs
  • ...
It may be useful to make a screen recording showing the problem. And show all the places where this is broken: - Mesh Selection in Solid View - Mesh Selection in Wireframe VIew - Selection of elements in Edit mode - Selection of elements in some Paint mode - Selection of UVs - ...
Author

And in my big scene blender crashes when going into wireframe mode.

And in my big scene blender crashes when going into wireframe mode.
Author

Solved it. Overlay next was enabled in the experimental tab and this took the wireframes away!

Solved it. Overlay next was enabled in the experimental tab and this took the wireframes away!
Germano Cavalcante changed title from Outlined selected object not showing to Overlay Next: Outline of selected objects not appearing 2023-11-08 14:31:17 +01:00
Member

Will raise priority here since it is a crasher (so makes Overlay Next unusable atm.)

ERROR (gpu.shader): overlay_armature_sphere_outline FragShader: 
      | 
 1281 |   if (select_info_buf.mode == SELECT_ALL) {
      | 
      | select_lib.glsl:27:0: Error: C1503: undefined variable "select_info_buf"
      | select_lib.glsl:27:0: Error: C1503: undefined variable "SELECT_ALL"
      | 
 1283 |     atomicOr(out_select_buf[id / 32u], 1u << (uint(id) % 32u));
      | 
      | select_lib.glsl:29:0: Error: C1503: undefined variable "out_select_buf"
      | 
 1285 |   else if (select_info_buf.mode == SELECT_PICK_ALL) {
      | 
      | select_lib.glsl:31:0: Error: C1503: undefined variable "select_info_buf"
      | select_lib.glsl:31:0: Error: C1503: undefined variable "SELECT_PICK_ALL"
      | 
 1287 |     atomicMin(out_select_buf[id], floatBitsToUint(gl_FragCoord.z));
      | 
      | select_lib.glsl:33:0: Error: C1503: undefined variable "out_select_buf"
      | 
 1289 |   else if (select_info_buf.mode == SELECT_PICK_NEAREST) {
      | 
      | select_lib.glsl:35:0: Error: C1503: undefined variable "select_info_buf"
      | select_lib.glsl:35:0: Error: C1503: undefined variable "SELECT_PICK_NEAREST"
      | 
 1293 |     ivec2 coord = abs(ivec2(gl_FragCoord.xy) - select_info_buf.cursor);
      | 
      | select_lib.glsl:39:0: Error: C1503: undefined variable "select_info_buf"
      | 
 1301 |       atomicMin(out_select_buf[id], (depth << 8u) | dist);
      | 
      | select_lib.glsl:47:0: Error: C1503: undefined variable "out_select_buf"
      | 
 1318 |   select_id_output(select_id);
      | 
      | overlay_armature_wire_frag.glsl:12:0: Error: C1503: undefined variable "select_id"

ERROR (gpu.shader): overlay_extra VertShader: 
      | 
 1536 |   select_id = id;
      | 
      | select_lib.glsl:15:0: Error: C1503: undefined variable "select_id"
      | 
 1621 |   select_id_set(in_select_buf[gl_InstanceID]);
      | 
      | overlay_extra_vert.glsl:48:0: Error: C1503: undefined variable "in_select_buf"

ERROR (gpu.shader): overlay_extra FragShader: 
      | 
 1503 |   if (select_info_buf.mode == SELECT_ALL) {
      | 
      | select_lib.glsl:27:0: Error: C1503: undefined variable "select_info_buf"
      | select_lib.glsl:27:0: Error: C1503: undefined variable "SELECT_ALL"
      | 
 1505 |     atomicOr(out_select_buf[id / 32u], 1u << (uint(id) % 32u));
      | 
      | select_lib.glsl:29:0: Error: C1503: undefined variable "out_select_buf"
      | 
 1507 |   else if (select_info_buf.mode == SELECT_PICK_ALL) {
      | 
      | select_lib.glsl:31:0: Error: C1503: undefined variable "select_info_buf"
      | select_lib.glsl:31:0: Error: C1503: undefined variable "SELECT_PICK_ALL"
      | 
 1509 |     atomicMin(out_select_buf[id], floatBitsToUint(gl_FragCoord.z));
      | 
      | select_lib.glsl:33:0: Error: C1503: undefined variable "out_select_buf"
      | 
 1511 |   else if (select_info_buf.mode == SELECT_PICK_NEAREST) {
      | 
      | select_lib.glsl:35:0: Error: C1503: undefined variable "select_info_buf"
      | select_lib.glsl:35:0: Error: C1503: undefined variable "SELECT_PICK_NEAREST"
      | 
 1515 |     ivec2 coord = abs(ivec2(gl_FragCoord.xy) - select_info_buf.cursor);
      | 
      | select_lib.glsl:39:0: Error: C1503: undefined variable "select_info_buf"
      | 
 1523 |       atomicMin(out_select_buf[id], (depth << 8u) | dist);
      | 
      | select_lib.glsl:47:0: Error: C1503: undefined variable "out_select_buf"
      | 
 1541 |   select_id_output(select_id);
      | 
      | overlay_extra_frag.glsl:13:0: Error: C1503: undefined variable "select_id"

CC @pragma37

Will raise priority here since it is a crasher (so makes Overlay Next unusable atm.) ``` ERROR (gpu.shader): overlay_armature_sphere_outline FragShader: | 1281 | if (select_info_buf.mode == SELECT_ALL) { | | select_lib.glsl:27:0: Error: C1503: undefined variable "select_info_buf" | select_lib.glsl:27:0: Error: C1503: undefined variable "SELECT_ALL" | 1283 | atomicOr(out_select_buf[id / 32u], 1u << (uint(id) % 32u)); | | select_lib.glsl:29:0: Error: C1503: undefined variable "out_select_buf" | 1285 | else if (select_info_buf.mode == SELECT_PICK_ALL) { | | select_lib.glsl:31:0: Error: C1503: undefined variable "select_info_buf" | select_lib.glsl:31:0: Error: C1503: undefined variable "SELECT_PICK_ALL" | 1287 | atomicMin(out_select_buf[id], floatBitsToUint(gl_FragCoord.z)); | | select_lib.glsl:33:0: Error: C1503: undefined variable "out_select_buf" | 1289 | else if (select_info_buf.mode == SELECT_PICK_NEAREST) { | | select_lib.glsl:35:0: Error: C1503: undefined variable "select_info_buf" | select_lib.glsl:35:0: Error: C1503: undefined variable "SELECT_PICK_NEAREST" | 1293 | ivec2 coord = abs(ivec2(gl_FragCoord.xy) - select_info_buf.cursor); | | select_lib.glsl:39:0: Error: C1503: undefined variable "select_info_buf" | 1301 | atomicMin(out_select_buf[id], (depth << 8u) | dist); | | select_lib.glsl:47:0: Error: C1503: undefined variable "out_select_buf" | 1318 | select_id_output(select_id); | | overlay_armature_wire_frag.glsl:12:0: Error: C1503: undefined variable "select_id" ERROR (gpu.shader): overlay_extra VertShader: | 1536 | select_id = id; | | select_lib.glsl:15:0: Error: C1503: undefined variable "select_id" | 1621 | select_id_set(in_select_buf[gl_InstanceID]); | | overlay_extra_vert.glsl:48:0: Error: C1503: undefined variable "in_select_buf" ERROR (gpu.shader): overlay_extra FragShader: | 1503 | if (select_info_buf.mode == SELECT_ALL) { | | select_lib.glsl:27:0: Error: C1503: undefined variable "select_info_buf" | select_lib.glsl:27:0: Error: C1503: undefined variable "SELECT_ALL" | 1505 | atomicOr(out_select_buf[id / 32u], 1u << (uint(id) % 32u)); | | select_lib.glsl:29:0: Error: C1503: undefined variable "out_select_buf" | 1507 | else if (select_info_buf.mode == SELECT_PICK_ALL) { | | select_lib.glsl:31:0: Error: C1503: undefined variable "select_info_buf" | select_lib.glsl:31:0: Error: C1503: undefined variable "SELECT_PICK_ALL" | 1509 | atomicMin(out_select_buf[id], floatBitsToUint(gl_FragCoord.z)); | | select_lib.glsl:33:0: Error: C1503: undefined variable "out_select_buf" | 1511 | else if (select_info_buf.mode == SELECT_PICK_NEAREST) { | | select_lib.glsl:35:0: Error: C1503: undefined variable "select_info_buf" | select_lib.glsl:35:0: Error: C1503: undefined variable "SELECT_PICK_NEAREST" | 1515 | ivec2 coord = abs(ivec2(gl_FragCoord.xy) - select_info_buf.cursor); | | select_lib.glsl:39:0: Error: C1503: undefined variable "select_info_buf" | 1523 | atomicMin(out_select_buf[id], (depth << 8u) | dist); | | select_lib.glsl:47:0: Error: C1503: undefined variable "out_select_buf" | 1541 | select_id_output(select_id); | | overlay_extra_frag.glsl:13:0: Error: C1503: undefined variable "select_id" ``` CC @pragma37
Philipp Oeser added
Priority
High
and removed
Priority
Normal
labels 2024-02-13 10:59:00 +01:00
Philipp Oeser changed title from Overlay Next: Outline of selected objects not appearing to Overlay Next: Outline of selected objects not appearing, selection crashes 2024-02-13 10:59:35 +01:00
Member

@lichtwerk Overlay Next is an experimental feature that it's not even in active development at the moment.
I don't think it makes sense to raise priority in this case, even if it's a crash.

@lichtwerk Overlay Next is an experimental feature that it's not even in active development at the moment. I don't think it makes sense to raise priority in this case, even if it's a crash.
Member

@lichtwerk Overlay Next is an experimental feature that it's not even in active development at the moment.
I don't think it makes sense to raise priority in this case, even if it's a crash.

Feel free to lower prio again then (I was just going over crash reports -- and since "most" of them deserve it I was raising it here as well)

> @lichtwerk Overlay Next is an experimental feature that it's not even in active development at the moment. > I don't think it makes sense to raise priority in this case, even if it's a crash. Feel free to lower prio again then (I was just going over crash reports -- and since "most" of them deserve it I was raising it here as well)
Miguel Pozo added
Priority
Normal
and removed
Priority
High
labels 2024-02-13 17:02:50 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#114543
No description provided.