New retiming feature completely breaks projects with previously altered timing #114859

Closed
opened 2023-11-14 19:00:03 +01:00 by Riley-Leal · 5 comments

System Information
Operating system: Windows 10
Graphics card: Nvidia RTX 2070 Super

Blender Version
Broken: 4.0
Worked: 3.6.5

Video clips that have been previously retimed have had their timings reset in projects created prior to 4.0, completely breaking existing projects.
Also, it seems that it doesn't adjust the timing for the entire clip. In a broken project, it won't adjust clip length to fit retiming percent. It creates a new retiming key instead and leaves some portion of the clip at seemingly 100% speed, even though it reports it as being some percent lower than that, I am unable to reproduce the latter issue in a fresh project however.

The first file is a clean project, just created in 3.6.5 to demonstrate the retiming issue, the second file is a stripped version of file I discovered the issue on, and demonstrates the retiming issue where it inserts keyframes instead of retiming the entire clip.
 
-Create a video project in a pre-4.0 version of Blender.
-Add a video clip to it, retime it to something other than 1.0
-Open the project in 4.0

**System Information** Operating system: Windows 10 Graphics card: Nvidia RTX 2070 Super **Blender Version** Broken: 4.0 Worked: 3.6.5 Video clips that have been previously retimed have had their timings reset in projects created prior to 4.0, completely breaking existing projects. Also, it seems that it doesn't adjust the timing for the entire clip. In a broken project, it won't adjust clip length to fit retiming percent. It creates a new retiming key instead and leaves some portion of the clip at seemingly 100% speed, even though it reports it as being some percent lower than that, I am unable to reproduce the latter issue in a fresh project however. The first file is a clean project, just created in 3.6.5 to demonstrate the retiming issue, the second file is a stripped version of file I discovered the issue on, and demonstrates the retiming issue where it inserts keyframes instead of retiming the entire clip.   -Create a video project in a pre-4.0 version of Blender. -Add a video clip to it, retime it to something other than 1.0 -Open the project in 4.0
Riley-Leal added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-11-14 19:00:04 +01:00
Member

Hi, thanks for the report. AFAICS, the retimed strip from 3.6 is restored to default (without speed factor) when launched in 4.0.

Did I understand the reported problem correctly? or I missed something?

Hi, thanks for the report. AFAICS, the retimed strip from 3.6 is restored to default (without speed factor) when launched in 4.0. Did I understand the reported problem correctly? or I missed something?
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-12-08 07:00:09 +01:00
Iliya Katushenock added the
Interest
Video Sequencer
Interest
Compatibility
labels 2023-12-08 08:03:55 +01:00
Author

Yes, that is the primary issue, there was also an issue with not being able to retime them properly again after that in my case.

In the project I noticed the problem, I was unable to correct the clips being reset to default timing because the clip would just add a new timing keyframe to the clip without adjusting the length of the clip in the timeline because it would leave some minuscule amount of the clip unaffected.

I was unable to replicate the second issue in a fresh project opened in 4.0 however, that's why I also included the example of the existing project that I brought over. I realize that maybe should be a separate issue and I can open a second bug report if that would be better.

Yes, that is the primary issue, there was also an issue with not being able to retime them properly again after that in my case. In the project I noticed the problem, I was unable to correct the clips being reset to default timing because the clip would just add a new timing keyframe to the clip without adjusting the length of the clip in the timeline because it would leave some minuscule amount of the clip unaffected. I was unable to replicate the second issue in a fresh project opened in 4.0 however, that's why I also included the example of the existing project that I brought over. I realize that maybe should be a separate issue and I can open a second bug report if that would be better.
Pratik Borhade added
Module
VFX & Video
Status
Confirmed
and removed
Status
Needs Information from User
labels 2023-12-15 10:44:05 +01:00
Member

Yes, a separate report would be good.
cc @iss

Yes, a separate report would be good. cc @iss

Eeh sorry about this, somehow I assumed, that I have versioning for simple cases in main already :(
By simple I mean without animation. Also sound strips would be probably a bit tricky, but as long as they aren't animated it's rather simple math so will fix.

Eeh sorry about this, somehow I assumed, that I have versioning for simple cases in main already :( By simple I mean without animation. Also sound strips would be probably a bit tricky, but as long as they aren't animated it's rather simple math so will fix.
Author

ok awesome, thanks for the reply. I'll go ahead and open a separate report for the secondary issue too.

ok awesome, thanks for the reply. I'll go ahead and open a separate report for the secondary issue too.
Richard Antalik added this to the 4.2 LTS milestone 2024-07-02 20:02:04 +02:00
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2024-07-04 23:57:54 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#114859
No description provided.