Regression: Workbench render performance issue #114990

Open
opened 2023-11-16 14:29:34 +01:00 by Ian-Dorow · 12 comments

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: Intel(R) UHD Graphics Intel 4.6.0 - Build 31.0.101.2111

Blender Version
Broken: version: 4.0.0, branch: blender-v4.0-release, commit date: 2023-11-13 17:26, hash: 878f71061b8e
Worked: 3.6.5, branch: blender-v3.6-release, commit date: 2023-10-16 14:30, hash: cf1e1ed46b7e

Short description of error
Render time with Workbench render engine is about 275% of the render time in 3.x version.
It also affects VSE scene strip preview with Solid shading scene strip display.

Exact steps for others to reproduce the error
Start Render Animation with the Workbench render engine selected.

To see a low performance of a scene strip preview in VSE with the attached file:

  1. Switch to Video Editing layout.
  2. Play animation.
**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: Intel(R) UHD Graphics Intel 4.6.0 - Build 31.0.101.2111 **Blender Version** Broken: version: 4.0.0, branch: blender-v4.0-release, commit date: 2023-11-13 17:26, hash: `878f71061b8e` Worked: 3.6.5, branch: blender-v3.6-release, commit date: 2023-10-16 14:30, hash: `cf1e1ed46b7e` **Short description of error** Render time with _Workbench_ render engine is about 275% of the render time in 3.x version. It also affects VSE scene strip preview with _Solid_ shading scene strip display. **Exact steps for others to reproduce the error** Start _Render Animation_ with the _Workbench_ render engine selected. To see a low performance of a scene strip preview in VSE with the attached file: 1. Switch to _Video Editing_ layout. 2. Play animation.
Ian-Dorow added the
Status
Needs Triage
Priority
Normal
Type
Report
labels 2023-11-16 14:29:34 +01:00
Iliya Katushenock added the
Interest
Workbench
label 2023-11-16 18:38:29 +01:00
Iliya Katushenock changed title from Workbench render performance issue to Regression: Workbench render performance issue 2023-11-16 18:38:59 +01:00

Can't reproduce here. Could be HW related.

Can't reproduce here. Could be HW related.
Author

Yes, I have also checked with a different hardware. Drastically decreased performance of the Workbench render does not occur. However, the poor performance for the preview of scene strips in VSE remains but not so severe.

Yes, I have also checked with a different hardware. Drastically decreased performance of the Workbench render does not occur. However, the poor performance for the preview of scene strips in VSE remains but not so severe.

@Ian-Dorow Can you provide playback speeds for 3.6 and 4.x? Also can you clarify previous comment as to what HW (GPU) did you test and what performance regression did you approximately observed?

@Ian-Dorow Can you provide playback speeds for 3.6 and 4.x? Also can you clarify previous comment as to what HW (GPU) did you test and what performance regression did you approximately observed?
Richard Antalik added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-11-24 04:37:32 +01:00
Author

Playback speed for scene strip preview in VSE on Intel UHD Graphics for 10th Gen Intel (Intel i5-1035G1 CPU), Windows-10 64 Bits:
Blender 3.6.5 approximate average fps: 12;
Blender 4.0.1 approximate average fps: 0.49.

Playback speed for scene strip preview in VSE on Intel HD Graphics 5500 (Intel Core i5-5200U CPU), Arch Linux 6.6.1:
Blender 3.6.5 approximate average fps: 17;
Blender 4.0.0 approximate average fps: 6.8.

In the attachments are presented comparison charts between rendering time with Workbench Render for each of the mentioned systems. Also, in the attachments are included *.csv tables with rendering time for each of the versions and the systems.
A file from the attachment in the initial post (Workbench_low_performance_4.0.blend) was used for testing.

Playback speed for scene strip preview in VSE on **Intel UHD Graphics for 10th Gen Intel** (Intel i5-1035G1 CPU), Windows-10 64 Bits: _Blender 3.6.5_ approximate average fps: **12**; _Blender 4.0.1_ approximate average fps: **0.49**. Playback speed for scene strip preview in VSE on **Intel HD Graphics 5500** (Intel Core i5-5200U CPU), Arch Linux 6.6.1: _Blender 3.6.5_ approximate average fps: **17**; _Blender 4.0.0_ approximate average fps: **6.8**. In the attachments are presented comparison charts between rendering time with **Workbench Render** for each of the mentioned systems. Also, in the attachments are included *.csv tables with rendering time for each of the versions and the systems. A file from the attachment in the initial post (_Workbench_low_performance_4.0.blend_) was used for testing.

Sorry, I have missed notification on this report, can you check 4.1 build from https://builder.blender.org/download/daily/? There have been some performance improvements in VSE. Either way, will change status because I can not reproduce this issue.

Sorry, I have missed notification on this report, can you check 4.1 build from https://builder.blender.org/download/daily/? There have been some performance improvements in VSE. Either way, will change status because I can not reproduce this issue.
Richard Antalik added
Status
Needs Triage
and removed
Status
Needs Information from User
labels 2024-01-07 21:22:12 +01:00
Member

Cant spot a performance decrease here

**System Information**
Operating system: Linux-6.6.8-200.fc39.x86_64-x86_64-with-glibc2.38 64 Bits, X11 UI
Graphics card: NVIDIA GeForce RTX 3080 Laptop GPU/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 545.29.06
version: 4.0.1, branch: blender-v4.0-release, commit date: 2023-11-16 16:40, hash: `d0dd92834a08`
Cant spot a performance decrease here ``` **System Information** Operating system: Linux-6.6.8-200.fc39.x86_64-x86_64-with-glibc2.38 64 Bits, X11 UI Graphics card: NVIDIA GeForce RTX 3080 Laptop GPU/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 545.29.06 version: 4.0.1, branch: blender-v4.0-release, commit date: 2023-11-16 16:40, hash: `d0dd92834a08` ```
Author

Sorry, I have missed notification on this report, can you check 4.1 build from https://builder.blender.org/download/daily/? There have been some performance improvements in VSE. Either way, will change status because I can not reproduce this issue.

No, no improvements with 4.1 version.

> Sorry, I have missed notification on this report, can you check 4.1 build from https://builder.blender.org/download/daily/? There have been some performance improvements in VSE. Either way, will change status because I can not reproduce this issue. No, no improvements with 4.1 version.
Miguel Pozo added
Module
EEVEE & Viewport
Status
Confirmed
and removed
Status
Needs Triage
labels 2024-02-06 19:55:59 +01:00
Member

I'm not sure this was caused by the Workbench rewrite.
I've noticed that a new Workbench instance is created every frame, so shaders are being re-compiled every frame (this wasn't the case on the previous Workbench).
I thought the issue of instances being re-created every frame should have been solved by #116199, but this seems to be following a different path were the issue is still present.

Anyway, even after skipping shader recompilation, I still get worse performance in the current version.
But Workbench doesn't seem to be the bottleneck:

 Group                          | GPU  | CPU  | Latency
--------------------------------|------|------|--------
 Total                          | 4.72 | 93.5 |
. SPACE_TOPBAR                  | 32.3 | 0.01 | 0.00
. SPACE_STATUSBAR               | 0.01 | 0.00 | 0.00
. SPACE_ACTION                  | 29.3 | 0.95 | 0.95
.. ARegion                      | 0.00 | 0.95 | 0.95
. SPACE_SEQ                     | 0.00 | 0.00 | 0.00
. SPACE_SEQ                     | 0.24 | 92.0 | 92.0
.. Viewport                     | 0.24 | 92.0 | 92.0
. Window Redraw                 | 0.00 | 0.46 | 0.46

 Group                          | GPU  | CPU  | Latency
--------------------------------|------|------|--------
 Total                          | 32.4 | 9.82 |
. DRW_draw_render_loop_ex       | 32.4 | 10.0 | 10.0
.. Manager.end_sync             | 0.01 | 0.15 | 0.14
.. Workbench                    | 29.5 | 5.08 | 5.08
.. Overlay                      | 2.73 | 0.98 | 0.98
I'm not sure this was caused by the Workbench rewrite. I've noticed that a new Workbench instance is created every frame, so shaders are being re-compiled every frame (this wasn't the case on the previous Workbench). I thought the issue of instances being re-created every frame should have been solved by #116199, but this seems to be following a different path were the issue is still present. Anyway, even after skipping shader recompilation, I still get worse performance in the current version. But Workbench doesn't seem to be the bottleneck: ``` Group | GPU | CPU | Latency --------------------------------|------|------|-------- Total | 4.72 | 93.5 | . SPACE_TOPBAR | 32.3 | 0.01 | 0.00 . SPACE_STATUSBAR | 0.01 | 0.00 | 0.00 . SPACE_ACTION | 29.3 | 0.95 | 0.95 .. ARegion | 0.00 | 0.95 | 0.95 . SPACE_SEQ | 0.00 | 0.00 | 0.00 . SPACE_SEQ | 0.24 | 92.0 | 92.0 .. Viewport | 0.24 | 92.0 | 92.0 . Window Redraw | 0.00 | 0.46 | 0.46 Group | GPU | CPU | Latency --------------------------------|------|------|-------- Total | 32.4 | 9.82 | . DRW_draw_render_loop_ex | 32.4 | 10.0 | 10.0 .. Manager.end_sync | 0.01 | 0.15 | 0.14 .. Workbench | 29.5 | 5.08 | 5.08 .. Overlay | 2.73 | 0.98 | 0.98 ```
Miguel Pozo added the
Interest
Video Sequencer
label 2024-02-07 21:26:20 +01:00
Member

@Ian-Dorow Could you check performance with this build?
#118062 (comment)/

I get pretty much identical performance to 3.6 on an AMD iGPU for animation renders, but VSE is still slower.

@Ian-Dorow Could you check performance with this build? https://projects.blender.org/blender/blender/pulls/118062#issuecomment-1121484/ I get pretty much identical performance to 3.6 on an AMD iGPU for animation renders, but VSE is still slower.
Author

@pragma37 Unfortunately, I can not find PR118062 variant of a build available for download, not via link provided nor into All Patches or All Archived Builds sections.

@pragma37 Unfortunately, I can not find **PR118062** variant of a build available for download, not via link provided nor into _All Patches_ or _All Archived Builds_ sections.
Member

Oops! It looks like there were issues with the build-bot yesterday.
This one works: https://builder.blender.org/download/patch/PR118062/

Oops! It looks like there were issues with the build-bot yesterday. This one works: https://builder.blender.org/download/patch/PR118062/
Author

Can confirm that with build PR118062 the issue is gone in the Workbench render. VSE preview seems to be slower than in 3.6 but drastically better than with reported version.
I have about 14-18 fps with 3.6 and about 10 fps with PR118062. Without the fix VSE preview is about 0.36-0.4 fps with 4.x.

Can confirm that with build **PR118062** the issue is gone in the Workbench render. VSE preview seems to be slower than in **3.6** but drastically better than with reported version. I have about 14-18 fps with **3.6** and about 10 fps with **PR118062**. Without the fix VSE preview is about 0.36-0.4 fps with **4.x**.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#114990
No description provided.