Workbench Shadow of Entire Scene #115550

Open
opened 2023-11-29 00:46:40 +01:00 by philovivero · 5 comments

System Information
Operating system: macOS-13.6-arm64-arm-64bit 64 Bits
Graphics card: Metal API Apple M2 Ultra 1.2

Blender Version
Broken: version: 4.0.1, branch: blender-v4.0-release, commit date: 2023-11-16 16:40, hash: d0dd92834a08
Worked: 3.6

Short description of error
View scene in workbench render with shadow. The entire scene's shadow is projected into the scene in miniature.

Exact steps for others to reproduce the error
attached .blend file (as simple as possible)

In the attached .blend, switch the leftmost pane to rendered mode. The weird grey/black blotch in the middle is the shadow of the entire scene projected into the scene. If there are other objects casting shadows, this will cause inversion of those shadows.

**System Information** Operating system: macOS-13.6-arm64-arm-64bit 64 Bits Graphics card: Metal API Apple M2 Ultra 1.2 **Blender Version** Broken: version: 4.0.1, branch: blender-v4.0-release, commit date: 2023-11-16 16:40, hash: `d0dd92834a08` Worked: 3.6 **Short description of error** View scene in workbench render with shadow. The entire scene's shadow is projected into the scene in miniature. <video src="/attachments/1fe5cc4a-aeb4-4e9f-ab7a-0761154705d5" controls></video> **Exact steps for others to reproduce the error** attached .blend file (as simple as possible) In the attached .blend, switch the leftmost pane to rendered mode. The weird grey/black blotch in the middle is the shadow of the entire scene projected into the scene. If there are other objects casting shadows, this will cause inversion of those shadows.
philovivero added the
Priority
Normal
Status
Needs Triage
Type
Report
labels 2023-11-29 00:46:40 +01:00
Iliya Katushenock added the
Interest
Workbench
label 2023-11-29 14:32:55 +01:00

Thank you for reporting the issue, @philovivero.

I'm not sure if I understand the issue completely. It seems that in rendered mode, the scene appears darker, possibly due to color management adjustments that only affect the rendered view.
To better understand your issue, could you please provide more details about the specific behavior you are encountering?
Any additional information you can provide would be helpful in diagnosing the problem.

I also noticed an assert when opening the file in a Debug build. It appears that the UI is corrupted in some way.

BLI_assert failed: D:\BlenderDev\blender\source\blender\editors\screen\area.cc:1249, region_overlap_fix(), at 'align1 == ((align1) & ((1 << 4) - 1))'
Thank you for reporting the issue, @philovivero. I'm not sure if I understand the issue completely. It seems that in rendered mode, the scene appears darker, possibly due to color management adjustments that only affect the rendered view. To better understand your issue, could you please provide more details about the specific behavior you are encountering? Any additional information you can provide would be helpful in diagnosing the problem. I also noticed an assert when opening the file in a Debug build. It appears that the UI is corrupted in some way. ``` BLI_assert failed: D:\BlenderDev\blender\source\blender\editors\screen\area.cc:1249, region_overlap_fix(), at 'align1 == ((align1) & ((1 << 4) - 1))' ```
Germano Cavalcante added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-11-29 19:08:43 +01:00
Author

You don't see something like this?

You don't see something like this?
Author

As to the assert, I cannot tell what that means... which part of the UI should I look at to see if it's broken? Maybe something is broken that I never use, and so I haven't noticed it.

As to the assert, I cannot tell what that means... which part of the UI should I look at to see if it's broken? Maybe something is broken that I never use, and so I haven't noticed it.

This issue appears to be specific to Mac or Metal.
I'll test this on a Mac later to investigate further.

This issue appears to be specific to Mac or Metal. I'll test this on a Mac later to investigate further.
Member

Unable to confirm either on Windows

Unable to confirm either on Windows
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#115550
No description provided.