Regression: Problems with adding keys #115789

Closed
opened 2023-12-05 11:04:38 +01:00 by Steffen Dünner · 10 comments

System Information
Operating system: Linux-6.2.0-37-generic-x86_64-with-glibc2.35 64 Bits, X11 UI
Graphics card: NVIDIA GeForce RTX 2070 Super/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 535.129.03

Blender Version
Broken: version: 4.1.0 Alpha, branch: main, commit date: 2023-12-05 08:17, hash: 689040db2f77
Worked: 4.0.1 Release

Short description of error
Adding keys by pressing "i" is not behaving as before. Also adding keys in the Graph Editor is acting weird.

Exact steps for others to reproduce the error

  • Open Blender, add a cube (or use the default cube or any other animatable object) and select it
  • Press "i" to add a keyframe. What should happen:
    image
    Now there is no dialogue any more. A key is added to all SRT channels.
  • Now press "i" again. The same dialogue as above should appear again. But now this error message appears instead:
    image

The other (very likely related) problem is in the Graph Editor:

  • Continue with the Blender session from above. The Graph Editor shows the added keys.
  • Now move the Timeline Cursor to another frame and press "i". This dialogue appears:
    image
  • In 4.0.1 and before every single option worked. Now in 4.1 Alpha (main) the first 3 options don't do anything, no key is added. Only the last 2 ("Active Channel at Cursor" and "Selected Channel at Cursor") do actually add keys.
**System Information** Operating system: Linux-6.2.0-37-generic-x86_64-with-glibc2.35 64 Bits, X11 UI Graphics card: NVIDIA GeForce RTX 2070 Super/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 535.129.03 **Blender Version** Broken: version: 4.1.0 Alpha, branch: main, commit date: 2023-12-05 08:17, hash: `689040db2f77` Worked: 4.0.1 Release **Short description of error** Adding keys by pressing "i" is not behaving as before. Also adding keys in the Graph Editor is acting weird. **Exact steps for others to reproduce the error** - Open Blender, add a cube (or use the default cube or any other animatable object) and select it - Press "i" to add a keyframe. What should happen: ![image](/attachments/08c1ac22-ce58-4499-9842-33b32e45d7e0) Now there is no dialogue any more. A key is added to all SRT channels. - Now press "i" again. The same dialogue as above should appear again. But now this error message appears instead: ![image](/attachments/8d7f501f-3a91-4ad8-a09d-d3f86ef3d6c1) The other (very likely related) problem is in the Graph Editor: - Continue with the Blender session from above. The Graph Editor shows the added keys. - Now move the Timeline Cursor to another frame and press "i". This dialogue appears: ![image](/attachments/605e8058-ed1b-4a39-8b08-bff53e1f6d79) - In 4.0.1 and before every single option worked. Now in 4.1 Alpha (main) the first 3 options don't do anything, no key is added. Only the last 2 ("Active Channel at Cursor" and "Selected Channel at Cursor") do actually add keys.
Steffen Dünner added the
Status
Needs Triage
Priority
Normal
Type
Report
labels 2023-12-05 11:04:38 +01:00
Member

Hi, pasting my comment from #115436 (comment):
Behavior changed in a99e419b6e
Now pressing I key will add keyframes to selected keying set. If nothing is selected in keying set, userpref will be used to add keyframe.
Older panel can still be invoked by RMB/context menu > insert keyframe with keying set (when keying set is not selected)

Hi, pasting my comment from https://projects.blender.org/blender/blender/issues/115436#issuecomment-1077709: Behavior changed in a99e419b6e841d673a3542c372d5faec82c0d138 Now pressing `I` key will add keyframes to selected keying set. If nothing is selected in keying set, userpref will be used to add keyframe. Older panel can still be invoked by `RMB/context menu > insert keyframe with keying set` (when keying set is not selected)

OMG, sorry. Didn't know this was a new feature. Sorry for the noise.

EDIT: OK, I can totally live with having to select a Keying Set before adding a key with the "i" key (or just add keys to the channels selected in the Preferences). Will take a while to get used to but OK.

But adding keys in the Graph Editor is still being very weird now, as all of what I wrote above is still true there. No matter what Keying Set I select, the 3 first options in the dialogue don't add any keys. Or did I miss something there as well?

OMG, sorry. Didn't know this was a new feature. Sorry for the noise. EDIT: OK, I can totally live with having to select a Keying Set before adding a key with the "i" key (or just add keys to the channels selected in the Preferences). Will take a while to get used to but OK. But adding keys in the Graph Editor is still being very weird now, as all of what I wrote above is still true there. No matter what Keying Set I select, the 3 first options in the dialogue don't add any keys. Or did I miss something there as well?
Member

No problem, closing 🙂

No problem, closing 🙂
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-12-05 12:03:21 +01:00
Member

Oh, did not notice the post you edited, reopening (Also: I haven't checked the "graph editor" part yet)

Oh, did not notice the post you edited, reopening (Also: I haven't checked the "graph editor" part yet)
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2023-12-05 12:04:48 +01:00
Member

But adding keys in the Graph Editor is still being very weird now, as all of what I wrote above is still true there. No matter what Keying Set I select, the 3 first options in the dialogue don't add any keys. Or did I miss something there as well?

Cant replicate in current main

> But adding keys in the Graph Editor is still being very weird now, as all of what I wrote above is still true there. No matter what Keying Set I select, the 3 first options in the dialogue don't add any keys. Or did I miss something there as well? Cant replicate in current main

Oh, did not notice the post you edited, reopening (Also: I haven't checked the "graph editor" part yet)

Thanks a lot. I guess the whole topic of keying etc. is under heavy construction right now.

> Oh, did not notice the post you edited, reopening (Also: I haven't checked the "graph editor" part yet) Thanks a lot. I guess the whole topic of keying etc. is under heavy construction right now.

But adding keys in the Graph Editor is still being very weird now, as all of what I wrote above is still true there. No matter what Keying Set I select, the 3 first options in the dialogue don't add any keys. Or did I miss something there as well?

Cant replicate in current main

OK, I can add keys in the Graph Editor now after trying "--factory-startup" but not with my current user config. Trying to find the problem now.
When trying to add a key in the Graph Editor with my config I'm getting this:

Error: Failed to insert keys on F-Curve with path 'location[0]', ensure that it is not locked or sampled, and try removing F-Modifiers
Error: Failed to insert keys on F-Curve with path 'location[1]', ensure that it is not locked or sampled, and try removing F-Modifiers
Error: Failed to insert keys on F-Curve with path 'location[2]', ensure that it is not locked or sampled, and try removing F-Modifiers
Error: Failed to insert keys on F-Curve with path 'rotation_euler[0]', ensure that it is not locked or sampled, and try removing F-Modifiers
Error: Failed to insert keys on F-Curve with path 'rotation_euler[1]', ensure that it is not locked or sampled, and try removing F-Modifiers
Error: Failed to insert keys on F-Curve with path 'rotation_euler[2]', ensure that it is not locked or sampled, and try removing F-Modifiers
Error: Failed to insert keys on F-Curve with path 'scale[0]', ensure that it is not locked or sampled, and try removing F-Modifiers
Error: Failed to insert keys on F-Curve with path 'scale[1]', ensure that it is not locked or sampled, and try removing F-Modifiers
Error: Failed to insert keys on F-Curve with path 'scale[2]', ensure that it is not locked or sampled, and try removing F-Modifiers

The curves are not locked or sampled and there is no Fcurve-Modifier on them.

EDIT: I had "Only Insert Needed" active in my prefs. By toggling it to off, keying now works in the Graph Editor. Strange though because if I manually add keys, they should be "needed", right?

> > But adding keys in the Graph Editor is still being very weird now, as all of what I wrote above is still true there. No matter what Keying Set I select, the 3 first options in the dialogue don't add any keys. Or did I miss something there as well? > > Cant replicate in current main OK, I can add keys in the Graph Editor now after trying "--factory-startup" but not with my current user config. Trying to find the problem now. When trying to add a key in the Graph Editor with my config I'm getting this: ``` Error: Failed to insert keys on F-Curve with path 'location[0]', ensure that it is not locked or sampled, and try removing F-Modifiers Error: Failed to insert keys on F-Curve with path 'location[1]', ensure that it is not locked or sampled, and try removing F-Modifiers Error: Failed to insert keys on F-Curve with path 'location[2]', ensure that it is not locked or sampled, and try removing F-Modifiers Error: Failed to insert keys on F-Curve with path 'rotation_euler[0]', ensure that it is not locked or sampled, and try removing F-Modifiers Error: Failed to insert keys on F-Curve with path 'rotation_euler[1]', ensure that it is not locked or sampled, and try removing F-Modifiers Error: Failed to insert keys on F-Curve with path 'rotation_euler[2]', ensure that it is not locked or sampled, and try removing F-Modifiers Error: Failed to insert keys on F-Curve with path 'scale[0]', ensure that it is not locked or sampled, and try removing F-Modifiers Error: Failed to insert keys on F-Curve with path 'scale[1]', ensure that it is not locked or sampled, and try removing F-Modifiers Error: Failed to insert keys on F-Curve with path 'scale[2]', ensure that it is not locked or sampled, and try removing F-Modifiers ``` The curves are not locked or sampled and there is no Fcurve-Modifier on them. EDIT: I had "Only Insert Needed" active in my prefs. By toggling it to off, keying now works in the Graph Editor. Strange though because if I manually add keys, they should be "needed", right?
Member

Yes, can confirm keyframes are not added with that preference

Yes, can confirm keyframes are not added with that preference
Member

The working of Only Insert Needed has been changed in 83287624bc
Current behavior is now expected as described in code comment and commit description: No need to insert a key if the same value is already the value of the FCurve at that point.
But this is failing silently without user knowing about it, also an undo step is created even after the operation is skipped.
cc @ChrisLend

The working of `Only Insert Needed` has been changed in 83287624bc5d4c1e9ee52c8e794e0bdc166b058a Current behavior is now expected as described in code comment and commit description: `No need to insert a key if the same value is already the value of the FCurve at that point.` But this is failing silently without user knowing about it, also an undo step is created even after the operation is skipped. cc @ChrisLend

This will change soon, but the patches need to go through review first
#115525: WIP: Anim: Separate keying flags
#115522: Anim: Don't use keying sets when inserting keyframes during autokeying

basically the "Insert Only Needed" option also applies to normal keyframing (it has done so since forever) so we need to split it into auto- and manual keyframing.

As such this isn't a bug

This will change soon, but the patches need to go through review first [#115525: WIP: Anim: Separate keying flags](https://projects.blender.org/blender/blender/pulls/115525) [#115522: Anim: Don't use keying sets when inserting keyframes during autokeying](https://projects.blender.org/blender/blender/pulls/115522) basically the "Insert Only Needed" option also applies to normal keyframing (it has done so since forever) so we need to split it into auto- and manual keyframing. As such this isn't a bug
Blender Bot added
Status
Archived
and removed
Status
Needs Info from Developers
labels 2023-12-07 09:38:17 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#115789
No description provided.