Snow rig (cloudrig / rigify) from Blender Studio gets deformed after linking ► library override ► reopen file #115917

Closed
opened 2023-12-07 22:31:36 +01:00 by Loïc DAUTRY · 1 comment

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 4090/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 531.79

Blender Version
Broken: version: 4.0.1, branch: blender-v4.0-release, commit date: 2023-11-16 16:40, hash: d0dd92834a08
Issue was first noticed on Blender 3.1.2 and tried again on 3.2.0
Worked: None found yet

Short description of error
I reported this issue on the rig page: Snow - Character Rig - Blender Studio, but I was redirected here (sorry for the ridiculous delay).

After linking that rig made from cloudrig/rigify, creating a library override, saving and reloading the file, the rig receives weird deformation on the eyebrows and face geometry that aren't there in the original asset file nor when linking it into the file:

image

Exact steps for others to reproduce the error

  1. Download the original rig and link it in a new clean scene (doing it from either File ► Link menu or the asset browser gives the same result)
  2. In the outliner: RMB RMB ► Library Override ► Make ► Selected & Content
  3. Save the file
  4. Menu File ► Revert

Or open my demo file with the linked rig packed inside:

Snow_library_override_BUG.blend

I don't get any errors in the system console, and according to the comments on my first report, the issue isn't always perceived from one person to the other. I don't know whether it's an issue in the rig or in Blender.

**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 4090/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 531.79 **Blender Version** Broken: version: 4.0.1, branch: blender-v4.0-release, commit date: 2023-11-16 16:40, hash: `d0dd92834a08` Issue was first noticed on Blender 3.1.2 and tried again on 3.2.0 Worked: None found yet **Short description of error** I reported this issue on the rig page: [Snow - Character Rig - Blender Studio](https://studio.blender.org/characters/snow/v2/#comment-10820), but I was redirected here (sorry for the ridiculous delay). After linking that rig made from cloudrig/rigify, creating a library override, saving and reloading the file, the rig receives weird deformation on the eyebrows and face geometry that aren't there in the original asset file nor when linking it into the file: ![image](/attachments/5e7d6866-457c-4e9d-a0e4-c3db8ab0be1b) **Exact steps for others to reproduce the error** 1. [Download the original rig](https://studio.blender.org/characters/snow/v2/) and link it in a new clean scene (doing it from either File ► Link menu or the asset browser gives the same result) 2. In the outliner: <kbd>![RMB][RMB] RMB</kbd> ► Library Override ► Make ► Selected & Content 3. Save the file 4. Menu File ► Revert Or open my demo file with the linked rig packed inside: [Snow_library_override_BUG.blend](/attachments/07dbc6c0-0ab3-4e06-8703-aa80a4a2396c) I don't get any errors in the system console, and according to the [comments on my first report](https://studio.blender.org/characters/snow/v2/#comment-10820), the issue isn't always perceived from one person to the other. I don't know whether it's an issue in the rig or in Blender. [RMB]: http://i.stack.imgur.com/LPwD4.png (Right Mouse Button)
Loïc DAUTRY added the
Priority
Normal
Status
Needs Triage
Type
Report
labels 2023-12-07 22:31:37 +01:00
Member

Hi, we already have a report for this: #108581, closing.

Hi, we already have a report for this: #108581, closing.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-12-08 04:55:23 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#115917
No description provided.