Regression: Rotate and Scale gizmo is always active when Rotation and Scale are locked #116666

Open
opened 2023-12-31 04:14:41 +01:00 by Riccardo Gagliarducci · 4 comments

System Information
Operating system: Linux-6.1.0-15-amd64-x86_64-with-glibc2.36 64 Bits, X11 UI (tested also in Windows 11)
Graphics card: Mesa Intel(R) UHD Graphics 630 (CFL GT2) Intel 4.6 (Core Profile) Mesa 22.3.6

Blender Version
Broken: version: 4.0.0, branch: blender-v4.0-release, commit date: 2023-11-13 17:26, hash: 878f71061b8e
Broken: version: 3.0.1, branch: master, commit date: 2022-01-25 17:19, hash: rBdc2d18018171
Worked: version: 2.9 series (2.93.9 and lower)

Short description of error
The rotation and scale lock does not have the same effect on the gizmo as the move lock.
Movement gizmos clearly highlight the axes on which a move can be made and take into account the transform lock.
In contrast, all axes in the rotation and scaling gizmo are always active, regardless of the state of the locks.

Exact steps for others to reproduce the error
Attached is a video highlighting the difference between version 2.9 (all 2.x series) where the gizmo UI correctly reflected the state of the locks and version 4.0.2 (from 3.x and up) where this does not happen.
The video also highlights a small case study in which this feature is used for greater clarity.

Thank you,
Riccardo

**System Information** Operating system: Linux-6.1.0-15-amd64-x86_64-with-glibc2.36 64 Bits, X11 UI (tested also in Windows 11) Graphics card: Mesa Intel(R) UHD Graphics 630 (CFL GT2) Intel 4.6 (Core Profile) Mesa 22.3.6 **Blender Version** Broken: version: 4.0.0, branch: blender-v4.0-release, commit date: 2023-11-13 17:26, hash: `878f71061b8e` Broken: version: 3.0.1, branch: master, commit date: 2022-01-25 17:19, hash: `rBdc2d18018171` Worked: version: 2.9 series (2.93.9 and lower) **Short description of error** The _rotation_ and _scale_ lock does not have the same effect on the gizmo as the move lock. Movement gizmos clearly highlight the axes on which a move can be made and take into account the transform lock. In contrast, all axes in the rotation and scaling gizmo are always active, regardless of the state of the locks. **Exact steps for others to reproduce the error** Attached is a video highlighting the difference between version 2.9 (all 2.x series) where the gizmo UI correctly reflected the state of the locks and version 4.0.2 (from 3.x and up) where this does not happen. The video also highlights a small case study in which this feature is used for greater clarity. Thank you, Riccardo
Riccardo Gagliarducci added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-12-31 04:14:42 +01:00
Iliya Katushenock added the
Interest
Modeling
Interest
Overlay
labels 2023-12-31 08:16:24 +01:00
Iliya Katushenock changed title from Rotate and Scale gizmo is always active when Rotation and Scale are locked to Regression: Rotate and Scale gizmo is always active when Rotation and Scale are locked 2023-12-31 08:16:31 +01:00

Confirmed broken since 3.0 actually.

Confirmed broken since 3.0 actually.
Jesse Yurkovich added
Module
User Interface
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-12-31 21:54:04 +01:00
Member

Can be fixed by (not sure why protectflag is restricted for location only, checking):

diff --git a/source/blender/editors/transform/transform_gizmo_3d.cc b/source/blender/editors/transform/transform_gizmo_3d.cc
index 65e53c6af3d..af57a87e5eb 100644
--- a/source/blender/editors/transform/transform_gizmo_3d.cc
+++ b/source/blender/editors/transform/transform_gizmo_3d.cc
@@ -955,7 +955,7 @@ static int gizmo_3d_foreach_selected(const bContext *C,
           /* Protect-flags apply to world space in object mode,
            * so only let them influence axis visibility if we show the global orientation,
            * otherwise it's confusing. */
-          protectflag_to_drawflags(base->object->protectflag & OB_LOCK_LOC, r_drawflags);
+          protectflag_to_drawflags(base->object->protectflag, r_drawflags);
         }
         else if (ELEM(orient_index, V3D_ORIENT_LOCAL, V3D_ORIENT_GIMBAL)) {
           protectflag_to_drawflags(base->object->protectflag, r_drawflags);
Can be fixed by (not sure why protectflag is restricted for location only, checking): ```Diff diff --git a/source/blender/editors/transform/transform_gizmo_3d.cc b/source/blender/editors/transform/transform_gizmo_3d.cc index 65e53c6af3d..af57a87e5eb 100644 --- a/source/blender/editors/transform/transform_gizmo_3d.cc +++ b/source/blender/editors/transform/transform_gizmo_3d.cc @@ -955,7 +955,7 @@ static int gizmo_3d_foreach_selected(const bContext *C, /* Protect-flags apply to world space in object mode, * so only let them influence axis visibility if we show the global orientation, * otherwise it's confusing. */ - protectflag_to_drawflags(base->object->protectflag & OB_LOCK_LOC, r_drawflags); + protectflag_to_drawflags(base->object->protectflag, r_drawflags); } else if (ELEM(orient_index, V3D_ORIENT_LOCAL, V3D_ORIENT_GIMBAL)) { protectflag_to_drawflags(base->object->protectflag, r_drawflags); ```
Member

This was done intentionally in 5f7d5c0809
Not a bug but I would prefer to operate those lock flags (scale/loc/rot) on global axis as well.
cc @ideasman42

This was done intentionally in 5f7d5c0809104bf702dff4be1b706c6841095fda Not a bug but I would prefer to operate those lock flags (scale/loc/rot) on global axis as well. cc @ideasman42

Not a bug but I would prefer to operate those lock flags (scale/loc/rot) on global axis as well.

I, too, would prefer it to be on the local axes as well (transforms indicate global values).

It is not clear to me why:

  • for the location the behavior is different
  • in which use case it makes sense

Thank you,
Riccardo

> Not a bug but I would prefer to operate those lock flags (scale/loc/rot) on global axis as well. I, too, would prefer it to be on the local axes as well (transforms indicate global values). It is not clear to me why: - for the location the behavior is different - in which use case it makes sense Thank you, Riccardo
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#116666
No description provided.