Copy/Paste objects Buffer does not respect "Duplicate Data" (Material, Mesh, ...) preference #116881

Closed
opened 2024-01-08 09:07:11 +01:00 by Kiellog · 10 comments

System Information
Operating system: Linux-6.6.10-arch1-1-x86_64-with-glibc2.38 64 Bits, X11 UI
Graphics card: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 545.29.06

Blender Version
Broken: version: 4.0.2, branch: makepkg (modified), commit date: 2023-12-05 07:41, hash: 9be62e85b727
Worked: Never?

Short description of error
Duplicating objects using the copy-paste buffer, the Copy on Duplicate Material preference is ignored, and a duplicate is always created.
Note: Paste-buffer does not update the UI, so some deselection/selection is required for the UI to show the actual material.

Exact steps for others to reproduce the error

  1. Have Copy on Duplicate Material set to OFF.
  2. Copy object with Copy Buffer.
  3. Paste object with Paste Buffer.
    (4) (Make sure the UI is updated, deselect, select object)

Video included

**System Information** Operating system: Linux-6.6.10-arch1-1-x86_64-with-glibc2.38 64 Bits, X11 UI Graphics card: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 545.29.06 **Blender Version** Broken: version: 4.0.2, branch: makepkg (modified), commit date: 2023-12-05 07:41, hash: `9be62e85b727` Worked: Never? **Short description of error** Duplicating objects using the copy-paste buffer, the Copy on Duplicate Material preference is ignored, and a duplicate is always created. Note: Paste-buffer does not update the UI, so some deselection/selection is required for the UI to show the actual material. **Exact steps for others to reproduce the error** 1. Have Copy on Duplicate Material set to OFF. 2. Copy object with Copy Buffer. 3. Paste object with Paste Buffer. (4) (Make sure the UI is updated, deselect, select object) Video included
Kiellog added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2024-01-08 09:07:12 +01:00

Thanks for report, but this is misunderstanding. This settings mean that material will be duplicated and assigned to copy, or original material will be there. This is not about create copy without materials. And as i can see of your video, everything is works correct.
image

Thanks for report, but this is misunderstanding. This settings mean that material will be duplicated and assigned to copy, or original material will be there. This is not about `create copy without materials`. And as i can see of your video, everything is works correct. ![image](/attachments/a0d97787-12e1-468f-8732-c79f265aa68f)
9.4 KiB
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2024-01-08 09:42:43 +01:00
Author

OK, but:
"or original material will be there"
does not apply. Regardless of ON or OFF, a duplicate material will be created (.001, .002 etc) . The Paste Buffer ignores ANY setting on Copy on Duplicate Material preference?
( I would love if the original material was there if OFF)

OK, but: "or original material will be there" does not apply. Regardless of ON or OFF, a duplicate material will be created (.001, .002 etc) . The Paste Buffer ignores ANY setting on Copy on Duplicate Material preference? ( I would love if the original material was there if OFF)
Kiellog reopened this issue 2024-01-08 09:48:37 +01:00
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2024-01-08 09:48:39 +01:00
Member

Thanks for report, but this is misunderstanding. This settings mean that material will be duplicated and assigned to copy, or original material will be there. This is not about create copy without materials. And as i can see of your video, everything is works correct.
image

Em, the material is duplicated despite the Preference, it is not the original material on the duplicate.
Think this is a legit report, not sure what you were seeing in the video @mod_moder ?

> Thanks for report, but this is misunderstanding. This settings mean that material will be duplicated and assigned to copy, or original material will be there. This is not about `create copy without materials`. And as i can see of your video, everything is works correct. > ![image](/attachments/a0d97787-12e1-468f-8732-c79f265aa68f) Em, the material is duplicated despite the Preference, it is not the original material on the duplicate. Think this is a legit report, not sure what you were seeing in the video @mod_moder ?

Ah, sorry, misunderstand mean of report. Well, now i can not confirm your issue. Can you check latest 4.0 blender from https://builder.blender.org/download/daily/?

Ah, sorry, misunderstand mean of report. Well, now i can not confirm your issue. Can you check latest 4.0 blender from https://builder.blender.org/download/daily/?
Member

This might not be how the Copy/Paste functionality was designed, but I think it should actually respect those settings (even if they are meant for the Duplicate operator)

This might not be how the Copy/Paste functionality was designed, but I think it should actually respect those settings (even if they are meant for the `Duplicate` operator)

Latest 4.0 and factory settings:

Latest 4.0 and factory settings:
Iliya Katushenock added
Module
User Interface
Status
Confirmed
and removed
Status
Needs Triage
labels 2024-01-08 10:03:11 +01:00

I can confirm, issue in Copy Objects operator in menu.

I can confirm, issue in `Copy Objects` operator in menu.
Author

yup! (same issue)
(note the UI update thing)

ed: oops, did I post while tags were being changed/accidentally close the issue? sorry for the reopen if not wanted!

yup! (same issue) (note the UI update thing) ed: oops, did I post while tags were being changed/accidentally close the issue? sorry for the reopen if not wanted!
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2024-01-08 10:04:47 +01:00
Kiellog reopened this issue 2024-01-08 10:04:57 +01:00
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2024-01-08 10:05:00 +01:00
Iliya Katushenock added
Status
Confirmed
and removed
Status
Needs Triage
labels 2024-01-08 10:07:33 +01:00
Member

Well, since copy/paste is more like save (at a tmp place), then append back, these preferences dont actually act on this.
Conceptually they probably should, but atm. they are not meant to be used here.

My second thought vote would be to close this as an accidental feature request, but will leave up to @mont29 to decide.

Well, since copy/paste is more like save (at a tmp place), then append back, these preferences dont actually act on this. Conceptually they probably should, but atm. they are not meant to be used here. My second thought vote would be to close this as an accidental feature request, but will leave up to @mont29 to decide.
Philipp Oeser changed title from Paste Buffer does not respect Copy on Duplicate Material preference to Copy/Paste objects Buffer does not respect "Duplicate Data" (Material, Mesh, ...) preference 2024-01-08 10:14:55 +01:00

The TL;DR: Would be that current copy-paste is very old code, and could be improved in many, many ways. Part of it may be addressed by the improved 'append & reuse' at some point this year, but the whole feature would need a complete check-up.

So for the time being, would indeed consider that current behavior is as expected from a code side. Will open a generic 'Update Copy/Paste' design task though, to keep track of the topic: #116890

The TL;DR: Would be that current copy-paste is very old code, and could be improved in many, many ways. Part of it _may_ be addressed by the improved 'append & reuse' at some point this year, but the whole feature would need a complete check-up. So for the time being, would indeed consider that current behavior is as expected from a code side. Will open a generic 'Update Copy/Paste' design task though, to keep track of the topic: #116890
Blender Bot added
Status
Archived
and removed
Status
Needs Info from Developers
labels 2024-01-08 13:30:22 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#116881
No description provided.