Render region ruins compositing for image input #118156

Closed
opened 2024-02-12 20:22:52 +01:00 by Lord Odin · 7 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 546.17

Blender Version
Broken: version: 4.0.1, branch: blender-v4.0-release, commit date: 2023-11-16 16:40, hash: d0dd92834a08

Short description of error
Doing a border render with compositing does not behave correctly in the Render Result window or when saving to disk during render animation, however it is correct when you save the render with a File Output node or look at it through the Viewer node.

Exact steps for others to reproduce the error
Add an image to the compositor with a scale node after it, do a border render of the default cube.

https://youtu.be/THAseqq04Ck

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 546.17 **Blender Version** Broken: version: 4.0.1, branch: blender-v4.0-release, commit date: 2023-11-16 16:40, hash: `d0dd92834a08` **Short description of error** Doing a border render with compositing does not behave correctly in the Render Result window or when saving to disk during render animation, however it is correct when you save the render with a File Output node or look at it through the Viewer node. **Exact steps for others to reproduce the error** Add an image to the compositor with a scale node after it, do a border render of the default cube. https://youtu.be/THAseqq04Ck
240 KiB
Lord Odin added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2024-02-12 20:22:52 +01:00
Member

Thanks for the report. I can confirm.
cc @OmarEmaraDev

Thanks for the report. I can confirm. cc @OmarEmaraDev
Pratik Borhade added
Module
VFX & Video
Status
Confirmed
Interest
Compositing
and removed
Status
Needs Triage
labels 2024-02-13 06:30:27 +01:00
Pratik Borhade changed title from Render border ruins compositing to Render region ruins compositing for image input 2024-02-13 06:30:59 +01:00
Member

This is the expected behavior as far as I can see. The compositor is part of the render pipeline, and the border option affects the entire pipeline. What do you expect to happen?

This is the expected behavior as far as I can see. The compositor is part of the render pipeline, and the border option affects the entire pipeline. What do you expect to happen?
Author

If that is your argument, why isn’t it the same behavior for the viewer node or the file output node. I’m just supposed to know the result I see won’t be the one saved to disk? Why would the render result and the file output node ever be different unless directly instructed to do so?

The expected behavior would be that the render border does not crop composited elements unless specified to do so, it’s called post processing for a reason. If I’m done rendering. Why can’t I add a background to it in post? It’s a silly problem to have in the first place.

Border render provides significant speed gains for rendering and denoising. So much so that render times can be halved or even more… Which means the render budget can be halved.

By default a frame does not crop to the border size, it expands it to the full frame size. Why isn’t there an option to do compositing on the full frame? Default behavior might be the expected behavior in some very specific pipelines but it’s not expected in mine. In my 10+ years of VFX I have never exported cropped renders WITH compositing. We save that for software that can actually do the job.

An option to have both cropped and full frame compositing would make the compositor massively more useful, solve this specific issue and an absolute mountain of other issues since this functionality can effects the vse as well.

If that is your argument, why isn’t it the same behavior for the viewer node or the file output node. I’m just supposed to know the result I see won’t be the one saved to disk? Why would the render result and the file output node ever be different unless directly instructed to do so? The expected behavior would be that the render border does not crop composited elements unless specified to do so, it’s called post processing for a reason. If I’m done rendering. Why can’t I add a background to it in post? It’s a silly problem to have in the first place. Border render provides significant speed gains for rendering and denoising. So much so that render times can be halved or even more… Which means the render budget can be halved. By default a frame does not crop to the border size, it expands it to the full frame size. Why isn’t there an option to do compositing on the full frame? Default behavior might be the expected behavior in some very specific pipelines but it’s not expected in mine. In my 10+ years of VFX I have never exported cropped renders WITH compositing. We save that for software that can actually do the job. An option to have both cropped and full frame compositing would make the compositor massively more useful, solve this specific issue and an absolute mountain of other issues since this functionality can effects the vse as well.
Member

I am not giving an argument in favor of that, just presenting the existing reasoning. The domain of the viewer and file output nodes are determined by their inputs, not the output, so it is expected that they produce different outputs sometimes.

In any case, I will bring this up in the module meeting and get back to you.

I am not giving an argument in favor of that, just presenting the existing reasoning. The domain of the viewer and file output nodes are determined by their inputs, not the output, so it is expected that they produce different outputs sometimes. In any case, I will bring this up in the module meeting and get back to you.
Omar Emara self-assigned this 2024-02-13 10:49:02 +01:00
Omar Emara removed their assignment 2024-02-13 13:35:28 +01:00
Member

So we discussed this in the meeting, and as mentioned, it is indeed by design. However, we recognized the utility of the behavior you mentioned, and we shall look into adding an option for it with a proper design. But closing this report since it is not a bug.

So we discussed this in the meeting, and as mentioned, it is indeed by design. However, we recognized the utility of the behavior you mentioned, and we shall look into adding an option for it with a proper design. But closing this report since it is not a bug.
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2024-02-13 13:40:06 +01:00
Author

So just to verify, the viewer node and file output node not being the same as the render output is not considered a bug?

So just to verify, the viewer node and file output node not being the same as the render output is not considered a bug?
Member

@derekbarker Yes. Composite nodes write the area of their input that intersects the render, while viewer nodes write their input in its entirety.

This is useful because when you are viewing your images, you don't want them to be clipped by the render resolution, what you plug is what what you get.

@derekbarker Yes. Composite nodes write the area of their input that intersects the render, while viewer nodes write their input in its entirety. This is useful because when you are viewing your images, you don't want them to be clipped by the render resolution, what you plug is what what you get.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#118156
No description provided.