Vulkan Crash at startup in Blender 4.2 Alpha #118838

Closed
opened 2024-02-28 09:18:25 +01:00 by Gioxyer · 5 comments

System Information
Operating system: Windows 11 Home
Graphics card: Radeon Graphics VII (with Ryzen 5 5500U)

Blender Version
Broken: (example: 4.2 6c78f79740, main, 2024-02-28, as found on the splash screen)
Worked: Blender 4.2 Alpha, older version (only startup, not rendering, on render crash)

Short description of error
Two main crash with Vulkan, the first time gives a txt file report, the second time crash, but load a part of UI of Blender 4.2 Alpha

Exact steps for others to reproduce the error

Refer to https://devtalk.blender.org/t/blender-vulkan-status-report/25706/21

Path to follow:
Open CMD as Administrator
CD + folder path of Blender 4.2 Alpha
Digit exe file (blender.exe) + --gpu-backend vulkan
Blender doesn't open, crash instantly with txt file as main error

Then blender.exe blender --factory-startup --gpu-backend vulkan
Seems blender will open, but crash, but I can see UI at beginning

As main error:

C:\Users\giorg\Downloads\blender-4.2.0-alpha+main.6c78f7974098-windows.amd64-release>blender.exe blender --factory-startup --gpu-backend vulkan
WARNING: dzn is not a conformant Vulkan implementation, testing use only.
WARNING: dzn is not a conformant Vulkan implementation, testing use only.
Error: Cannot read file "C:\Users\giorg\Downloads\blender-4.2.0-alpha+main.6c78f7974098-windows.amd64-release\blender": No such file or directory
Error: argument has no '.blend' file extension, not using as new file, exiting! C:\Users\giorg\Downloads\blender-4.2.0-alpha+main.6c78f7974098-windows.amd64-release\blender

Blender quit

**System Information** Operating system: Windows 11 Home Graphics card: Radeon Graphics VII (with Ryzen 5 5500U) **Blender Version** Broken: (example: 4.2 6c78f7974098, main, 2024-02-28, as found on the splash screen) Worked: Blender 4.2 Alpha, older version (only startup, not rendering, on render crash) **Short description of error** Two main crash with Vulkan, the first time gives a txt file report, the second time crash, but load a part of UI of Blender 4.2 Alpha **Exact steps for others to reproduce the error** Refer to https://devtalk.blender.org/t/blender-vulkan-status-report/25706/21 Path to follow: Open CMD as Administrator CD + folder path of Blender 4.2 Alpha Digit exe file (blender.exe) + --gpu-backend vulkan Blender doesn't open, crash instantly with txt file as main error Then blender.exe blender --factory-startup --gpu-backend vulkan Seems blender will open, but crash, but I can see UI at beginning As main error: C:\Users\giorg\Downloads\blender-4.2.0-alpha+main.6c78f7974098-windows.amd64-release>blender.exe blender --factory-startup --gpu-backend vulkan WARNING: dzn is not a conformant Vulkan implementation, testing use only. WARNING: dzn is not a conformant Vulkan implementation, testing use only. Error: Cannot read file "C:\Users\giorg\Downloads\blender-4.2.0-alpha+main.6c78f7974098-windows.amd64-release\blender": No such file or directory Error: argument has no '.blend' file extension, not using as new file, exiting! C:\Users\giorg\Downloads\blender-4.2.0-alpha+main.6c78f7974098-windows.amd64-release\blender Blender quit
Gioxyer added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2024-02-28 09:18:25 +01:00
Iliya Katushenock added the
Interest
EEVEE & Viewport
Interest
Vulkan
labels 2024-02-28 10:17:39 +01:00

Here it does not crash.

**System Information**
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3060 Laptop GPU NVIDIA Corporation 546.1.0.0
version: 4.2.0 Alpha, branch: main, commit date: 2024-02-28, hash: `6c78f79740`

I see some messages in the console:

Warning: Layer requested, but not supported by the platform. [VK_LAYER_KHRONOS_validation]
PERFORMANCE: impact clearing depth texture in render pass that doesn't allow depth writes.

Even not being able to repro, this feature was implemented to get some insight on supported platforms. So, tagging @Jeroen-Bakker

Here it does not crash. ``` **System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3060 Laptop GPU NVIDIA Corporation 546.1.0.0 version: 4.2.0 Alpha, branch: main, commit date: 2024-02-28, hash: `6c78f79740` ``` I see some messages in the console: ``` Warning: Layer requested, but not supported by the platform. [VK_LAYER_KHRONOS_validation] PERFORMANCE: impact clearing depth texture in render pass that doesn't allow depth writes. ``` Even not being able to repro, this feature was implemented to get some insight on supported platforms. So, tagging @Jeroen-Bakker
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2024-02-28 15:03:53 +01:00
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2024-02-28 15:04:01 +01:00
Member

WARNING: dzn is not a conformant Vulkan implementation, testing use only. is saying that your platform doesn't have a vulkan conformant driver installed. Please make sure that a vulkan conformant driver is installed and try again.

Conformant means that the driver works as expected to the vulkan specification. If this isn't the case some features that is required might not exist or isn't available. Other software also have the same issue https://duckduckgo.com/?q=dzn+is+not+a+conformant+Vulkan+implementation&t=newext&atb=v407-1&ia=web It seems to be that due to a recent software update from windows store broke the vulkan driver. No vulkan application could be run, even the simplest demo.

I had the same problem too. I had been working on it for 5 hours. Then I saw that the "OpenCL™, OpenGL®, and Vulkan® Compatibility Pack" in the Windows Store had been updated yesterday. When I uninstalled it, the problem was solved. https://apps.microsoft.com/detail/9NQPSL29BFFF?hl=en&gl=US

might point to a solution (source https://stackoverflow.com/questions/77913326/vkcreateinstance-crashes-even-after-updating-drivers)

I will close this issue as the platform didn't meet the minimum requirements to run vulkan.

`WARNING: dzn is not a conformant Vulkan implementation, testing use only.` is saying that your platform doesn't have a vulkan conformant driver installed. Please make sure that a vulkan conformant driver is installed and try again. Conformant means that the driver works as expected to the vulkan specification. If this isn't the case some features that is required might not exist or isn't available. Other software also have the same issue https://duckduckgo.com/?q=dzn+is+not+a+conformant+Vulkan+implementation&t=newext&atb=v407-1&ia=web It seems to be that due to a recent software update from windows store broke the vulkan driver. No vulkan application could be run, even the simplest demo. ``` I had the same problem too. I had been working on it for 5 hours. Then I saw that the "OpenCL™, OpenGL®, and Vulkan® Compatibility Pack" in the Windows Store had been updated yesterday. When I uninstalled it, the problem was solved. https://apps.microsoft.com/detail/9NQPSL29BFFF?hl=en&gl=US ``` might point to a solution (source https://stackoverflow.com/questions/77913326/vkcreateinstance-crashes-even-after-updating-drivers) I will close this issue as the platform didn't meet the minimum requirements to run vulkan.
Blender Bot added
Status
Archived
and removed
Status
Needs Info from Developers
labels 2024-02-29 08:04:10 +01:00
Gioxyer reopened this issue 2024-02-29 08:38:42 +01:00
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2024-02-29 08:38:45 +01:00
Author

Thanks, I fixed by unistall the software from Window 11 App, on control panel I didn't find it. Now it works and it open as well

Thanks, I fixed by unistall the software from Window 11 App, on control panel I didn't find it. Now it works and it open as well
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2024-02-29 12:15:34 +01:00

@Gioxyer If you say things are working, does this issue need to be Open or can it be Closed now?

@Gioxyer If you say things are working, does this issue need to be Open or can it be Closed now?
Author

It can be closed, thanks for helping

It can be closed, thanks for helping
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#118838
No description provided.