Adjusting hotkey behavior for bone (de)selection #120412

Open
opened 2024-04-08 21:28:47 +02:00 by Rik Schutte · 3 comments

This proposal has been discussed in the #animation-module channel before, and people there are generally positive about this change.

Scope

For now this is about pose bones only. Edit Bone, Object, Vertex selection behavior would be nice to have consistent with this, but that's for later.

This proposal does not include any of the tool widgets, so all operations are performed outside the areas covered by a widget.

Drag behavior: This proposal is only about clicking, not dragging to change selection. It is worth to note that the drag-to-select gestures also use the control key to toggle between selecting and deselecting (drag to select and ctrl + drag to deselect). This proposal is consistent with that behavior.

Terminology

To avoid having to repeat everything for left-click and right-click select (LCS resp. RCS), we just use SMB for "Selecting Mouse Button", which is to be understood as LMB for LCS, RMB for RCS.

Current issue

Deselecting bones in the viewport can currently be done with:

  • a 2 click solution: shift + SMB to select active object, shift + SMB again to then deselect active object.
  • ctrl + SMB + drag (box/circle/lasso selection) over the targeted bones.

The workflow above seems to be rather cumbersome (2 clicks/actions for activating and deselecting a bone) or not precise enough with the box selection. It also lacks consistency, whereas ctrl is only used when drag-deselecting, but completely ignored when click-deselecting.

Proposed solution

Simplifying shift + SMB by removing its 'deselection' functionality. This way it will only be used for adding bones to selection and making a bone the active object.
Switching single bone deselection to ctrl + SMB, to be more consistent with the ctrl + SMB + drag behavior (deselecting bones within drawn box/circle/lasso area).

Current Proposed
Current behavior Proposed behavior

Hotkeys

Current hotkey behavior

Interaction Effect
SMB click selects a bone + makes it active
shift + SMB adds bone to selection. If already selected, it first makes it 'active'. then after repeating this hotkey, it deselects the bone.
ctrl + SMB unused

Proposed hotkey behavior

Interaction Effect
SMB selects a bone + activate (same as before)
shift + SMB adds bone to selection, and/or sets active bone but NOT deselect it when clicking twice.
ctrl + SMB deselects bone.
_This proposal has been discussed in the [`#animation-module` channel][chat] before, and people there are generally positive about this change._ [chat]: https://blender.chat/channel/animation-module ## Scope For now this is about **pose bones only**. Edit Bone, Object, Vertex selection behavior would be nice to have consistent with this, but that's for later. This proposal does not include any of the tool widgets, so all operations are performed outside the areas covered by a widget. **Drag behavior:** This proposal is only about clicking, not dragging to change selection. It is worth to note that the drag-to-select gestures also use the control key to toggle between selecting and deselecting (`drag` to select and `ctrl + drag` to deselect). This proposal is consistent with that behavior. ## Terminology To avoid having to repeat everything for left-click and right-click select (LCS resp. RCS), we just use `SMB` for "Selecting Mouse Button", which is to be understood as `LMB` for LCS, `RMB` for RCS. ## Current issue Deselecting bones in the viewport can currently be done with: - a 2 click solution: `shift + SMB` to select active object, `shift + SMB` again to then deselect active object. - `ctrl + SMB + drag` (box/circle/lasso selection) over the targeted bones. The workflow above seems to be rather cumbersome (2 clicks/actions for activating and deselecting a bone) or not precise enough with the box selection. It also lacks consistency, whereas `ctrl` is only used when drag-deselecting, but completely ignored when click-deselecting. ## Proposed solution Simplifying `shift + SMB` by removing its 'deselection' functionality. This way it will only be used for adding bones to selection and making a bone the active object. Switching single bone deselection to `ctrl + SMB`, to be more consistent with the `ctrl + SMB + drag` behavior (deselecting bones within drawn box/circle/lasso area). | Current | Proposed | | - | - | | ![Current behavior](https://projects.blender.org/attachments/947ea6cd-c8c4-4fdd-be33-3b52b201de1a) | ![Proposed behavior](https://projects.blender.org/attachments/87e385f0-79e6-43e1-9e86-09f39fa7766e) | ## Hotkeys ### Current hotkey behavior | Interaction | Effect | | ------------- | --------------------------------------------------------------------------------------------------------------------------------- | | `SMB click` | selects a bone + makes it active | | `shift + SMB` | adds bone to selection. If already selected, it first makes it 'active'. then after repeating this hotkey, it deselects the bone. | | `ctrl + SMB` | unused | ### Proposed hotkey behavior | Interaction | Effect | | ------------- | ---------------------------------------------------------------------------------------- | | `SMB` | selects a bone + activate (same as before) | | `shift + SMB` | adds bone to selection, and/or sets active bone but NOT deselect it when clicking twice. | | `ctrl + SMB` | deselects bone. |
Rik Schutte added the
Type
Design
label 2024-04-08 21:28:47 +02:00
Iliya Katushenock added this to the Animation & Rigging project 2024-04-08 21:44:48 +02:00
Sybren A. Stüvel added the
Module
Animation & Rigging
label 2024-04-09 12:03:26 +02:00
Member

This looks good to me, the sooner we can have a "test build" to allow people to try it and see if it feels right, better, easy, I think the better but on paper less clicks and more consistent would be better

This looks good to me, the sooner we can have a "test build" to allow people to try it and see if it feels right, better, easy, I think the better but on paper less clicks and more consistent would be better
Sybren A. Stüvel self-assigned this 2024-04-23 12:40:51 +02:00

Going over the details, I think this needs some clearing up.

Current hotkey behavior: (Both for RMB and LMB selection preferences)

LMB= selects a bone

Hmmm nope. In "right-click select" (RCS) mode, you need RMB to select the bone. LMB will place the 3D cursor.

LMB + drag = box/lasso selects bones within drawn area.

This does work like that, so it's always LMB regardless of which button you select with. At least when the Select Box tool is active in the toolbar (which AFAIK is the default).

shift + LMB = adds bone to selection. If already selected, it first makes it 'active object'. then after repeating this hotkey, it deselects the bone.

This doesn't work like that in RCS mode either. In Armature Edit mode, shift + LMB doesn't do anything. shift + RMB will select a chain of bones, from the active bone to the clicked bone. In Pose mode it does work as you describe, except it uses shift + RMB instead.

I think it would be clearer to start the description with an introduction of the "selecting mouse button" (SMB), which is either LMB or RMB depending on your right/left click select preference.

Also this proposal should be explicit about which bones it's talking about, because of the differences between edit & pose modes. Should these modes work consistently? Or are there different needs for animators & riggers here? Selection in armature edit mode is going to be slightly different anyway, because of the three parts of the bone that can be selected (tip, head, bone) compared to pose mode (only bone).

The bigger issue is that, when the description is unclear / ambiguous about the existing behaviour, it means that the proposed behaviour is unclear as well. Since it's not just "swap LMB for RMB for RCS mode", I think expressing it in terms of SMB, or LMB/RMB when they're always left/right regardless of preference, will help a lot.

This level of precision is a necessity for any developer to be able to implement the proposal.

Going over the details, I think this needs some clearing up. > **Current hotkey behavior: (Both for RMB and LMB selection preferences)** > > `LMB`= selects a bone Hmmm nope. In "right-click select" (RCS) mode, you need `RMB` to select the bone. `LMB` will place the 3D cursor. > `LMB + drag` = box/lasso selects bones within drawn area. This does work like that, so it's always `LMB` regardless of which button you select with. At least when the Select Box tool is active in the toolbar (which AFAIK is the default). > `shift + LMB` = adds bone to selection. If already selected, it first makes it 'active object'. then after repeating this hotkey, it deselects the bone. This doesn't work like that in RCS mode either. In Armature Edit mode, `shift + LMB` doesn't do anything. `shift + RMB` will select a chain of bones, from the active bone to the clicked bone. In Pose mode it does work as you describe, except it uses `shift + RMB` instead. I think it would be clearer to start the description with an introduction of the "selecting mouse button" (`SMB`), which is either `LMB` or `RMB` depending on your right/left click select preference. Also this proposal should be explicit about which bones it's talking about, because of the differences between edit & pose modes. Should these modes work consistently? Or are there different needs for animators & riggers here? Selection in armature edit mode is going to be slightly different anyway, because of the three parts of the bone that can be selected (tip, head, bone) compared to pose mode (only bone). The bigger issue is that, when the description is unclear / ambiguous about the existing behaviour, it means that the proposed behaviour is unclear as well. Since it's not just "_swap `LMB` for `RMB` for RCS mode_", I think expressing it in terms of `SMB`, or `LMB`/`RMB` when they're _always_ left/right regardless of preference, will help a lot. This level of precision is a necessity for any developer to be able to implement the proposal.
Sybren A. Stüvel changed title from Adjusting hotkey behavior for bone (de)selection. to Adjusting hotkey behavior for bone (de)selection 2024-05-07 14:49:54 +02:00

I've just had a little meeting with @Rikstopher about this, and updated the proposal description accordingly.

I've just had a little meeting with @Rikstopher about this, and updated the proposal description accordingly.
Sybren A. Stüvel added the
Interest
User Interface
label 2024-06-06 12:51:47 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#120412
No description provided.