Weight Paint cannot be visualized with Flat Lighting as in Vertex/Texture Paint modes #120636

Open
opened 2024-04-14 16:14:42 +02:00 by Massimiliano Puliero · 7 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 546.17

Blender Version
Broken: version: 4.1.0, branch: blender-v4.1-release, commit date: 2024-03-25 20:42, hash: 40a5e739e270

Short description of error
Unlike Vertex/Texture Paint, Weight Paint is not drawn by the Workbench engine and is therefore not affected by "viewport shading" settings.

This is a disadvantage because we cannot set Flat Shading in Weight Paint mode:
image

Exact steps for others to reproduce the error

  • With the default Cube selected, go to Weight Paint mode
  • With Viewport Shading Solid, set the Viewport Shading Light to Flat
  • Compare with Vertex Paint or Texture Paint Mode
**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 546.17 **Blender Version** Broken: version: 4.1.0, branch: blender-v4.1-release, commit date: 2024-03-25 20:42, hash: `40a5e739e270` **Short description of error** Unlike Vertex/Texture Paint, Weight Paint is not drawn by the Workbench engine and is therefore not affected by "viewport shading" settings. This is a disadvantage because we cannot set Flat Shading in Weight Paint mode: ![image](/attachments/1d6e120f-2630-4c97-aa19-f0e7f5150661) **Exact steps for others to reproduce the error** - With the default Cube selected, go to Weight Paint mode - With Viewport Shading `Solid`, set the Viewport Shading Light to `Flat` - Compare with Vertex Paint or Texture Paint Mode
Massimiliano Puliero added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2024-04-14 16:14:42 +02:00
Member

Hi there! I'm pretty sure the shading option is actually working. You could decrease the opacity of the weight overlay here and see the underlying object shading:

图片

Will close this issue since it's not really a bug with blender. But feel free to comment further. Thanks!

Hi there! I'm pretty sure the shading option is actually working. You could decrease the opacity of the weight overlay here and see the underlying object shading: ![图片](/attachments/70dd21b3-d5b9-47d6-9a42-63108f8e972e) Will close this issue since it's not really a bug with blender. But feel free to comment further. Thanks!
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2024-04-15 04:36:32 +02:00

Sorry but it's the opposite, I still see the shading on the weight paint, I don't get the flat weight color even the shading is on "flat".

weight paint it's the only mode where the shading option doesn't work.

I upload another video where the white area is assigned 100% to a vertex group but the shading (even if is set to "flat") make it hard to understand.

Thank you.

Sorry but it's the opposite, I still see the shading on the weight paint, I don't get the flat weight color even the shading is on "flat". weight paint it's the only mode where the shading option doesn't work. I upload another video where the white area is assigned 100% to a vertex group but the shading (even if is set to "flat") make it hard to understand. Thank you.
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2024-04-15 15:17:34 +02:00

it looks like it's a knows issue never resolved properly.

#73434 (comment)

it looks like it's a knows issue never resolved properly. https://projects.blender.org/blender/blender/issues/73434#issue-35500

As an overlay, the weight paint drawing overlays the result of the engine drawing:
GIF.gif

I don't think the comment at #73434 still applies because at that time the weight paint overlay behaved differently than what is seen now.

@MassimilianoPuliero, I noticed that the weight colors in your case are in grayscale. Is this a change in theme?

As an overlay, the weight paint drawing overlays the result of the engine drawing: ![GIF.gif](/attachments/b167649b-cb41-4a2c-8449-1cce9d756d3c) I don't think the comment at #73434 still applies because at that time the weight paint overlay behaved differently than what is seen now. @MassimilianoPuliero, I noticed that the weight colors in your case are in grayscale. Is this a change in theme?
4.2 MiB
Germano Cavalcante added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2024-04-15 20:50:55 +02:00

Hi, thanks for the reply,
Yes it is a custom theme, but the matter doesn't change.

in the comment it says:
"The only remaining problem is that the Weight Paint object is affected by shading options: lighting, material, textures, etc. It should always act as if the shading mode was set to Flat with a completely white color."

Which is the exact problem I'm facing now, having an accurate color feedback is crucial to Weight paint properly, everything revolves around it, if the color is altered in someway I have always to double check manually the weight values or spin the geometry to find where it might be a good angle to see the color as flat as possible.

Anyway, if it's not a bug in the sense that there aren't errors in the code, please acknowledge the issue for the next update.

Thank you.
Max

Hi, thanks for the reply, Yes it is a custom theme, but the matter doesn't change. in the comment it says: _"The only remaining problem is that the Weight Paint object is affected by shading options: lighting, material, textures, etc. **It should always act as if the shading mode was set to Flat** with a completely white color."_ Which is the exact problem I'm facing now, having an accurate color feedback is crucial to Weight paint properly, everything revolves around it, if the color is altered in someway I have always to double check manually the weight values or spin the geometry to find where it might be a good angle to see the color as flat as possible. Anyway, if it's not a bug in the sense that there aren't errors in the code, please acknowledge the issue for the next update. Thank you. Max

It certainly is weird that the overlay adds shading where there wasn't any before. Like here, where the bottom of the cube looks like it has a different weight even though it's the exact same weight as the sides:

image

I get that it may be helpful to see the shape of the mesh in some situations, but there's no way to turn it off?

It certainly is weird that the overlay adds shading where there wasn't any before. Like here, where the bottom of the cube looks like it has a different weight even though it's the exact same weight as the sides: ![image](/attachments/1d6e120f-2630-4c97-aa19-f0e7f5150661) I get that it may be helpful to see the shape of the mesh in some situations, but there's no way to turn it off?
156 KiB
Germano Cavalcante changed title from Weight Pant mode ignores viewport shading settings. to Weight Paint cannot be visualized with Flat Lighting as in Vertex/Texture Paint modes 2024-04-16 20:58:59 +02:00

I now understand the confusion better. Weight Paint Mode behaves differently from Vertex Paint and Texture Paint.
While one is an Overlay, the others are drawn by the Workbench engine.
While not necessarily a bug, it can be confusing for the user.

Therefore, I edited the description and am confirming the issue.

I now understand the confusion better. Weight Paint Mode behaves differently from Vertex Paint and Texture Paint. While one is an Overlay, the others are drawn by the Workbench engine. While not necessarily a bug, it can be confusing for the user. Therefore, I edited the description and am confirming the issue.
Germano Cavalcante added the
Interest
Animation & Rigging
label 2024-04-16 21:11:58 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#120636
No description provided.