Workbench: Shadow with spike artifacts #120663

Open
opened 2024-04-15 15:54:28 +02:00 by Omar · 4 comments

System Information
Operating system: Linux-6.5.0-26-generic-x86_64-with-glibc2.35 64 Bits, X11 UI
Graphics card: NVIDIA GeForce RTX 2060/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 535.161.07

Blender Version
Broken: 4.0.3, 4.1.1, 4.2
Worked: 3.5.1 was not perfect, but way better (19dbe049db caused a "regression" of sorts here)

Short description of error
Rendering in workbench with Shadow enabled is showing some weird line artifacts on some meshes. This same mesh and previous version of the file did not show these artifacts in 4.0.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file
image

**System Information** Operating system: Linux-6.5.0-26-generic-x86_64-with-glibc2.35 64 Bits, X11 UI Graphics card: NVIDIA GeForce RTX 2060/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 535.161.07 **Blender Version** Broken: 4.0.3, 4.1.1, 4.2 Worked: 3.5.1 was not perfect, but way better (19dbe049db9198f7f018c92c42f69daa2d7faeeb caused a "regression" of sorts here) **Short description of error** Rendering in workbench with Shadow enabled is showing some weird line artifacts on some meshes. This same mesh and previous version of the file did not show these artifacts in 4.0. **Exact steps for others to reproduce the error** Based on the default startup or an attached .blend file ![image](/attachments/acb57bb2-58ee-4c81-a08f-3126040acdd4)
Omar added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2024-04-15 15:54:29 +02:00
Iliya Katushenock added the
Interest
EEVEE & Viewport
Interest
Workbench
labels 2024-04-15 17:22:59 +02:00
Iliya Katushenock changed title from Workbench Render Line Artifacts to Regression: Workbench Render Line Artifacts 2024-04-15 17:23:06 +02:00

I can confirm.
Looks like shadow spikes.
Possibly related to:
#113430: Solid viewport shading shadow rendering bug

4.0 presents the same problem

I can confirm. Looks like shadow spikes. Possibly related to: #113430: Solid viewport shading shadow rendering bug 4.0 presents the same problem
Germano Cavalcante changed title from Regression: Workbench Render Line Artifacts to Workbench: Shadow with spike artifacts 2024-04-15 22:55:53 +02:00
Member

3.5.1 was still fine, will try to check which commit broke this

3.5.1 was still fine, will try to check which commit broke this
Member

3.5.1 was still fine, will try to check which commit broke this

Hold on, 3.5.1 can also have the artifact if you change the light direction... but in 3.6, it is definitely worse...

> 3.5.1 was still fine, will try to check which commit broke this Hold on, 3.5.1 can also have the artifact if you change the light direction... but in 3.6, it is definitely worse...
Member

Like I said, 3.5.1 is also not perfect, but this is the commit that had a bad influence (or at least exposed something that was wrong from the beginning) : 19dbe049db

CC @ideasman42
CC @HooglyBoogly

Like I said, 3.5.1 is also not perfect, but this is the commit that had a bad influence (or at least exposed something that was wrong from the beginning) : 19dbe049db9198f7f018c92c42f69daa2d7faeeb CC @ideasman42 CC @HooglyBoogly
Philipp Oeser added the
Interest
Modeling
label 2024-04-16 12:31:13 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#120663
No description provided.