Core Add-ons planned changes #121830

Open
opened 2024-05-15 16:14:36 +02:00 by Dalai Felinto · 0 comments

Core Add-ons

This is a task to keep track of whether they need any user preference changes. This should be tacked before 4.2 beta.

Until then, the core add-ons will be shown on the Extensions panel.

All good Enabled No Pending Preferences Name
Node Wrangler
Rigify
UI Translation
glTF 2.0 format
Hydra Storm render engine
Copy Global Transform
VR Scene Inspection
Cycles Render Engine
FBX format
BioVision Motion Capture (BVH) format
Pose Library
Scalable Vector Graphics (SVG) 1.1 format
UV Layout

VR Scene Inspection

Move to Input > Head Mounted Display

  • Add checkbox to header, to enable/disable.
  • Move Actions Maps as a preference to the HMD panel.
  • Update the warning (on the preferences): not supported on MacOS.

Copy Global Transform

TODO: Find place to have on/off button OR have it always on?

glTF 2.0 format

TODO: All the settings are useful, but we need to find a place for them on the UI.

Proposal:

  • Unify "Shader Editor Add-ons + Material Variants + Animation UI" on a single glTF option
  • Remove "Allow glTF Embedded format" (have it on, the "warning" about when to use it is already on the Embed format tooltip).

Hydra Storm render engine

Find out the best place to move this to. Maybe under Developers Extra | Development > Rendering: [ ] Hydra Storm Render.

Cycles Render Engine

It has preferences, but they are also shown on the System tab. We just need to remove them from Cycles add-on own preference.

UI Translation

The plan is to create a new Tab on preferences called "Development". This will only be visible when "Developers Extra" is enabled.

We move the "Experimental > Debugging" panel there. And then the UI Translation can add its own panel there, which a header option to enable/disable.

To keep things simple Bastien is thinking on checking for this on register(), and only register the operators/... if is enable. That means to use this core add-on you need to (1) enable the "use_ui_translation_addon" upcoming setting; (2) restart Blender. Which he is fine with.

Pose Library

All is good, but in the future Sybren wanted to make hooks/callbacks so it could be extended by Studios (original reason why it was an add-on).

Rigify

  • Move ‘Add → Armature’ menu into ‘Rigify’ sub-menu.
  • Disabled by default still, because of the extra panels it shows in the Armature properties.
  • It could be moved to an Animation section on the User Preferences.

Node Wrangler

  • Too many changes to mention. It needs a separate plan of action.
## Core Add-ons This is a task to keep track of whether they need any user preference changes. This should be tacked before 4.2 beta. Until then, the core add-ons will be shown on the Extensions panel. | All good | Enabled | No Pending Preferences | Name | | - | - | - | - | | | | | Node Wrangler | | | | | | Rigify | | | | | | UI Translation | | | ✓ | | glTF 2.0 format | | | | | ✓ | Hydra Storm render engine | Move to ??? | | | | ✓ | Copy Global Transform | | | | ✓ | VR Scene Inspection | | | ✓ | ✓ | Cycles Render Engine | | | ✓ | ✓ | ✓ | FBX format | | | ✓ | ✓ | ✓ | BioVision Motion Capture (BVH) format | | ✓ | ✓ | ✓ | Pose Library | | ✓ | ✓ | ✓ | Scalable Vector Graphics (SVG) 1.1 format | | | ✓ | ✓ | ✓ | UV Layout | | ### VR Scene Inspection Move to Input > Head Mounted Display * Add checkbox to header, to enable/disable. * Move Actions Maps as a preference to the HMD panel. * Update the warning (on the preferences): not supported on MacOS. ### Copy Global Transform TODO: Find place to have on/off button OR have it always on? ### glTF 2.0 format TODO: All the settings are useful, but we need to find a place for them on the UI. Proposal: * Unify "Shader Editor Add-ons + Material Variants + Animation UI" on a single glTF option * Remove "Allow glTF Embedded format" (have it on, the "warning" about when to use it is already on the Embed format tooltip). ### Hydra Storm render engine Find out the best place to move this to. Maybe under Developers Extra | Development > Rendering: [ ] Hydra Storm Render. ### Cycles Render Engine It has preferences, but they are also shown on the System tab. We just need to remove them from Cycles add-on own preference. ### UI Translation The plan is to create a new Tab on preferences called "Development". This will only be visible when "Developers Extra" is enabled. We move the "Experimental > Debugging" panel there. And then the UI Translation can add its own panel there, which a header option to enable/disable. To keep things simple Bastien is thinking on checking for this on register(), and only register the operators/... if is enable. That means to use this core add-on you need to (1) enable the "use_ui_translation_addon" upcoming setting; (2) restart Blender. Which he is fine with. ### Pose Library All is good, but in the future Sybren wanted to make hooks/callbacks so it could be extended by Studios (original reason why it was an add-on). ### Rigify * Move ‘Add → Armature’ menu into ‘Rigify’ sub-menu. * Disabled by default still, because of the extra panels it shows in the Armature properties. * It could be moved to an Animation section on the User Preferences. ### Node Wrangler * Too many changes to mention. It needs a separate plan of action.
Dalai Felinto added the
Type
To Do
label 2024-05-15 16:14:36 +02:00
Dalai Felinto added this to the Python API project 2024-05-15 16:14:36 +02:00
Dalai Felinto changed title from Core Add-ons planned changes for 4.2 to Core Add-ons planned changes 2024-06-24 11:46:41 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
1 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#121830
No description provided.