Out of the box (extensions) experience #122147

Closed
opened 2024-05-23 11:52:05 +02:00 by Dalai Felinto · 7 comments

There is an (old) idea of allowing people to easily enhance their Blender experience "off the box". Originally this was thinking about assets, but the same could be said about add-ons and themes.

As a matter of fact, the online functionality brought by the extensions platform (and in the future remote asset repositories) address just that. The downside is, you still need internet connection.

Given some of the feedback on the extensions platform for people who want (or need) to work 100% offline, it is interesting to provide an option for them as well. And even more anyone should be able to create their own bundle and share around.

To better leverage the extensions platform these extensions should be seen as a quick-start, and still be treated as any other extensions downloaded from the same repository. That means they can still be updated afterwards.

Features/tasks:

  • Create a bundle of the 4.1 extensions (excluding core) to offer as download.
  • Blender should support either individual or multiple draggable .zip files.
    • Installing multiple will not enable the add-ons (the option will be disabled).
  • Install (to remote repository) from disk #122302

This is done because users will likely want to install a “pack” without enabling them all.
Further, any errors are likely to be difficult to troubleshoot if there are many at once.

To-be decided:

  • Do we ship some more essential extensions (node wrangler, rigify, ...) as:
    • Core Add-ons;
    • As pre-installed extension;
    • Leave them only in a separate downloadable bundle together with the other 100 4.1 extensions;
  • Whatever solution we go with, it still be decided on a case-by-case basis.
There is an (old) idea of allowing people to easily enhance their Blender experience "off the box". Originally this was thinking about assets, but the same could be said about add-ons and themes. As a matter of fact, the online functionality brought by the extensions platform (and in the future remote asset repositories) address just that. The downside is, you still need internet connection. Given some of the feedback on the extensions platform for people who want (or need) to work 100% offline, it is interesting to provide an option for them as well. And even more anyone should be able to create their own bundle and share around. To better leverage the extensions platform these extensions should be seen as a quick-start, and still be treated as any other extensions downloaded from the same repository. That means they can still be updated afterwards. Features/tasks: * [ ] Create a bundle of the 4.1 extensions (excluding core) to offer as download. * [ ] Blender should support either individual or multiple draggable .zip files. * Installing multiple will *not* enable the add-ons (the option will be disabled). * [x] Install (to remote repository) from disk #122302 This is done because users will likely want to install a “pack” without enabling them all. Further, any errors are likely to be difficult to troubleshoot if there are many at once. To-be decided: * Do we ship some more essential extensions (node wrangler, rigify, ...) as: * Core Add-ons; * As pre-installed extension; * Leave them only in a separate downloadable bundle together with the other 100 4.1 extensions; * Whatever solution we go with, it still be decided on a case-by-case basis.
Dalai Felinto added the
Type
To Do
label 2024-05-23 11:52:05 +02:00
Dalai Felinto added this to the Python API project 2024-05-23 11:52:05 +02:00

Little thought I had, has there been a custom format considered for extensions? Just zip files in reality but renamed to like "BLA" (blender add-on) or something like that and letting them be double clicked or dragged - it might make it more simple for users to tell what's a blender add-on and what isn't since I've seen some confusion about how to install them from zips before (as they aren't really seen as something you install something with usually)

Little thought I had, has there been a custom format considered for extensions? Just zip files in reality but renamed to like "BLA" (blender add-on) or something like that and letting them be double clicked or dragged - it might make it more simple for users to tell what's a blender add-on and what isn't since I've seen some confusion about how to install them from zips before (as they aren't really seen as something you install something with usually)
Dalai Felinto added
Type
Design
and removed
Type
To Do
labels 2024-05-23 14:11:08 +02:00

a custom format

Yes, there were a problem with detecting if zip is installable as an addon (or is just, say, a repository zip download).

> a custom format Yes, there were a problem with detecting if zip is installable as an addon (or is just, say, a repository zip download).
Author
Owner

Updated the task since we are dropping the idea of adding the repository information on the manifest. Instead we will implement support to installing to remote repository from disk.

Updated the task since we are dropping the idea of adding the repository information on the manifest. Instead we will implement support to installing to remote repository from disk.

I don't really understand the purpose of the bundle of 4.1 extensions, assuming that's only going to be made available for Blender 4.2 and not updated after. Then users will learn to install this bundle, maybe some studios will automate the installation. And then for Blender 4.3 or 5.0 some of those add-ons break, and users will have to set things up again? It seems confusing to me.

Personally I think something like this could be done:

  • Bundle more add-ons as core. Including node wrangler, rigify and maybe 10 more popular ones. Most of these are being effectively maintained by Blender developers, and to me it does not make so much difference in which repository that happens. While the functionality can be dubious in cases, looking at the git history there doesn't seem to be that much maintenance overhead besides automated cleanups and API updates, which isn't so bad to validate the impact of API changes.
  • Try to improve the migration of bundled add-ons to extensions. Maybe rather than just showing as missing in the UI, there could be something like. "This add-on was moved to the online extensions repository. [Install Extension]".

In some ways I think these are just growing pains, and many of the user concerns will go away once it becomes clear that the extensions repository has many more useful add-ons than what we used to bundle with Blender, and the particular set add-ons that used to be bundled will not be so important anymore. But we are not there yet, and I think the transition can be made a bit smoother.

I don't really understand the purpose of the bundle of 4.1 extensions, assuming that's only going to be made available for Blender 4.2 and not updated after. Then users will learn to install this bundle, maybe some studios will automate the installation. And then for Blender 4.3 or 5.0 some of those add-ons break, and users will have to set things up again? It seems confusing to me. Personally I think something like this could be done: * Bundle more add-ons as core. Including node wrangler, rigify and maybe 10 more popular ones. Most of these are being effectively maintained by Blender developers, and to me it does not make so much difference in which repository that happens. While the functionality can be dubious in cases, looking at the git history there doesn't seem to be that much maintenance overhead besides automated cleanups and API updates, which isn't so bad to validate the impact of API changes. * Try to improve the migration of bundled add-ons to extensions. Maybe rather than just showing as missing in the UI, there could be something like. "This add-on was moved to the online extensions repository. [Install Extension]". In some ways I think these are just growing pains, and many of the user concerns will go away once it becomes clear that the extensions repository has many more useful add-ons than what we used to bundle with Blender, and the particular set add-ons that used to be bundled will not be so important anymore. But we are not there yet, and I think the transition can be made a bit smoother.
Member

I love this idea overall, but coming from the perspective of someone who has worked at both large and small studios, internet access on studio machines is extremely limited, thus making it more or less impossible to download Blender on our own without going through an IT department (or whoever is in charge of both internet access and approving software that can be installed on studio machines).

Right now, to get the latest version of Blender installed, it's generally pretty easy because I fought that battle years ago and the studio is finally comfortable with the basic download. Having an extra bundle of extensions to download means jumping through all the hoops again. Requesting it, waiting for them to find it and download it, and then run it through whatever virus detection stuff they use. Honestly not that big of a deal, but at small studio, it could take up to a day or so for all that to be cleared, depending on their workload.

I love the idea of a Core add-on bundle which would be included in the main Blender package (if I'm understanding that correctly).

I love this idea overall, but coming from the perspective of someone who has worked at both large and small studios, internet access on studio machines is extremely limited, thus making it more or less impossible to download Blender on our own without going through an IT department (or whoever is in charge of both internet access and approving software that can be installed on studio machines). Right now, to get the latest version of Blender installed, it's generally pretty easy because I fought that battle years ago and the studio is finally comfortable with the basic download. Having an extra bundle of extensions to download means jumping through all the hoops again. Requesting it, waiting for them to find it and download it, and then run it through whatever virus detection stuff they use. Honestly not that big of a deal, but at small studio, it could take up to a day or so for all that to be cleared, depending on their workload. I love the idea of a Core add-on bundle which would be included in the main Blender package (if I'm understanding that correctly).

I love the idea of a Core add-on bundle which would be included in the main Blender package (if I'm understanding that correctly).

This already exists basically, and about 10 (out of previous ~110) add-ons are in this core bundle. Node wrangler was added to this as well now.

My proposal was to add about 10 popular ones to cover the most important cases. Though it currently doesn't look like there will be agreement on that.

The other proposals are about bundles that can be created or downloaded separately.

> I love the idea of a Core add-on bundle which would be included in the main Blender package (if I'm understanding that correctly). This already exists basically, and about 10 (out of previous ~110) add-ons are in this core bundle. Node wrangler was added to this as well now. My proposal was to add about 10 popular ones to cover the most important cases. Though it currently doesn't look like there will be agreement on that. The other proposals are about bundles that can be created or downloaded separately.
Author
Owner

This is considered done now that Install remote from disk is done.

The System repository is documented here, and allow people to handle a portable Blender:
https://docs.blender.org/manual/en/4.2/advanced/deploying_blender.html

This is considered done now that [Install remote from disk](https://projects.blender.org/blender/blender/issues/122302) is done. The System repository is documented here, and allow people to handle a portable Blender: https://docs.blender.org/manual/en/4.2/advanced/deploying_blender.html
Blender Bot added the
Status
Archived
label 2024-06-24 13:12:54 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#122147
No description provided.