texture paint + zoom #34665

Closed
opened 2013-03-17 15:33:17 +01:00 by Cezary Kopias · 6 comments

%%%--- Operating System, Graphics card ---
Win7_x64 , intel HD 4000 , lenovo Y580

- Blender version with error, and version that worked ---

r55350

- Short description of error ---

When zoomed in i cant paint in texture paint mode

- Steps for others to reproduce the error (preferably based on attached .blend file) ---

just see a blend file and try to paint than zoom out
%%%

%%%--- Operating System, Graphics card --- Win7_x64 , intel HD 4000 , lenovo Y580 - Blender version with error, and version that worked --- r55350 - Short description of error --- When zoomed in i cant paint in texture paint mode - Steps for others to reproduce the error (preferably based on attached .blend file) --- just see a blend file and try to paint than zoom out %%%
Author

Changed status to: 'Open'

Changed status to: 'Open'

%%%This is an old bug, I remember stumbling onto it often. Time to squash it.

Campbel, I see that the issue is the use of PROJ_VERT_CULL for face masking based on vertex positions alone. This is problematic and we should ideally use the face or interpolated normal for that, as is indeed is done in project_paint_uvpixel_mask. If we do it based on vertices alone, faces will be culled where they shouldn't. Would you recommend doing it that way?%%%

%%%This is an old bug, I remember stumbling onto it often. Time to squash it. Campbel, I see that the issue is the use of PROJ_VERT_CULL for face masking based on vertex positions alone. This is problematic and we should ideally use the face or interpolated normal for that, as is indeed is done in project_paint_uvpixel_mask. If we do it based on vertices alone, faces will be culled where they shouldn't. Would you recommend doing it that way?%%%

%%%I have an idea, assigning to self%%%

%%%I have an idea, assigning to self%%%

%%%This is known limitation since projection paint was added, noted in wiki docs (realize these docs are insubstantial but they will have to do)
http://wiki.blender.org/index.php/Doc:2.6/Manual/Textures/Painting/Projection#Hints%%%

%%%This is known limitation since projection paint was added, noted in wiki docs (realize these docs are insubstantial but they will have to do) http://wiki.blender.org/index.php/Doc:2.6/Manual/Textures/Painting/Projection#Hints%%%

Changed status from 'Open' to: 'Archived'

Changed status from 'Open' to: 'Archived'

%%%I was looking into this last night. The only solution I came up with is somewhat more expensive on startup of a stroke and is more or less this: Project the normals in view space and check if both the x/y projected vector components change sign between face vertices. If they do that means that there probably exists a point within the polygon where the normal will be valid for painting and the polygon should not be discarded.

Thoughts?%%%

%%%I was looking into this last night. The only solution I came up with is somewhat more expensive on startup of a stroke and is more or less this: Project the normals in view space and check if both the x/y projected vector components change sign between face vertices. If they do that means that there probably exists a point within the polygon where the normal will be valid for painting and the polygon should not be discarded. Thoughts?%%%
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#34665
No description provided.