Cloth doesn't collide with objects, and itself. #43406

Closed
opened 2015-01-25 10:26:20 +01:00 by Kamil Adamski · 30 comments

System Information
Operating system and graphics card
Windows 7 Ultimate, GTX 970.

Blender Version
Broken: All new from Buildbot including Gooseberry branch.
Worked: Official from Blender.org

Short description of error

Like in topic. Cloth object don't collide with collision object, and don't collide with itself.

Exact steps for others to reproduce the error
Add plane, subdivide, add to it cloth simulation. Add sphere, add collision and watch.

**System Information** Operating system and graphics card Windows 7 Ultimate, GTX 970. **Blender Version** Broken: All new from Buildbot including Gooseberry branch. Worked: Official from Blender.org **Short description of error** Like in topic. Cloth object don't collide with collision object, and don't collide with itself. **Exact steps for others to reproduce the error** Add plane, subdivide, add to it cloth simulation. Add sphere, add collision and watch.
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @adrian2608

Added subscriber: @adrian2608

#43527 was marked as duplicate of this issue

#43527 was marked as duplicate of this issue

#43717 was marked as duplicate of this issue

#43717 was marked as duplicate of this issue

Added subscriber: @zeauro

Added subscriber: @zeauro

I confirm the same problem under Ubuntu 14.04 64 bits.

no_cloth.blend

attached.blend works under official 2.73 but it does not for master 2.73.4 hash 3121941.

I confirm the same problem under Ubuntu 14.04 64 bits. [no_cloth.blend](https://archive.blender.org/developer/F139336/no_cloth.blend) attached.blend works under official 2.73 but it does not for master 2.73.4 hash 3121941.
Lukas Tönne self-assigned this 2015-01-26 16:15:14 +01:00
Member

My bad, i disabled contact point generation for cloth during work on the hair solver.

Using the same collision algorithm for cloth (surface) and hair (strands) geometry may not be a good idea in the long run. For a simple penalty-force response it may still work ok-ish, but already the contact detection needs to work differently with simple BVH tree intersection tests.

Eventually i'd like to move to Bullet collision detection, using ghost objects so we can handle responses separately in our own solver. Cloth is a pretty straightforward mesh collision shape, but hair requires some more creative solution, e.g. using a compound implicit shape of cylinders and spheres (connected capsules).

The response part could then at least use a 3-stage Coulomb friction model (free - impacting - sliding), which works a lot better for stable resting on colliders. We could then also look into more advanced collision integration in the solver itself, using a solver method that supports unilateral constraints much better than penalty forces. For in-depth info, here is a selection of papers on the subject:

Large Steps in Cloth Simulation (Baraff, Witkin 1998)
A Hybrid Iterative Solver for Robustly Capturing Coulomb Friction in Hair Dynamics (Daviet, Descoubes 2011)
Implicit Contact Handling for Deformable Objects (MA Otaduy, R Tamstorf, D Steinemann 2009)

My bad, i disabled contact point generation for cloth during work on the hair solver. Using the same collision algorithm for cloth (surface) and hair (strands) geometry may not be a good idea in the long run. For a simple penalty-force response it may still work ok-ish, but already the contact detection needs to work differently with simple BVH tree intersection tests. Eventually i'd like to move to Bullet collision detection, using [ghost objects ](http://bulletphysics.org/Bullet/BulletFull/classbtGhostObject.html) so we can handle responses separately in our own solver. Cloth is a pretty straightforward mesh collision shape, but hair requires some more creative solution, e.g. using a compound implicit shape of cylinders and spheres (connected capsules). The response part could then *at least* use a 3-stage Coulomb friction model (free - impacting - sliding), which works a lot better for stable resting on colliders. We could then also look into more advanced collision integration in the solver itself, using a solver method that supports [unilateral constraints ](http://en.wikipedia.org/wiki/Unilateral_contact) much better than penalty forces. For in-depth info, here is a selection of papers on the subject: [Large Steps in Cloth Simulation (Baraff, Witkin 1998) ](http://www.cs.cmu.edu/~baraff/papers/sig98.pdf) [A Hybrid Iterative Solver for Robustly Capturing Coulomb Friction in Hair Dynamics (Daviet, Descoubes 2011) ](https://hal.archives-ouvertes.fr/hal-00647497/document) [Implicit Contact Handling for Deformable Objects (MA Otaduy, R Tamstorf, D Steinemann 2009) ](http://www.gmrv.es/Publications/2009/OTSG09/OTSG09.pdf)

Added subscriber: @Sergey

Added subscriber: @Sergey

Added subscriber: @ZauberParacelsus

Added subscriber: @ZauberParacelsus

Added subscriber: @tischbein3-2

Added subscriber: @tischbein3-2

Added subscriber: @Lapineige

Added subscriber: @Lapineige

Closed as duplicate of #43717

Closed as duplicate of #43717

Changed status from 'Duplicate' to: 'Open'

Changed status from 'Duplicate' to: 'Open'

Added subscriber: @kevindietrich

Added subscriber: @kevindietrich

Sorry I screwed up merging duplicates...

Sorry I screwed up merging duplicates...

Added subscribers: @sindra1961, @LukasTonne

Added subscribers: @sindra1961, @LukasTonne

Added subscriber: @rajaditya_m

Added subscriber: @rajaditya_m

Hi I am a newbie with who is willing to work on cloth simulation aspect of blender since it is a part of my Phd thesis. Is this bug already fixed ?

Hi I am a newbie with who is willing to work on cloth simulation aspect of blender since it is a part of my Phd thesis. Is this bug already fixed ?

In #43406#290864, @rajaditya_m wrote:
Hi I am a newbie with who is willing to work on cloth simulation aspect of blender since it is a part of my Phd thesis. Is this bug already fixed ?

I suggest using the 2.73a release. The issue with cloth collisions only occurs in the upstream development versions of blender.

> In #43406#290864, @rajaditya_m wrote: > Hi I am a newbie with who is willing to work on cloth simulation aspect of blender since it is a part of my Phd thesis. Is this bug already fixed ? I suggest using the 2.73a release. The issue with cloth collisions only occurs in the upstream development versions of blender.

Yes, I tested it with the 2.72 release edition and it seems there the problem is not there. But it is occuring in the developer build that I got from the git repository. I will look into this. Since this is my first tryst with blender any suggestions will be welcome.

Yes, I tested it with the 2.72 release edition and it seems there the problem is not there. But it is occuring in the developer build that I got from the git repository. I will look into this. Since this is my first tryst with blender any suggestions will be welcome.

This issue was referenced by dfefd36837

This issue was referenced by dfefd3683710a4bf70cf90c874b65a9c118d2c06
Member

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Member

Closed by commit dfefd36837.

Closed by commit dfefd36837.

I seem to recognize collision, but do not function for cloth sim.
I attach a file.
Cube should stand in the former version.
However, bending is ignored in the revised version.
clothtest.blend

[The edition that I confirmed]
blender-2.73-56935e2-win32.zip
version 2.73 (sub 9), branch b'master', commit date b'2015-03-02' b'00:05', hash b'56935e2', b'Release'

I seem to recognize collision, but do not function for cloth sim. I attach a file. Cube should stand in the former version. However, bending is ignored in the revised version. [clothtest.blend](https://archive.blender.org/developer/F146633/clothtest.blend) [The edition that I confirmed] blender-2.73-56935e2-win32.zip version 2.73 (sub 9), branch b'master', commit date b'2015-03-02' b'00:05', hash b'56935e2', b'Release'

I think that friction does not function in the same way.

I think that friction does not function in the same way.

I think that some situation is different.
Results are different even if they make the same setting in 2.73a(release edition) and the revision.
The result is the same even if I carry out the result of made blend file in any version.
Made blend files are different.
I made this file in a revised version.
clothtest2.blend
I made this file in 2.73a(release edition).
clothtest2_release.blend
Both setting is the same.

I think that some situation is different. Results are different even if they make the same setting in 2.73a(release edition) and the revision. The result is the same even if I carry out the result of made blend file in any version. Made blend files are different. I made this file in a revised version. [clothtest2.blend](https://archive.blender.org/developer/F146638/clothtest2.blend) I made this file in 2.73a(release edition). [clothtest2_release.blend](https://archive.blender.org/developer/F146639/clothtest2_release.blend) Both setting is the same.
Member

Changed status from 'Resolved' to: 'Open'

Changed status from 'Resolved' to: 'Open'
Member

Confirmed, i think i'm not applying positions in quite the same way or so. Will look into it ...

Confirmed, i think i'm not applying positions in quite the same way or so. Will look into it ...
Member

Closed as duplicate of #43911

Closed as duplicate of #43911
Member

Merged into #43911 because its description is more specific.

Merged into #43911 because its description is more specific.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
10 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#43406
No description provided.