Blender segfaults when importing Python module in OSX #43869

Closed
opened 2015-03-03 15:01:22 +01:00 by Dalai Felinto · 11 comments

System Information
OSX 10.9.5

Blender Version
Broken: 2.73, 2.72, ...
Worked: home-built Blender with Frameworks Python

Short description of error
Blender segfaults when I import the home-built 'vrpn' module.
The same module works fine if I import it from the system Python, or if I build Blender using the Frameworks Python option.

Exact steps for others to reproduce the error

import sys
sys.path.append('/Users/dfelinto/src/vrpn/build/python/')
import vrpn

Full backtrace of segfault: P207

Tested using hash: d4a0345c from VRPN repository (git://git.cs.unc.edu/vrpn.git).
And 19656233 from Blender's repository

**System Information** OSX 10.9.5 **Blender Version** Broken: 2.73, 2.72, ... Worked: home-built Blender with Frameworks Python **Short description of error** Blender segfaults when I import the home-built 'vrpn' module. The same module works fine if I import it from the system Python, or if I build Blender using the Frameworks Python option. **Exact steps for others to reproduce the error** ``` import sys sys.path.append('/Users/dfelinto/src/vrpn/build/python/') import vrpn ``` Full backtrace of segfault: [P207](https://archive.blender.org/developer/P207.txt) Tested using hash: d4a0345c from VRPN repository (git://git.cs.unc.edu/vrpn.git). And 19656233 from Blender's repository
Author
Owner

Changed status to: 'Open'

Changed status to: 'Open'
jens verwiebe was assigned by Dalai Felinto 2015-03-03 15:01:22 +01:00
Author
Owner

Added subscriber: @dfelinto

Added subscriber: @dfelinto
Author
Owner

This is the Python module I built: http://www.dalaifelinto.com/ftp/vrpn.so (OSX only)

This is the Python module I built: http://www.dalaifelinto.com/ftp/vrpn.so (OSX only)

Added subscriber: @ideasman42

Added subscriber: @ideasman42

Checked and it loads fine on Linux (in/out of Blender).
(build "33e9509828f30594852ffd2a0f1dfefcc2e97960", CMake, options -DVRPN_GPL_SERVER=OFF -DVRPN_USE_GPM_MOUSE=OFF)

The crash is happening outside Blender's code,
recently we ran into a crash on Linux which only happened inside Blender, but ended up being caused by a conflict shared libraries used by Blender and the module.

The exact libraries aren't important, but heres a summary of the problem:
https://developer.blender.org/T43491#291613

Using LD_DEBUG=files helped track down the problem here:
https://developer.blender.org/T43491#288351

You want to compare the libraries loaded in Blender with the ones Python uses to see if symbols from Blender's libraries are getting used by vrpn

Checked and it loads fine on Linux (in/out of Blender). (build "33e9509828f30594852ffd2a0f1dfefcc2e97960", CMake, options `-DVRPN_GPL_SERVER=OFF -DVRPN_USE_GPM_MOUSE=OFF`) The crash is happening outside Blender's code, recently we ran into a crash on Linux which only happened inside Blender, but ended up being caused by a conflict shared libraries used by Blender and the module. The exact libraries aren't important, but heres a summary of the problem: https://developer.blender.org/T43491#291613 Using `LD_DEBUG=files` helped track down the problem here: https://developer.blender.org/T43491#288351 You want to compare the libraries loaded in Blender with the ones Python uses to see if symbols from Blender's libraries are getting used by `vrpn`

Setting as unconfirmed. this is fairly unlikely to be a bug in Blender's code. I expect its some configuration issue.

Setting as *unconfirmed*. this is fairly unlikely to be a bug in Blender's code. I expect its some configuration issue.

Added subscriber: @amirul4

Added subscriber: @amirul4

hye,
can anybody plz help me
my name amirul using windows 7 32bit
currently i build game from blender game but by using FAAST 1.2 cannot control the game.
how can i make it work? can anybody explain to me how to activate vrpn in blender game so that it receive the command. If it use a python scripts,do PM me. i can't even find addons module for vrpn to blender. pplz do help me. im appreciate if u can do so,tqvm

hye, can anybody plz help me my name amirul using windows 7 32bit currently i build game from blender game but by using FAAST 1.2 cannot control the game. how can i make it work? can anybody explain to me how to activate vrpn in blender game so that it receive the command. If it use a python scripts,do PM me. i can't even find addons module for vrpn to blender. pplz do help me. im appreciate if u can do so,tqvm

Added subscriber: @mont29

Added subscriber: @mont29

Changed status from 'Open' to: 'Archived'

Changed status from 'Open' to: 'Archived'

Nothing new here, thanks for the report, but time to archive.

Nothing new here, thanks for the report, but time to archive.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#43869
No description provided.