Bone Heat weighting: failed (due to none of the vertices in an island being visible to any bones) #45493

Open
opened 2015-07-19 11:08:20 +02:00 by pistol ioan · 32 comments

Win 10 64. gtx 970

Blender 2.75a Hash c27589e

Bone Heat weighting: failed to find solution for one or more bones

I attach the blend file and two prints..

Also the same broblems apper when i try to "assign automatic from bones" by individual bones in Weight Paint. Like one by one. Please see print2.

print2.jpg

print.jpg

cat.blend

**Win 10 64. gtx 970** **Blender 2.75a Hash c27589e** **Bone Heat weighting: failed to find solution for one or more bones** I attach the blend file and two prints.. Also the same broblems apper when i try to "assign automatic from bones" by individual bones in Weight Paint. Like one by one. Please see print2. ![print2.jpg](https://archive.blender.org/developer/F208808/print2.jpg) ![print.jpg](https://archive.blender.org/developer/F208807/print.jpg) [cat.blend](https://archive.blender.org/developer/F208811/cat.blend)
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @istoltoto

Added subscriber: @istoltoto

#103409 was marked as duplicate of this issue

#103409 was marked as duplicate of this issue

blender/blender-addons#87888 was marked as duplicate of this issue

blender/blender-addons#87888 was marked as duplicate of this issue

#90340 was marked as duplicate of this issue

#90340 was marked as duplicate of this issue

#46296 was marked as duplicate of this issue

#46296 was marked as duplicate of this issue

#51250 was marked as duplicate of this issue

#51250 was marked as duplicate of this issue

Added subscribers: @LukasTonne, @Sergey, @ideasman42, @mont29

Added subscribers: @LukasTonne, @Sergey, @ideasman42, @mont29

Not sure we’d consider that a bug, bone heating process is rather complex and not guaranteed to success afaik.

@LukasTonne, @Sergey, @ideasman42, maybe you know more about it?

Not sure we’d consider that a bug, bone heating process is rather complex and not guaranteed to success afaik. @LukasTonne, @Sergey, @ideasman42, maybe you know more about it?
Author

Is very nasty to paint every bone.
Please consider to solve this problem.

Please?

Is very nasty to paint every bone. Please consider to solve this problem. Please?
Bastien Montagne changed title from Bone Hear weighting: failed to Bone Heat weighting: failed 2015-07-19 15:47:20 +02:00

Added subscriber: @brecht

Added subscriber: @brecht

A workaround is to split the mesh and then bind the weights. Enter editmode on the mesh, L linked select the body, P to separate into a separate mesh, compute the weights for the two meshes separately, and Ctrl + J join them again.

It seems there is some issue with the teeth where they are not visible to any bone, which is somehow messing things up.

A workaround is to split the mesh and then bind the weights. Enter editmode on the mesh, `L` linked select the body, `P` to separate into a separate mesh, compute the weights for the two meshes separately, and `Ctrl + J` join them again. It seems there is some issue with the teeth where they are not visible to any bone, which is somehow messing things up.

I think the problem is that the algorithm does not explicitly handle connected components separately. They are all handled in a single matrix, and that's usually fine. But if none of the vertices in a connected component are visible to any bones, then the matrix will not be invertible, and the solve will fail for all components.

The solution would be to detect such cases, and then disable visibility tests for such components, or somehow get the weights from nearby components. Switching the code to use BMesh instead of Mesh would make that easier.

I think the problem is that the algorithm does not explicitly handle connected components separately. They are all handled in a single matrix, and that's usually fine. But if none of the vertices in a connected component are visible to any bones, then the matrix will not be invertible, and the solve will fail for all components. The solution would be to detect such cases, and then disable visibility tests for such components, or somehow get the weights from nearby components. Switching the code to use BMesh instead of Mesh would make that easier.
Author

Wow, the guy who created Cycles is still with us.
The cycles is the main reason why i love Bender.

You are awesome Brecht Van Lommel !!

Wow, the guy who created Cycles is still with us. The cycles is the main reason why i love Bender. You are awesome Brecht Van Lommel !!

Added subscribers: @AlexanderKrause, @cessen

Added subscribers: @AlexanderKrause, @cessen

As I wrote at the other report, that got merged to this one now:
Auto weights was a guaranteed process with 2.70 for humanoid characters, but it doesn't work at all since 2.75. And that is only with specifically Rigify generated rigs.
Most Rigify Video Tutorials including payed once are even mostly based on that process to distribute weights.

It's not just some bones failing but all of them.

As I wrote at the other report, that got merged to this one now: Auto weights was a guaranteed process with 2.70 for humanoid characters, but it doesn't work at all since 2.75. And that is only with specifically Rigify generated rigs. Most Rigify Video Tutorials including payed once are even mostly based on that process to distribute weights. It's not just some bones failing but all of them.

Added subscriber: @gregus

Added subscriber: @gregus

Hello,

I can't succeed in parenting a character to a rig with the "automatic weights" function. "Bone Heat Weighting: failed to find solution
for one or more bones" is always returned.
Character mesh seems okay, there are no separated parts and no non-manifolds vertex/edges.

1. select the character
2. select the rig
3. CTRL +P with "automatic weights"

Regards,

Gregus

System Information
win 7 SP1, GTX 670M

Blender Version
Broken: 2.78a and 2.78.4{F572514}

Hello, I can't succeed in parenting a character to a rig with the "automatic weights" function. "Bone Heat Weighting: failed to find solution for one or more bones" is always returned. Character mesh seems okay, there are no separated parts and no non-manifolds vertex/edges. 1. select the character 2. select the rig 3. CTRL +P with "automatic weights" Regards, Gregus System Information win 7 SP1, GTX 670M Blender Version Broken: 2.78a and 2.78.4{[F572514](https://archive.blender.org/developer/F572514/AUTOMATIC_WEIGHTS.blend)}

Right now "automatic weights" just leaves you with an error message.

Suggestions :

  1. When the script has an issue in solving the assignation of a weightmap to a specific bone,it should leave this bone and jump to the next one so that the process can go on on the rest of the mesh which is correct.
    Then, there can be an error message at the end of the process, but maybe 80-90 % of weightmaps are created and that's a big improvement.
    The remaining "bad parts " can later be manually assigned.

  2. the parts of the mesh with poly/vertex problems should be shown selected so that we know WHERE is the problem.AUTOMATIC WEIGHTS.blend

Right now "automatic weights" just leaves you with an error message. Suggestions : 1. When the script has an issue in solving the assignation of a weightmap to a specific bone,it should leave this bone and jump to the next one so that the process can go on on the rest of the mesh which is correct. Then, there can be an error message at the end of the process, but maybe 80-90 % of weightmaps are created and that's a big improvement. The remaining "bad parts " can later be manually assigned. 2. the parts of the mesh with poly/vertex problems should be shown selected so that we know WHERE is the problem.[AUTOMATIC WEIGHTS.blend](https://archive.blender.org/developer/F572516/AUTOMATIC_WEIGHTS.blend)

Added subscriber: @SpectreFirst

Added subscriber: @SpectreFirst

Huh, this is interesting. I have tested both cat.blend and automatic weights.blend and it seems that I was able to successfully use automatic weights by simply scaling models up about three times. For example, I can open automatic weights.blend, scale the model to its natural height of 1.65 m (2.5 scale), apply the scale, scale the Armature in Edit Mode to the same size (I used 3D Cursor as a base for scaling), Ctrl+P - Automatic Weight and after a while it successfully did what it supposed to. Cat.blend is harder to work with but if I scale the Armature about 3 times it seems to be working as well; there are still problems with very small details but weights were assigned without errors. All in all, it looks like there is a problem with small sizes and precision and scaling to bigger size worked for both cases.

Huh, this is interesting. I have tested both cat.blend and automatic weights.blend and it seems that I was able to successfully use automatic weights by simply scaling models up about three times. For example, I can open automatic weights.blend, scale the model to its natural height of 1.65 m (2.5 scale), apply the scale, scale the Armature in Edit Mode to the same size (I used 3D Cursor as a base for scaling), Ctrl+P - Automatic Weight and after a while it successfully did what it supposed to. Cat.blend is harder to work with but if I scale the Armature about 3 times it seems to be working as well; there are still problems with very small details but weights were assigned without errors. All in all, it looks like there is a problem with small sizes and precision and scaling to bigger size worked for both cases.

You can also consider acquire this plug-in and use atop of blender automatic weight painting:

https://www.blendermarket.com/products/voxel-heat-diffuse-skinning

It saved me a lot of trouble.

You can also consider acquire this plug-in and use atop of blender automatic weight painting: https://www.blendermarket.com/products/voxel-heat-diffuse-skinning It saved me a lot of trouble.
Member

Added subscriber: @Jeroen-Bakker

Added subscriber: @Jeroen-Bakker
Member

As mentioned the algorithm has flaws. Users find it a regression, so want to register this as a Known Issue.

As mentioned the algorithm has flaws. Users find it a regression, so want to register this as a Known Issue.

Added subscriber: @pauanyu_blender

Added subscriber: @pauanyu_blender
Philipp Oeser changed title from Bone Heat weighting: failed to Bone Heat weighting: failed (due to none of the vertices in an island being visible to any bones) 2021-08-03 10:51:27 +02:00
Member

Added subscribers: @shannonz, @lichtwerk

Added subscribers: @shannonz, @lichtwerk
Member

Added subscriber: @Sonship

Added subscriber: @Sonship
Member

Added subscribers: @JoseAntonioMolinero, @mod_moder

Added subscribers: @JoseAntonioMolinero, @mod_moder
Member

Added subscriber: @PratikPB2123

Added subscriber: @PratikPB2123
Philipp Oeser removed the
Interest
Animation & Rigging
label 2023-02-09 14:36:52 +01:00

I remember some talk about a new bone heat skinning method and some example papers. Thing is, sadly not can't seem to find this thread anymore. It showed some examples and I believe it had a link to a new approach for bone skinning. Does any one perhaps remember reading or seeing that post?

I remember some talk about a new bone heat skinning method and some example papers. Thing is, sadly not can't seem to find this thread anymore. It showed some examples and I believe it had a link to a new approach for bone skinning. Does any one perhaps remember reading or seeing that post?
Member

@RomboutVersluijs perhaps best to get in contact with the (Animation & Rigging)[https://projects.blender.org/blender/blender/wiki/Module:%20Animation%20&%20Rigging] module.

@RomboutVersluijs perhaps best to get in contact with the (Animation & Rigging)[https://projects.blender.org/blender/blender/wiki/Module:%20Animation%20&%20Rigging] module.
Jeroen Bakker added this to the Animation & Rigging project 2023-10-18 08:35:39 +02:00

@Jeroen-Bakker

Thanks for the heads-up. I'll try to do more searches for it

@Jeroen-Bakker Thanks for the heads-up. I'll try to do more searches for it
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
13 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#45493
No description provided.