Fresnel node: difference between 2.76 and 2.78 GLSL output #49372

Closed
opened 2016-09-16 10:01:19 +02:00 by Michael Otto · 13 comments

Blender Version
Broken: 2.76
Worked: 2.78

Short description of error
The GLSL viewport output (Renderer: Blaner internal / game) of the Fresnel node differs from 2.76 to 2.78

fresnel issue.blend

Exact steps for others to reproduce the error
open file in 2.76 and 2.78

fresnel issue.blend

**Blender Version** Broken: 2.76 Worked: 2.78 **Short description of error** The GLSL viewport output (Renderer: Blaner internal / game) of the Fresnel node differs from 2.76 to 2.78 [fresnel issue.blend](https://archive.blender.org/developer/F360968/fresnel_issue.blend) **Exact steps for others to reproduce the error** open file in 2.76 and 2.78 [fresnel issue.blend](https://archive.blender.org/developer/F360969/fresnel_issue.blend)

Changed status to: 'Open'

Changed status to: 'Open'

Added subscriber: @MichaelOtto

Added subscriber: @MichaelOtto

Added subscribers: @MikeErwin, @Sergey, @brecht, @mont29

Added subscribers: @MikeErwin, @Sergey, @brecht, @mont29

The fact that the result differs that not means it's a bug… But in this case new version is indeed bad - was regression between 2.76 and 2.77 it seems.

@Sergey, @MikeErwin, @brecht, one of you guys know more about it?

The fact that the result differs that not means it's a bug… But in this case new version is indeed bad - was regression between 2.76 and 2.77 it seems. @Sergey, @MikeErwin, @brecht, one of you guys know more about it?

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk

is this using the cycles Fresnel node? (not sure if this is even supposed to work with BI/GameEngine...)

is this using the cycles Fresnel node? (not sure if this is even supposed to work with BI/GameEngine...)
Sergey Sharybin self-assigned this 2016-09-16 10:54:58 +02:00

The fresnel seems wrong to me in the current master. My guess it's the normal space (world vs. camera). Checking that.

The fresnel seems wrong to me in the current master. My guess it's the normal space (world vs. camera). Checking that.

change came in 002de

change came in 002de

Hi, I was a little in a haste because I had a meeting starting... sorry. Here's my addition

I also have the impression that it's something with the normals. When you disconnect the normals from the geom node, it gives correct results ("correct" = looks as exspected by me ;) )

Hi, I was a little in a haste because I had a meeting starting... sorry. Here's my addition I also have the impression that it's something with the normals. When you disconnect the normals from the geom node, it gives correct results ("correct" = looks as exspected by me ;) )

@Sergey: cycles viewport seems fine to me, you mean BI/BGE use camera space normals whereas cycles uses world?

@Sergey: cycles viewport seems fine to me, you mean BI/BGE use camera space normals whereas cycles uses world?

@MichaelOtto: yep if you dont have a normal connected it will use GPU_VIEW_NORMAL, if you've got somethink linked it multiplies GPU_VIEW_MATRIX with this

@MichaelOtto: yep if you dont have a normal connected it will use GPU_VIEW_NORMAL, if you've got somethink linked it multiplies GPU_VIEW_MATRIX with this

This issue was referenced by 4b046c530d

This issue was referenced by 4b046c530d3e14d7737c4770b9ae07942f4c6047

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest: Wayland
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#49372
There is no content yet.