Material with normal map/bump mapping produces damaged penumbra on mesh (Cycles). #49921

Closed
opened 2016-11-02 22:50:12 +01:00 by Lex · 6 comments

System Information
Windows 10 with GTX 1070

Blender Version
2.78

Short description of error
Here is screenshot of the problem - blocky artifacts on areas with penumbra (Cycles render):
Screenshot
This happens both for materials with normal maps and also with bump mapping.

Exact steps for others to reproduce the error

  1. Open attached scene (s).
  2. Switch viewport shading mode to "Rendered" (CPU or GPU - not matter).

Normal mapping penumbra selfshadows bug.blend
Bump mapping penumbra selfshadows bug.blend

**System Information** Windows 10 with GTX 1070 **Blender Version** 2.78 **Short description of error** Here is screenshot of the problem - blocky artifacts on areas with penumbra (Cycles render): [Screenshot ](https://www.dropbox.com/s/4ugmp184y0j0ung/Normal%20Map%20bug%20with%20shadow.png?dl=0) This happens both for materials with normal maps and also with bump mapping. **Exact steps for others to reproduce the error** 1. Open attached scene (s). 2. Switch viewport shading mode to "Rendered" (CPU or GPU - not matter). [Normal mapping penumbra selfshadows bug.blend](https://archive.blender.org/developer/F390988/Normal_mapping_penumbra_selfshadows_bug.blend) [Bump mapping penumbra selfshadows bug.blend](https://archive.blender.org/developer/F390987/Bump_mapping_penumbra_selfshadows_bug.blend)
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @Lex4art

Added subscriber: @Lex4art

Added subscribers: @Sergey, @mont29

Added subscribers: @Sergey, @mont29

This looks like the classical terminator issue to me, @Sergey?

This looks like the classical terminator issue to me, @Sergey?

Changed status from 'Open' to: 'Archived'

Changed status from 'Open' to: 'Archived'
Sergey Sharybin self-assigned this 2016-12-02 12:43:44 +01:00

It is indeed a terminator problem. Happens when there's too much difference between bump normal and a real geometric one -- it's possible to have ray which bounced below the surface, which causes such shading artifacts. Workaround is to apply subsurf modifier on the object.

There might be tricks to solve this without too much overhead, but currently it's not considered a bug.

Thanks for the report anyway.

It is indeed a terminator problem. Happens when there's too much difference between bump normal and a real geometric one -- it's possible to have ray which bounced below the surface, which causes such shading artifacts. Workaround is to apply subsurf modifier on the object. There might be tricks to solve this without too much overhead, but currently it's not considered a bug. Thanks for the report anyway.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#49921
No description provided.