Denoising progressive refine issue #51712

Closed
opened 2017-06-03 23:17:09 +02:00 by Eric Leo · 11 comments

System Information
OS X 10.10.5, 32gb Ram, 6core intel Xeon - mid 2010.
ATI Radeon

Blender Version
daily build blender-2.78.0-git20170603.420d4a70b8-x86_64

Short description of error
Denoising not working when render performance "progressive refine" is enabled. When progressive refine is disabled denoising works as expected

Exact steps for others to reproduce the error
denoising progressive refine issue.blend.zip

denoising progressive refine issue.blend.zip

**System Information** OS X 10.10.5, 32gb Ram, 6core intel Xeon - mid 2010. ATI Radeon **Blender Version** daily build blender-2.78.0-git20170603.420d4a70b8-x86_64 **Short description of error** Denoising not working when render performance "progressive refine" is enabled. When progressive refine is disabled denoising works as expected **Exact steps for others to reproduce the error** [denoising progressive refine issue.blend.zip](https://archive.blender.org/developer/F618279/denoising_progressive_refine_issue.blend.zip) [denoising progressive refine issue.blend.zip](https://archive.blender.org/developer/F618304/denoising_progressive_refine_issue.blend.zip)
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @stargazer

Added subscriber: @stargazer

Added subscriber: @FloridaJo

Added subscriber: @FloridaJo
Lukas Stockner was assigned by Joel Godin 2017-06-03 23:48:20 +02:00

True here as well.

True here as well.
Member

Changed status from 'Open' to: 'Archived'

Changed status from 'Open' to: 'Archived'
Member

Thanks for the report, but this isn't a bug, it's simply not supported (yet).

Thanks for the report, but this isn't a bug, it's simply not supported (yet).

Added subscriber: @brecht

Added subscriber: @brecht

Can we automatically grey out progressive refine when denoising is enabled, and then disable it inside Cycles for rendering? Would also be good to mention this in the release notes.

Can we automatically grey out progressive refine when denoising is enabled, and then disable it inside Cycles for rendering? Would also be good to mention this in the release notes.
Author

Really good idea to grey out progressive refine. Without it greyed out people will think blender is broken.

Really good idea to grey out progressive refine. Without it greyed out people will think blender is broken.

Added subscriber: @EjnarBrendsdal

Added subscriber: @EjnarBrendsdal

A little mention on this.
It seems confusing to me that the progressive option is greyed out with no mentioned that it is because i had denoising turned on.
My colleague suggested that maybe the denoising options should be placed in render settings under performance as well, but I see that the interface is frozen due to 2.8 and it is a larger decision which has probably already been discussed at length...
But could this at least be mentioned in the tool tip?

A little mention on this. It seems confusing to me that the progressive option is greyed out with no mentioned that it is because i had denoising turned on. My colleague suggested that maybe the denoising options should be placed in render settings under performance as well, but I see that the interface is frozen due to 2.8 and it is a larger decision which has probably already been discussed at length... But could this at least be mentioned in the tool tip?
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#51712
No description provided.