Graph editor "normalize" drag errors for integers #52086

Closed
opened 2017-07-17 08:08:55 +02:00 by Konstantins Visnevskis · 7 comments

System Information
Win8.1x64, 3x gtx580

Blender Version
2.79t1

Short description of error
In graph editor, if normalize is activated:

  1. dragging keyframe resets value range to -1..1
  2. Cancelling the drag action doesn't return the keyframe to it's original position.

Exact steps for others to reproduce the error

  • Select the second keyframe (value>1) and drag.
  • keyframe jumps to value of range -1..1
    kn.blend
**System Information** Win8.1x64, 3x gtx580 **Blender Version** 2.79t1 **Short description of error** In graph editor, if normalize is activated: 1. dragging keyframe resets value range to -1..1 2. Cancelling the drag action doesn't return the keyframe to it's original position. **Exact steps for others to reproduce the error** - Select the second keyframe (value>1) and drag. - keyframe jumps to value of range -1..1 [kn.blend](https://archive.blender.org/developer/F669736/kn.blend)

Changed status to: 'Open'

Changed status to: 'Open'

Added subscriber: @KonstantinsVisnevskis

Added subscriber: @KonstantinsVisnevskis
Sergey Sharybin self-assigned this 2017-07-18 10:26:09 +02:00

Added subscriber: @zeauro

Added subscriber: @zeauro

Pressing Normalize button should immediately reduce steps of the curve. It is not the case. Instead it displays 13 steps that correspond to curve before pressing Normalize button.
We have to drag keyframe and cancel the drag to refresh graph editor to display a coherent number of steps for a range of -1..1. The only available 3 steps for this range : -1,0,1.

But basically, cancelling drag action always return keyframe to its original position for me.
Moved keyframe returns to frame 10 and value 1 or value 12 visually normalized to 1.

Refreshing that we are doing by cancelled drag action can be reverted by a Ctrl Z.
So, there is always ability to cancel normalize action and go back to -1..12 range original curve simply by unpressing Normalize button.

There is an obvious refreshing problem but it is not really a pratical problem because we have workaround to force it or to restore previous state.

Pressing Normalize button should immediately reduce steps of the curve. It is not the case. Instead it displays 13 steps that correspond to curve before pressing Normalize button. We have to drag keyframe and cancel the drag to refresh graph editor to display a coherent number of steps for a range of -1..1. The only available 3 steps for this range : -1,0,1. But basically, cancelling drag action always return keyframe to its original position for me. Moved keyframe returns to frame 10 and value 1 or value 12 visually normalized to 1. Refreshing that we are doing by cancelled drag action can be reverted by a Ctrl Z. So, there is always ability to cancel normalize action and go back to -1..12 range original curve simply by unpressing Normalize button. There is an obvious refreshing problem but it is not really a pratical problem because we have workaround to force it or to restore previous state.

Ok, depends on priorities probably. But there is still a problem of keyframes being inserted with -1..1 clipping, which was the main point.

Ok, depends on priorities probably. But there is still a problem of keyframes being inserted with -1..1 clipping, which was the main point.

This issue was referenced by 9ddee885ae

This issue was referenced by 9ddee885aea4d026bb0409a51a137706c95d318b

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#52086
No description provided.