hole in bake normal #52679

Closed
opened 2017-09-08 05:55:30 +02:00 by bdp · 19 comments

System Information
windows 10
graphics card : NVDIA GeForce GT 610/PCIe/SSE2

Blender Version
Broken: (blender 2.79 rc2)

Short description of error
hole in bake normal
hole-bake.png
bake hole.blend

Exact steps for others to reproduce the error

  1. open my files
  2. press bake
  3. you will see hole transparent in image
**System Information** windows 10 graphics card : NVDIA GeForce GT 610/PCIe/SSE2 **Blender Version** Broken: (blender 2.79 rc2) **Short description of error** hole in bake normal ![hole-bake.png](https://archive.blender.org/developer/F778595/hole-bake.png) [bake hole.blend](https://archive.blender.org/developer/F778610/bake_hole.blend) **Exact steps for others to reproduce the error** 1. open my files 2. press bake 3. you will see hole transparent in image
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @bdp

Added subscriber: @bdp

Added subscriber: @dfelinto

Added subscriber: @dfelinto

Was this working with old Blenders? (e.g., 2.78)? Are you using Cycles or BI?

Was this working with old Blenders? (e.g., 2.78)? Are you using Cycles or BI?

Also please simplify the file. You should be able to isolate the problem to a few polygons only.

Also please simplify the file. You should be able to isolate the problem to a few polygons only.
Author

this file test use 2.78 , 2.79rc2 result hole.
use cycles

this file test use 2.78 , 2.79rc2 result hole. use cycles

Are you sure? I tried here with 2.78a and:

  • You are using a principled node, which hasn't been in any official Blender
  • In 2.78a I see the hole
Are you sure? I tried here with 2.78a and: * You are using a principled node, which hasn't been in any official Blender * In 2.78a I see the hole

The other thing that would be helpful is to see if you have this issue with Blender Internal too.

The other thing that would be helpful is to see if you have this issue with Blender Internal too.
Author

my original file is 2.79rc2
for testing i use 2.78c then i use diffuse bsdf

i didnt see problem with blender internal.
its problem appear when use cycles.

my original file is 2.79rc2 for testing i use 2.78c then i use diffuse bsdf i didnt see problem with blender internal. its problem appear when use cycles.
Author

@dfelinto: i try test again this file.. i try edit unwrap this model then bake normal, result hole disappear..
problem solved.
i dont know its bug or not .. but change unwrap on model solve this hole

@dfelinto: i try test again this file.. i try edit unwrap this model then bake normal, result hole disappear.. problem solved. i dont know its bug or not .. but change unwrap on model solve this hole

Added subscriber: @brecht

Added subscriber: @brecht

I can confirm the issue, looks like a bug to me.

I can confirm the issue, looks like a bug to me.

Sure it is a bug, but I was hoping to spare developers' time for tasks that the reporter could do, such as simplifying the file.

Sure it is a bug, but I was hoping to spare developers' time for tasks that the reporter could do, such as simplifying the file.

Added subscriber: @NahuelBelich

Added subscriber: @NahuelBelich

@dfelinto
not sure if it helps now but i simplified the file isolating the the problematic face.
bake hole1.blend

ill test a few things on a 6859695 and RC2 , all test was done resetting blender and doing a bake before to test that if its failing when i open the file:

  • rotate the uv 3º to 8º and the problem solves --> rotate back - 3º to 8º to return the uvs to the same place and the problem still solved
  • move among 5 to 12 pixels any uv vertex in a single axis and its solves, it was kind of random on this too, try this one like seven times and a few where where fixed on different values, return to position and the problem still solved
  • add one more subdivision and it solves.
  • Baking Object instead of tangent normals, doesn't show the error.
  • BI also works OK

I could however, move or rotate the uvs to "fix" the issue, but if i return the uvs to its original location using Ctrl+Z the problem returns.

@dfelinto not sure if it helps now but i simplified the file isolating the the problematic face. [bake hole1.blend](https://archive.blender.org/developer/F780728/bake_hole1.blend) ill test a few things on a 6859695 and RC2 , all test was done resetting blender and doing a bake before to test that if its failing when i open the file: - rotate the uv 3º to 8º and the problem solves --> rotate back - 3º to 8º to return the uvs to the same place and the problem still solved - move among 5 to 12 pixels any uv vertex in a single axis and its solves, it was kind of random on this too, try this one like seven times and a few where where fixed on different values, return to position and the problem still solved - add one more subdivision and it solves. - Baking Object instead of tangent normals, doesn't show the error. - BI also works OK I could however, move or rotate the uvs to "fix" the issue, but if i return the uvs to its original location using Ctrl+Z the problem returns.

This issue was referenced by 4aee701f00

This issue was referenced by 4aee701f0028fbf17103a5565d72e05bbfcc8d9f

Added subscriber: @Sergey

Added subscriber: @Sergey
Sergey Sharybin self-assigned this 2017-09-12 11:18:13 +02:00

Prepared possible fix D2837.

Prepared possible fix [D2837](https://archive.blender.org/developer/D2837).

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
6 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#52679
No description provided.