Percent mode in Bevel operation does not work. #52733

Closed
opened 2017-09-13 21:33:51 +02:00 by Bart · 12 comments

System Information
Windows 7 64bit with latest updates, GTX 780 6GB edition, Intel i5 4670K

Blender Version
Broken: 2.79 (official)
Worked: 2.78a (official)

Short description of error

Using the percent mode in the Bevel operation does not give a result. Other modes work fine. The value for determining the amount of Bevel suddenly looks like this: 1.#QNAN0

Boolean_percent.png

Exact steps for others to reproduce the error

  1. Open default scene.
  2. Slect default cube and go into edit mode.
  3. Press CTRL+b to enter Bevel operation.
  4. Assign a value.
  5. Go into "Percent" mode.
  6. Nothing will happen, your selected edge won't show. Bevel value can not be assigned.
**System Information** Windows 7 64bit with latest updates, GTX 780 6GB edition, Intel i5 4670K **Blender Version** Broken: 2.79 (official) Worked: 2.78a (official) **Short description of error** Using the percent mode in the Bevel operation does not give a result. Other modes work fine. The value for determining the amount of Bevel suddenly looks like this: 1.#QNAN0 ![Boolean_percent.png](https://archive.blender.org/developer/F795591/Boolean_percent.png) **Exact steps for others to reproduce the error** 1. Open default scene. 2. Slect default cube and go into edit mode. 3. Press CTRL+b to enter Bevel operation. 4. Assign a value. 5. Go into "Percent" mode. 6. Nothing will happen, your selected edge won't show. Bevel value can not be assigned.
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @JernejCerne

Added subscriber: @JernejCerne

Added subscriber: @VukGardasevic

Added subscriber: @VukGardasevic

I can confirm with 2.79 factory startup, selecting an edge > ctrl +b > pressing M for flipping through modes until percent is chosen. The percentage gets a -1.#QNAN value.

Note the task was originally referring to Boolean but clearly points out to Bevel.

I can confirm with 2.79 factory startup, selecting an edge > ctrl +b > pressing M for flipping through modes until percent is chosen. The percentage gets a `-1.#QNAN ` value. Note the task was originally referring to Boolean but clearly points out to Bevel.
Vuk Gardašević changed title from Percent mode in Boolean operation does not work. to Percent mode in Bevel operation does not work. 2017-09-13 22:20:30 +02:00
Author

Yes sorry. I was really tired when I wrote this post, still am. Don't know how I managed to confuse the two. Sorry again.
Just for info. I opened one of my older files created in 2.78a. Bevel in percent mode worked fine.

Yes sorry. I was really tired when I wrote this post, still am. Don't know how I managed to confuse the two. Sorry again. Just for info. I opened one of my older files created in 2.78a. Bevel in percent mode worked fine.
Member

Added subscribers: @howardt, @JoshuaLeung

Added subscribers: @howardt, @JoshuaLeung
Howard Trickey was assigned by Joshua Leung 2017-09-14 13:33:03 +02:00
Member

Assigning to @howardt

Assigning to @howardt
Member

Strange, it works fine for me on Linux. I will try on Windows when I get a chance and see if I can reproduce there.

Strange, it works fine for me on Linux. I will try on Windows when I get a chance and see if I can reproduce there.

Hm, going back and retesting there seems to be a difference between enabling the debug option or not.

Starting with blender --factory-startup -d seems to produce the error while without the -d argument it doesn't.

Hm, going back and retesting there seems to be a difference between enabling the debug option or not. Starting with `blender --factory-startup -d` seems to produce the error while without the -d argument it doesn't.
Member

Thanks, can confirm that that happens now.

Thanks, can confirm that that happens now.

This issue was referenced by 96ce50449c

This issue was referenced by 96ce50449c3060514e28d79d7e488d0d2b16354e
Member

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#52733
No description provided.