Severe rendering delay in scene data preparation when using an array modifier #52818

Closed
opened 2017-09-18 17:46:17 +02:00 by Mark Raynsford · 9 comments

System Information
Linux copperhead 4.12.13-1-ARCH #1 SMP PREEMPT Fri Sep 15 06:36:43 UTC 2017 x86_64 GNU/Linux

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
OpenGL core profile version string: 3.3 (Core Profile) Mesa 17.2.0
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.2.0
OpenGL shading language version string: 1.30

Blender Version
Broken: 2.79 8ef39d5c88

See attached system-info.txt: system-info.txt

Short description of error

Using an array modifier to create ~70 instances of a 12k triangle model results in an enormous delay
before rendering. Blender appears to be "Preparing scene data" but tile rendering still hasn't started
after about ten minutes of waiting.

I use array modifiers heavily in all of my projects and haven't seen any problem like this prior to today, and I very recently upgraded to 2.79, so I suspect an issue may have been introduced there.

Exact steps for others to reproduce the error

Please see "array_append.blend" in the repository at https://github.com/io7m/blender-perf-20170918

Just click render.

**System Information** Linux copperhead 4.12.13-1-ARCH #1 SMP PREEMPT Fri Sep 15 06:36:43 UTC 2017 x86_64 GNU/Linux OpenGL vendor string: Intel Open Source Technology Center OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile OpenGL core profile version string: 3.3 (Core Profile) Mesa 17.2.0 OpenGL core profile shading language version string: 3.30 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile OpenGL core profile extensions: OpenGL version string: 3.0 Mesa 17.2.0 OpenGL shading language version string: 1.30 **Blender Version** Broken: 2.79 8ef39d5c882 See attached system-info.txt: [system-info.txt](https://archive.blender.org/developer/F813695/system-info.txt) **Short description of error** Using an array modifier to create ~70 instances of a 12k triangle model results in an enormous delay before rendering. Blender appears to be "Preparing scene data" but tile rendering still hasn't started after about ten minutes of waiting. I use array modifiers heavily in all of my projects and haven't seen any problem like this prior to today, and I very recently upgraded to 2.79, so I suspect an issue may have been introduced there. **Exact steps for others to reproduce the error** Please see "array_append.blend" in the repository at https://github.com/io7m/blender-perf-20170918 Just click render.
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @io7m

Added subscriber: @io7m

Added subscriber: @Sergey

Added subscriber: @Sergey
Sergey Sharybin self-assigned this 2017-09-19 13:52:47 +02:00

Caused by some O(N^2) complexity in tangent space calculation. Will check if it's possible to speed up something.

Caused by some O(N^2) complexity in tangent space calculation. Will check if it's possible to speed up something.

Workaround would be to remove degenerated faces, by, i.e., removing doubles in edit mode.

Workaround would be to remove degenerated faces, by, i.e., removing doubles in edit mode.
Author

Ouch!

I have no idea how these degenerate faces found their way into the mesh. Is there any way to show where they are in the viewport? Removing doubles eliminates over a thousand vertices, and that's just insane... Something clearly went very wrong when the chair was joined.

Eliminating a O(N^2) time complexity still sounds like a good idea, though.

Ouch! I have no idea how these degenerate faces found their way into the mesh. Is there any way to show where they are in the viewport? Removing doubles eliminates over a thousand vertices, and that's just insane... Something clearly went very wrong when the chair was joined. Eliminating a O(N^2) time complexity still sounds like a good idea, though.

This issue was referenced by 3241905f40

This issue was referenced by 3241905f40e11ffc276bcca09033c045eaad70cd

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Author

Thanks for the impressively quick response, as ever!

Thanks for the impressively quick response, as ever!
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#52818
No description provided.