collada exporter transform geometry randomly if camera is exported #52831

Closed
opened 2017-09-19 16:58:53 +02:00 by mathieu menuet · 9 comments

System Information
Windows 7 x64

Blender Version
Broken: 2.79 release

Short description of error
When exporting a scene with a camera, geometry will be randomly transformed.

Exact steps for others to reproduce the error
Open Attached file, export with this settings:
bug export dae v2.blend
bug export collada.PNG
This is the original ( and the result of export + import when camera isn't selected)
bug export collada original.PNG
This is the original plus the result of export and import (when the camera is also exported)
bug export collada result with camera.PNG

Do the same thing without the camera selected and export will be good... for some reason.

**System Information** Windows 7 x64 **Blender Version** Broken: 2.79 release **Short description of error** When exporting a scene with a camera, geometry will be randomly transformed. **Exact steps for others to reproduce the error** Open Attached file, export with this settings: [bug export dae v2.blend](https://archive.blender.org/developer/F825391/bug_export_dae_v2.blend) ![bug export collada.PNG](https://archive.blender.org/developer/F825127/bug_export_collada.PNG) This is the original ( and the result of export + import when camera isn't selected) ![bug export collada original.PNG](https://archive.blender.org/developer/F825129/bug_export_collada_original.PNG) This is the original plus the result of export and import (when the camera is also exported) ![bug export collada result with camera.PNG](https://archive.blender.org/developer/F825131/bug_export_collada_result_with_camera.PNG) Do the same thing without the camera selected and export will be good... for some reason.
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @bliblubli

Added subscriber: @bliblubli
Author

Added subscriber: @GaiaClary

Added subscriber: @GaiaClary
Gaia Clary was assigned by mathieu menuet 2017-09-19 16:59:18 +02:00
Member

Thanks for the report but it would be helpful if you add a blend-file to the report that demonstrates the issue at hand.
I could not reproduce this behavior when i export a simple scene with camera and 2 objects.

Thanks for the report but it would be helpful if you add a blend-file to the report that demonstrates the issue at hand. I could not reproduce this behavior when i export a simple scene with camera and 2 objects.
Author
oups sorry [bug export dae v2.blend](https://archive.blender.org/developer/F825391/bug_export_dae_v2.blend)
Author

After testing many versions, Bug is already present in 2.74.

After testing many versions, Bug is already present in 2.74.

This issue was referenced by 26f98446b1

This issue was referenced by 26f98446b17f418a633a1420a491e5ad0b59b988
Member

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Member

the problem was that as soon as animations are exported the Exporter enforced the decomposition of Object matrices into Location and x/y/z rotation. It looks like this decomposition is obsolete, so i removed it. Now the export/import of the scene seems to work as expected.

I also tested a character animation (export/import back) and that seems to work as well.

the problem was that as soon as animations are exported the Exporter enforced the decomposition of Object matrices into Location and x/y/z rotation. It looks like this decomposition is obsolete, so i removed it. Now the export/import of the scene seems to work as expected. I also tested a character animation (export/import back) and that seems to work as well.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#52831
No description provided.