View - Clip values are reseting when switch in Object Local View #52959

Closed
opened 2017-09-30 16:16:55 +02:00 by Daniel Toma · 8 comments

System Information
macOS

Blender Version
Broken: 2.79
Worked: (optional)

Short description of error
Camera Clip values are reseting every time I enter in User Persp (Local)

Exact steps for others to reproduce the error
3D View Editor - Properties - View - Clip - Change values.
Select an object enter in Local View with " \ " shortcut.
The values are reseting to the default ones 0.100 / 1000.000

**System Information** macOS **Blender Version** Broken: 2.79 Worked: (optional) **Short description of error** Camera Clip values are reseting every time I enter in User Persp (Local) **Exact steps for others to reproduce the error** 3D View Editor - Properties - View - Clip - Change values. Select an object enter in Local View with " \ " shortcut. The values are reseting to the default ones 0.100 / 1000.000
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @DanielToma

Added subscriber: @DanielToma

Added subscriber: @zeauro

Added subscriber: @zeauro

Please attach a .blend fle demonstrating the problem.

I can't reproduce on linux (ubuntu 16.04 64bits) with both official 2.79 and master.

Please attach a .blend fle demonstrating the problem. I can't reproduce on linux (ubuntu 16.04 64bits) with both official 2.79 and master.
Author

I've done some test and I realise that if I change the clip value in Local mode when exit from Local the value is changing to the initial one.
Don't know if this is the normal.
At the begining didn't notice this comportment, I thought that is reseting the value all the time.

I've done some test and I realise that if I change the clip value in Local mode when exit from Local the value is changing to the initial one. Don't know if this is the normal. At the begining didn't notice this comportment, I thought that is reseting the value all the time.

OK !
I can reproduce and confirm the issue.

It looks like is a little inconsistency, here. Any setting of View panel is kept during a switching between local/global view.
If Lens value is preserved, I would be logical that clipping would be preserved, too.

But in practice, when you are switching from Global View to Local View, you are zooming from a scene with a large amount of assets to only selected ones.
If you are changing clipping in Local view, probability that theses values are annoying in Global View is stronger than the reverse action : changing settings in Global View.
It is probably the reason of current behaviour.

Having specific settings or preferences for Local View could be discussed as an UI Design task. Currently, there is no solution for fast hiding in 2.8 branch.
Collections definition and distribution on different renderlayers is a slow process.
And 3DView settings are independent of renderlayers.
So, this ability of blender to switch quickly between a component object and an assembly for fast modeling is not restored in 2.8, yet.
Solution may be a new Local View or a completely different tool.
But with an uncertain future of Local View, this little clipping change preference is not really a priority.

OK ! I can reproduce and confirm the issue. It looks like is a little inconsistency, here. Any setting of View panel is kept during a switching between local/global view. If Lens value is preserved, I would be logical that clipping would be preserved, too. But in practice, when you are switching from Global View to Local View, you are zooming from a scene with a large amount of assets to only selected ones. If you are changing clipping in Local view, probability that theses values are annoying in Global View is stronger than the reverse action : changing settings in Global View. It is probably the reason of current behaviour. Having specific settings or preferences for Local View could be discussed as an UI Design task. Currently, there is no solution for fast hiding in 2.8 branch. Collections definition and distribution on different renderlayers is a slow process. And 3DView settings are independent of renderlayers. So, this ability of blender to switch quickly between a component object and an assembly for fast modeling is not restored in 2.8, yet. Solution may be a new Local View or a completely different tool. But with an uncertain future of Local View, this little clipping change preference is not really a priority.

This issue was referenced by 7d3723a54d

This issue was referenced by 7d3723a54d8a809d5c95b235e90a12e2f6295f0e

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#52959
No description provided.