Parent bone name disappeared in the UI in pose mode #52977

Closed
opened 2017-10-02 17:07:39 +02:00 by Erick Tukuniata · 14 comments

System Information
Operating system and graphics card win 7 gtx 550ti geforce

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen) Blender 2.79.1 64c1a48 it seems like it had been there more than a month
Worked: (optional) Blender 2.79.1 b4b1397

Short description of error
Parent bone name disappeared in the UI in pose mode

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  • Make sure that bone have a parent
  • Go to pose mode
  • In the bone tab, relations panel you can only see the word "Parent" and bone icon but the given name is not displayed.
**System Information** Operating system and graphics card win 7 gtx 550ti geforce **Blender Version** Broken: (example: 2.69.7 4b206af, see splash screen) Blender 2.79.1 64c1a48 it seems like it had been there more than a month Worked: (optional) Blender 2.79.1 b4b1397 **Short description of error** Parent bone name disappeared in the UI in pose mode **Exact steps for others to reproduce the error** Based on a (as simple as possible) attached .blend file with minimum amount of steps - Make sure that bone have a parent - Go to pose mode - In the bone tab, relations panel you can only see the word "Parent" and bone icon but the given name is not displayed.

Changed status to: 'Open'

Changed status to: 'Open'

Added subscriber: @ErickNyanduKabongo

Added subscriber: @ErickNyanduKabongo

Oops i forgot the image
bug.png

Oops i forgot the image ![bug.png](https://archive.blender.org/developer/F929577/bug.png)

Added subscriber: @VukGardasevic

Added subscriber: @VukGardasevic

I can confirm the issue on Win 7 with build 5c6e3ff from 28. September.

Seems that the line in the properties_data_bone.py script in class BONE_PT_relations

col.prop(bone, "parent", text="")

doesn't display anything apart from the icon.

That seems to work in 2.79 release.

A workaround would be:

        if context.bone:
            # col.prop(bone, "parent", text="")
            bone_name = bone.parent.name if bone.parent else "No Parent Bone Found"
            box = col.box()
            box.scale_y = 0.5
            box.label(text=bone_name, icon='BONE_DATA')
        else:
        
            col.prop_search(bone, "parent", arm, "edit_bones", text="")

however it's better to see what the issue really is as it can affect other areas.

I can confirm the issue on Win 7 with build `5c6e3ff` from 28. September. Seems that the line in the `properties_data_bone.py` script in `class BONE_PT_relations` ``` col.prop(bone, "parent", text="") ``` doesn't display anything apart from the icon. That seems to work in 2.79 release. A workaround would be: ``` if context.bone: # col.prop(bone, "parent", text="") bone_name = bone.parent.name if bone.parent else "No Parent Bone Found" box = col.box() box.scale_y = 0.5 box.label(text=bone_name, icon='BONE_DATA') else: col.prop_search(bone, "parent", arm, "edit_bones", text="") ``` however it's better to see what the issue really is as it can affect other areas.
Member

Added subscriber: @JoshuaLeung

Added subscriber: @JoshuaLeung
Julian Eisel was assigned by Joshua Leung 2017-10-20 06:00:54 +02:00
Member

This seems related to a UI widgets bug, where setting text="" on a widget to hide the label ends up causing the widget to be displayed incorrectly. For example:

  1. Using text="" on an enum with the expand=True set will result in the enum buttons having no labels. (To test, try doing this on the Armature "Ghost" panel - DATA_PT_ghost)
  2. Modify a UI List row template to only draw an icon + blank text, and no icon will be drawn
This seems related to a UI widgets bug, where setting `text=""` on a widget to hide the label ends up causing the widget to be displayed incorrectly. For example: 1) Using `text=""` on an enum with the `expand=True` set will result in the enum buttons having no labels. (To test, try doing this on the Armature "Ghost" panel - `DATA_PT_ghost`) 2) Modify a UI List row template to only draw an icon + blank text, and no icon will be drawn

Bump, It seems like Blender 2.79a is getting closer. Can someone have a look? This bug is really disturbing when trying to debug your relation in pose mode.

Bump, It seems like Blender 2.79a is getting closer. Can someone have a look? This bug is really disturbing when trying to debug your relation in pose mode.
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

yes, this is also caused by c57636f060
see #53630 (Effect strips not displaying Input data)

yes, this is also caused by c57636f060 see #53630 (Effect strips not displaying Input data)

Added subscribers: @JulianEisel, @mont29

Added subscribers: @JulianEisel, @mont29
Julian Eisel was unassigned by Bastien Montagne 2017-12-28 09:40:24 +01:00
Bastien Montagne self-assigned this 2017-12-28 09:40:24 +01:00

Yuck, usual UI code mess…

Yuck, usual UI code mess…

This issue was referenced by 17f1ce4d4f

This issue was referenced by 17f1ce4d4fdb2da5cf9deafaadf5d0031cd485ff

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
6 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#52977
No description provided.