Image texture node, sequence doesnt preview in viewport #53129

Closed
opened 2017-10-22 17:54:38 +02:00 by Peter Boos · 8 comments

System Information
Operating system and graphics card

Blender Version
Broken: (example: 2.79 5bd8ac9)

Short description of error

Exact steps for others to reproduce the error
In VSE create a movie from an image strip, render to movie, then it wil output 001-008.mkv (8 images or so).

In another blend file (or on a different layer) :
In cycles use this mkv as movie sequence, for the texture node.
Assign texture node to emission object, and put it to a plane (or use addon pictures to planes).

you can use offset or start frame, or move to a specific time on the strip, but the texture out in image seqeunce stays at the first picture.
In rendering it seams to work, but it doesnt work in viewport mode, so if one tried to show a few pictures or wants to sync to some specific time (ea animating the of set), isnt workable in viewport.

**System Information** Operating system and graphics card **Blender Version** Broken: (example: 2.79 5bd8ac9) **Short description of error** **Exact steps for others to reproduce the error** In VSE create a movie from an image strip, render to movie, then it wil output 001-008.mkv (8 images or so). In another blend file (or on a different layer) : In cycles use this mkv as movie sequence, for the texture node. Assign texture node to emission object, and put it to a plane (or use addon pictures to planes). you can use offset or start frame, or move to a specific time on the strip, but the texture out in image seqeunce stays at the first picture. In rendering it seams to work, but it doesnt work in viewport mode, so if one tried to show a few pictures or wants to sync to some specific time (ea animating the of set), isnt workable in viewport.
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @PeterBoos

Added subscriber: @PeterBoos

Added subscriber: @zeauro

Added subscriber: @zeauro

It may be just default preferences for Timeline Editor that are the reason of problem.

By default, editors enabled under Playback menu of Timeline Editor are All 3D Views and Animation Editors.
https://docs.blender.org/manual/en/dev/editors/timeline.html#playback-menu

But it is not sufficient. You have to enable Property Editors checkbox , too in order to see an image sequence updated in viewport.
Properties to refresh the image are dependent of this editor.

Is it the case ?

It may be just default preferences for Timeline Editor that are the reason of problem. By default, editors enabled under Playback menu of Timeline Editor are All 3D Views and Animation Editors. https://docs.blender.org/manual/en/dev/editors/timeline.html#playback-menu But it is not sufficient. You have to enable Property Editors checkbox , too in order to see an image sequence updated in viewport. Properties to refresh the image are dependent of this editor. Is it the case ?
Author

No, or if it should then its not working, neither for mkv movie or jpg image series.
Not for CPU and not for GPU (if only CPU worked would allready be fine to me).

No, or if it should then its not working, neither for mkv movie or jpg image series. Not for CPU and not for GPU (if only CPU worked would allready be fine to me).

I still does not manage to reproduce the issue under linux. For me, when it works for rendering, it works in viewport.

Please, provide info required by template (Operating system and graphics card, blender version that is broken, last version when it worked...) .

It would be helpful if you add mkv created or little jpg image serie and a blend-file to the report that demonstrates the issue at hand.

Marking as "Incomplete" until the requested information/data is provided.

I still does not manage to reproduce the issue under linux. For me, when it works for rendering, it works in viewport. Please, provide info required by template (Operating system and graphics card, blender version that is broken, last version when it worked...) . It would be helpful if you add mkv created or little jpg image serie and a blend-file to the report that demonstrates the issue at hand. Marking as "Incomplete" until the requested information/data is provided.

This issue was referenced by 0e3fd70d7a

This issue was referenced by 0e3fd70d7ac62c12ed85d3a90266994fac26bad0

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#53129
No description provided.