import a fbx then export a dae file, blender crashed, (always) #53230

Closed
opened 2017-11-02 10:27:08 +01:00 by xiwen · 17 comments

System Information
macOS 10.13.1
iMac late 2013

Blender Version
version 2.79

Worked: (optional)

Short description of error
import a fbx then export a dae file, blender crashed, (always)

Exact steps for others to reproduce the error

  1. open blender
  2. remove box
  3. import a fbx
  4. export to dae
  5. crash

crash log:

blender.crash

model sample:

Sapphiart_model.fbx.zip

**System Information** macOS 10.13.1 iMac late 2013 **Blender Version** version 2.79 Worked: (optional) **Short description of error** import a fbx then export a dae file, blender crashed, (always) **Exact steps for others to reproduce the error** 1. open blender 2. remove box 3. import a fbx 4. export to dae 5. crash crash log: [blender.crash](https://archive.blender.org/developer/F1085843/blender.crash) model sample: [Sapphiart_model.fbx.zip](https://archive.blender.org/developer/F1085844/Sapphiart_model.fbx.zip)
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @abroter

Added subscriber: @abroter

Added subscriber: @PeterBoos

Added subscriber: @PeterBoos

I couldnt even open the fbx file, i am not a developer but in some cases i give advice that can help you and them

You see its complex to keep up with company formats if those companies dont support open formats (like DocX), basically its all reversed engineering whats in Blender.
I think you better go with the tools provided by those companies to convert those files; checkout this : https://www.autodesk.com/products/fbx/fbx-review
Blender will never be a state of the art converter of autocad formats, simply because they dont put their format under open document contract licenses.
Also they are prone to change some of their formats so that different versions of autocad itself cannot even exchange files, just to drive up their sales...

I'd say yes its a bug, but dont blame the people who try to reverse engineer it, and always in such cases try to find the company and check if they do conversions.
Some developers try to reverse engineer their formats with some degree of succes, but since its not open its always a trouble.
So great if it got fixed but dont count of it, as reverse engineering is a enormous task. But i hope that the link will help you in your process.

I couldnt even open the fbx file, i am not a developer but in some cases i give advice that can help you and them You see its complex to keep up with company formats if those companies dont support open formats (like DocX), basically its all reversed engineering whats in Blender. I think you better go with the tools provided by those companies to convert those files; checkout this : https://www.autodesk.com/products/fbx/fbx-review Blender will never be a state of the art converter of autocad formats, simply because they dont put their format under open document contract licenses. Also they are prone to change some of their formats so that different versions of autocad itself cannot even exchange files, just to drive up their sales... I'd say yes its a bug, but dont blame the people who try to reverse engineer it, and always in such cases try to find the company and check if they do conversions. Some developers try to reverse engineer their formats with some degree of succes, but since its not open its always a trouble. So great if it got fixed but dont count of it, as reverse engineering is a enormous task. But i hope that the link will help you in your process.
Author

In #53230#469046, @PeterBoos wrote:
I couldnt even open the fbx file, i am not a developer but in some cases i give advice that can help you and them

You see its complex to keep up with company formats if those companies dont support open formats (like DocX), basically its all reversed engineering whats in Blender.
I think you better go with the tools provided by those companies to convert those files; checkout this : https://www.autodesk.com/products/fbx/fbx-review
Blender will never be a state of the art converter of autocad formats, simply because they dont put their format under open document contract licenses.
Also they are prone to change some of their formats so that different versions of autocad itself cannot even exchange files, just to drive up their sales...

I'd say yes its a bug, but dont blame the people who try to reverse engineer it, and always in such cases try to find the company and check if they do conversions.
Some developers try to reverse engineer their formats with some degree of succes, but since its not open its always a trouble.
So great if it got fixed but dont count of it, as reverse engineering is a enormous task. But i hope that the link will help you in your process.

sample fbx file can open with “autodesk fbx review” app
屏幕快照 2017-11-03 上午11.17.21.png

> In #53230#469046, @PeterBoos wrote: > I couldnt even open the fbx file, i am not a developer but in some cases i give advice that can help you and them > > You see its complex to keep up with company formats if those companies dont support open formats (like DocX), basically its all reversed engineering whats in Blender. > I think you better go with the tools provided by those companies to convert those files; checkout this : https://www.autodesk.com/products/fbx/fbx-review > Blender will never be a state of the art converter of autocad formats, simply because they dont put their format under open document contract licenses. > Also they are prone to change some of their formats so that different versions of autocad itself cannot even exchange files, just to drive up their sales... > > I'd say yes its a bug, but dont blame the people who try to reverse engineer it, and always in such cases try to find the company and check if they do conversions. > Some developers try to reverse engineer their formats with some degree of succes, but since its not open its always a trouble. > So great if it got fixed but dont count of it, as reverse engineering is a enormous task. But i hope that the link will help you in your process. sample fbx file can open with “autodesk fbx review” app ![屏幕快照 2017-11-03 上午11.17.21.png](https://archive.blender.org/developer/F1089074/屏幕快照_2017-11-03_上午11.17.21.png)

Added subscribers: @GaiaClary, @FloridaJo

Added subscribers: @GaiaClary, @FloridaJo
Gaia Clary was assigned by Joel Godin 2017-11-03 11:17:24 +01:00

Happens here on OSX as well. Oct 24 build.
crash log here:

blender.crash.txt

Is this yours @GaiaClary ?

Happens here on OSX as well. Oct 24 build. crash log here: [blender.crash.txt](https://archive.blender.org/developer/F1089900/blender.crash.txt) Is this yours @GaiaClary ?
Member

Please can you create a blend file that will crash blender when you try to export it to dae ?
Then prepare the blend file such that all i need to do is calling:

  File -> Export -> Collada -> Export Collada

to see blender crashing.
I just want to be sure that i am looking at the right thing.
Then its much easier to figure out what is wrong :)

thanks

Please can you create a blend file that will crash blender when you try to export it to dae ? Then prepare the blend file such that all i need to do is calling: ``` File -> Export -> Collada -> Export Collada ``` to see blender crashing. I just want to be sure that i am looking at the right thing. Then its much easier to figure out what is wrong :) thanks
Member

Changed status from 'Open' to: 'Archived'

Changed status from 'Open' to: 'Archived'
Member

Changed status from 'Archived' to: 'Open'

Changed status from 'Archived' to: 'Open'

If I pack external data, it no longer crashes.
You have to import, then export > crash.
If you import, pack, export, > no crash.

If I pack external data, it no longer crashes. You have to import, then export > crash. If you import, pack, export, > no crash.
Member

Added subscriber: @cmbasnett

Added subscriber: @cmbasnett

Added subscriber: @ywaby

Added subscriber: @ywaby

same with me

  • import fbx and export dae, will crash blender
  • export to other file type, it is ok
  • save and reopen blender then export dae, it work ok
  • daily build blender has same problem

my system is debian testing

with error info

terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_M_construct null not valid

HallwaysCollision.fbx

same with me - import fbx and export dae, will crash blender - export to other file type, it is ok - save and reopen blender then export dae, it work ok - daily build blender has same problem my system is debian testing with error info ``` terminate called after throwing an instance of 'std::logic_error' what(): basic_string::_M_construct null not valid ``` [HallwaysCollision.fbx](https://archive.blender.org/developer/F1641005/HallwaysCollision.fbx)

This issue was referenced by e59cf13b8c

This issue was referenced by e59cf13b8c457c69945a9f85e9de61d36d434eea
Member

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Member

Right after importing the fbx the active UV Layer seems to be not defined for the imported Mesh Object. The active UV Layer is automatically enabled as soon as i open the data properties of the mesh object. From this moment on the Collada exporter works without crashing.

The Blender crash during Collada export happens because the exporter expects an active UV Layer when UV Layers are defined. This seems to be a wrong assumption. I fixed this in the Collada Exporter in master

Right after importing the fbx the active UV Layer seems to be not defined for the imported Mesh Object. The active UV Layer is automatically enabled as soon as i open the data properties of the mesh object. From this moment on the Collada exporter works without crashing. The Blender crash during Collada export happens because the exporter expects an active UV Layer when UV Layers are defined. This seems to be a wrong assumption. I fixed this in the Collada Exporter in master
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
7 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#53230
No description provided.