Normal transform orientation for edge is wrong when edge has specific coordinates #53311

Closed
opened 2017-11-13 14:09:49 +01:00 by Satoshi Doita · 12 comments

System Information
Windows 7 Professional 64-bit service pack 1
Intel Core i7-2600
8GB RAM
NVIDIA GTX 1060 6GB

Blender Version
Broken: 2.79 5bd8ac9

description of error
When selected edge matches one of following rules, wrong transform orientation being used instead of normal transform orientation.

  1. One of vertex is on local origin.
    Or
  2. One of vertex's local coordinate is the other vertex's local coordinate multiplied by power of 2.

e.g. (1, 2, 3)and(4, 8, 12), (0.3, -1.22, 7)and(-2.4, 9.76, -56), (0, 0, 0)and(0.5,0.6,-0.4)

Exact steps for others to reproduce the error

  1. Open attached .blend file and enter edit mode.
  2. Make sure show_manipulator is on and transform orientation is set to normal.
  3. Select edge and see transform orientation.

NormalTransformOrientation.blend

**System Information** Windows 7 Professional 64-bit service pack 1 Intel Core i7-2600 8GB RAM NVIDIA GTX 1060 6GB **Blender Version** Broken: 2.79 5bd8ac9 **description of error** When selected edge matches one of following rules, wrong transform orientation being used instead of normal transform orientation. 1. One of vertex is on local origin. Or 2. One of vertex's local coordinate is the other vertex's local coordinate multiplied by power of 2. e.g. (1, 2, 3)and(4, 8, 12), (0.3, -1.22, 7)and(-2.4, 9.76, -56), (0, 0, 0)and(0.5,0.6,-0.4) **Exact steps for others to reproduce the error** 1. Open attached .blend file and enter edit mode. 2. Make sure show_manipulator is on and transform orientation is set to normal. 3. Select edge and see transform orientation. [NormalTransformOrientation.blend](https://archive.blender.org/developer/F1131539/NormalTransformOrientation.blend)
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @SatoshiDoita

Added subscriber: @SatoshiDoita

Added subscriber: @zeauro

Added subscriber: @zeauro

Confirmed on linux for 2.79 and master 556b13f

Confirmed on linux for 2.79 and master 556b13f
Dan Marra self-assigned this 2018-01-10 22:12:06 +01:00

After playing with this a bit, I noticed that if you move the vertex that is positioned at local (0,0,0) to another position, and then move it back to local (0,0,0), the orientation of the manipulator is correct.

After playing with this a bit, I noticed that if you move the vertex that is positioned at local (0,0,0) to another position, and then move it back to local (0,0,0), the orientation of the manipulator is correct.

My last comment wasn;t entirely true. It seems that in the first case of (0,0,0), setting the pivot point to "active element" corrects the behavior. However, for the second reproduction step regarding multiples of 2, no pivot point selection seems to remedy the problem.

My last comment wasn;t entirely true. It seems that in the first case of (0,0,0), setting the pivot point to "active element" corrects the behavior. However, for the second reproduction step regarding multiples of 2, no pivot point selection seems to remedy the problem.

This is actually a problem that occurs when the vertex normal is the same as the normal between both points of the edge; aka the edge is pointing towards the object origin.

This is actually a problem that occurs when the vertex normal is the same as the normal between both points of the edge; aka the edge is pointing towards the object origin.

Added subscriber: @ideasman42

Added subscriber: @ideasman42

Thanks @dmarra for finding the cause of the error, though I closed the diff since I think it doesn't properly resolve the issue.
Modifying the normal by the plane may give bad results in some cases.

The issue is:

  • the normal and the plane may be aligned or near aligned.
  • the resulting matrix prioritizes the normal over the plane (the plane is rotated to be orthogonal with the normal).
  • in the case of wire edges it's expected the orientation is aligned with the edge (in this case the normals aren't meaningful).
Thanks @dmarra for finding the cause of the error, though I closed the diff since I think it doesn't properly resolve the issue. Modifying the normal by the plane may give bad results in some cases. The issue is: - the normal and the plane may be aligned or near aligned. - the resulting matrix prioritizes the normal over the plane (the plane is rotated to be orthogonal with the normal). - in the case of wire edges it's expected the orientation is aligned with the edge (in this case the normals aren't meaningful).

This issue was referenced by 0edda8e4ce

This issue was referenced by 0edda8e4ce4e7dc0d72a105b773896b7b17c480b

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'

No problem @ideasman42 . My fix had some weird side effects when I tested it deeper after submitting the patch, so not surprised it was rejected. Glad I could help better define the root cause though.

No problem @ideasman42 . My fix had some weird side effects when I tested it deeper after submitting the patch, so not surprised it was rejected. Glad I could help better define the root cause though.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#53311
No description provided.