Playback slow with large static Text Object #53410

Closed
opened 2017-11-28 09:15:13 +01:00 by Atair-1 · 9 comments

System Information
Windows7 x64, GTX 1070

Blender Version
2.79

When adding a Text object with 100+ words, the animation playback speed goes down to <10fps
It the only value it seems to be related is the 'Preview U' Resolution.

Looks like the Dependency Graph rebuilds the whole Text-Mesh on every frame, even if there is nothing animated.

**System Information** Windows7 x64, GTX 1070 **Blender Version** 2.79 When adding a Text object with 100+ words, the animation playback speed goes down to <10fps It the only value it seems to be related is the 'Preview U' Resolution. Looks like the Dependency Graph rebuilds the whole Text-Mesh on every frame, even if there is nothing animated.
Author

Changed status to: 'Open'

Changed status to: 'Open'
Author

Added subscriber: @Atair-1

Added subscriber: @Atair-1

Added subscriber: @zeauro

Added subscriber: @zeauro

Confirmed on ubuntu with master 7c64e33 and official 2.79

inefficient_text_display.blend

In attached .blend file, I used Lyapunov Texture Template to create a long 3D text object.
At default Preview resolution of 12, it corresponds to 254 193 tris interpolated. At Preview U resolution set at 1, it correspond to 33 973 tris. Of course playback is a little bit better but not great.

And it becomes really unacceptable when draw type is set to Bounds to reduce display of text to a wire of 4 lines : there is no improvement of fps.

Edit; Oops. It looks like problem does not exist when blender is launched with new depsgraph.
By typing in commandline blender --enable-new-depsgraph, there is no more problem.
Is it something that should be supported by legacy depsgraph in 2.79a ?

Confirmed on ubuntu with master 7c64e33 and official 2.79 [inefficient_text_display.blend](https://archive.blender.org/developer/F1218894/inefficient_text_display.blend) In attached .blend file, I used Lyapunov Texture Template to create a long 3D text object. At default Preview resolution of 12, it corresponds to 254 193 tris interpolated. At Preview U resolution set at 1, it correspond to 33 973 tris. Of course playback is a little bit better but not great. And it becomes really unacceptable when draw type is set to Bounds to reduce display of text to a wire of 4 lines : there is no improvement of fps. Edit; Oops. It looks like problem does not exist when blender is launched with new depsgraph. By typing in commandline blender --enable-new-depsgraph, there is no more problem. Is it something that should be supported by legacy depsgraph in 2.79a ?
Author

With the new depsgraph the playback lag is gone, but a new problem is introduced:
Transforming (Moving) The Textobject is now very slow / choppy.
Easily noticeable with 250+ Words
Should this go into a separate task?

With the new depsgraph the playback lag is gone, but a new problem is introduced: Transforming (Moving) The Textobject is now very slow / choppy. Easily noticeable with 250+ Words Should this go into a separate task?

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'

Added subscriber: @ideasman42

Added subscriber: @ideasman42

@Atair-1 fixed original report, please report separate issue.

@Atair-1 fixed original report, please report separate issue.

This issue was referenced by df7b9fa2ee

This issue was referenced by df7b9fa2eeb5908de4e1b3c2c6f7cf30329f1e3d
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#53410
No description provided.