Particle Size Weirdness #53513

Closed
opened 2017-12-08 14:57:58 +01:00 by Steffen Dünner · 9 comments

System Information
Win10 x64, nVidia GTX1080Ti

Blender Version
Broken: All so far
Worked: (optional)

Short description of error
One might not consider this a real bug, but IMHO this can easily destroy (as in "change") your particle simulations during a project so I consider it a showstopper bug.

The value "ParticleSettings.particle_size" can be changed in two different places in the particle settings tab.

Under "Physics":
Particles_Force.png

And under "Render":
Particles_Render.png

This makes perfect sense if you want to e.g. simulate particles with a certain size but render them as larger or smaller instances (Groups, Objects, ...).
The problem is that both sizes point to the same data path and change each other. So if you use "Fluid" particles and bake your simulation, most of the particle settings UI turns grey and can't be changed (because now the bake is in control). You're still allowed to change how particles get displayed and rendered. And you can also change the render size of the particles BUT as it uses the same data path you don't only change how they're rendered but you now change a setting of the simulation / physics. You can successfully render the baked sim with larger particles if you want BUT as soon as you have to rebake your whole simulation will totally change which is a true production nightmare.
The render/display size could be made totally independent or a factor of the physical size but the display size should NEVER influence the physical size.

This "feature" is currently making an otherwise super smooth project a lot more tedious to handle and I hope it can be "fixed" with some band-aid until the new particle system in 2.8+ comes.

Exact steps for others to reproduce the error
Read above.

**System Information** Win10 x64, nVidia GTX1080Ti **Blender Version** Broken: All so far Worked: (optional) **Short description of error** One might not consider this a real bug, but IMHO this can easily destroy (as in "change") your particle simulations during a project so I consider it a showstopper bug. The value "ParticleSettings.particle_size" can be changed in two different places in the particle settings tab. Under "Physics": ![Particles_Force.png](https://archive.blender.org/developer/F1344709/Particles_Force.png) And under "Render": ![Particles_Render.png](https://archive.blender.org/developer/F1344731/Particles_Render.png) This makes perfect sense if you want to e.g. simulate particles with a certain size but render them as larger or smaller instances (Groups, Objects, ...). The problem is that both sizes point to the same data path and change each other. So if you use "Fluid" particles and bake your simulation, most of the particle settings UI turns grey and can't be changed (because now the bake is in control). You're still allowed to change how particles get displayed and rendered. And you can also change the render size of the particles BUT as it uses the same data path you don't only change how they're rendered but you now change a setting of the simulation / physics. You can successfully render the baked sim with larger particles if you want BUT as soon as you have to rebake your whole simulation will totally change which is a true production nightmare. The render/display size could be made totally independent or a factor of the physical size but the display size should NEVER influence the physical size. This "feature" is currently making an otherwise super smooth project a lot more tedious to handle and I hope it can be "fixed" with some band-aid until the new particle system in 2.8+ comes. **Exact steps for others to reproduce the error** Read above.

Added subscriber: @SteffenD

Added subscriber: @SteffenD
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

Just to give this a second voice: I can confirm above analysis and would also consider this kindof weak...
However, splitting this into two separate props would have to be done carefully as it touches various places (cycles, smoke, ...) and I'm not sure how high this is on the list?
Until someone else votes this as 'not a bug' I'll change this to normal prio...

Just to give this a second voice: I can confirm above analysis and would also consider this kindof weak... However, splitting this into two separate props would have to be done carefully as it touches various places (cycles, smoke, ...) and I'm not sure how high this is on the list? Until someone else votes this as 'not a bug' I'll change this to normal prio...

This issue was referenced by a6c69ca57f

This issue was referenced by a6c69ca57f661a8538d70cde9471a2554cecc65b

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'

Added subscriber: @zeauro

Added subscriber: @zeauro

I think that this should be re-opened.
Removing size in Physics panel does not solve anything.

User can still precise one size for simulation, modify it for rendering purpose (for example, to use metaballs).
When he will try to re-use same simulation settings to make a derivative one, value of Size used for initial simulation is lost.

I think that this should be re-opened. Removing size in Physics panel does not solve anything. User can still precise one size for simulation, modify it for rendering purpose (for example, to use metaballs). When he will try to re-use same simulation settings to make a derivative one, value of Size used for initial simulation is lost.

After finishing the job that caused me to post this "bug report", I somehow lost sight of this ticket. But on second thought it might actually be worth to re-open it again for the exact reason that ronan mentioned.
Render size and simulation size should both be available but the render size should never affect the simulation. Quite the same as changing the instanced object or group doesn't affect the simulation. You should still be allowed to change render settings after caching a simulation.

After finishing the job that caused me to post this "bug report", I somehow lost sight of this ticket. But on second thought it might actually be worth to re-open it again for the exact reason that ronan mentioned. Render size and simulation size should both be available but the render size should never affect the simulation. Quite the same as changing the instanced object or group doesn't affect the simulation. You should still be allowed to change render settings after caching a simulation.

In #53513#483348, @SteffenD wrote:
Render size and simulation size should both be available but the render size should never affect the simulation.

My point is just that fix did not fix the issue. There is still one size in the UI affecting both render and simulation.

If you consider that you can always scale a metaball in edit mode or an object or a group that will be used by duplis ; in that case, it is render size that should be removed and physical size should be kept and greyed out after baking particles.

> In #53513#483348, @SteffenD wrote: > Render size and simulation size should both be available but the render size should never affect the simulation. My point is just that fix did not fix the issue. There is still one size in the UI affecting both render and simulation. If you consider that you can always scale a metaball in edit mode or an object or a group that will be used by duplis ; in that case, it is render size that should be removed and physical size should be kept and greyed out after baking particles.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#53513
No description provided.