Collapse of surface Curves when CTRL+J #53586

Closed
opened 2017-12-19 11:09:11 +01:00 by Paco Giner · 8 comments

Windows 10 64x - Nvidia GeForce Titan black Z

Broken: 2.79 5bd8ac9
Worked: 2.78 any and previous

I try to make a modeling from surface curves, and use different curves with the same resolution and number of points, arranged in space as sections. It is a procedure that I have used many times before, always successfully. At the moment, I select all the curves, and I press CTRL + J (OIN) to turn them into a single object, after this, I change to editing mode and select all the points and pulse F, with which the surface is created.
The current problem is that by selecting now the different curves, and pressing CTRL + J the curves are joined, but they are moved to the location of the last one selected, which we can consider as an active element, and therefore, it is not possible to correctly perform the creation of the surface. In addition, the points of the different curves are aligned with the same value and orientation of the active curve.

Windows 10 64x - Nvidia GeForce Titan black Z Broken: 2.79 5bd8ac9 Worked: 2.78 any and previous I try to make a modeling from surface curves, and use different curves with the same resolution and number of points, arranged in space as sections. It is a procedure that I have used many times before, always successfully. At the moment, I select all the curves, and I press CTRL + J (OIN) to turn them into a single object, after this, I change to editing mode and select all the points and pulse F, with which the surface is created. The current problem is that by selecting now the different curves, and pressing CTRL + J the curves are joined, but they are moved to the location of the last one selected, which we can consider as an active element, and therefore, it is not possible to correctly perform the creation of the surface. In addition, the points of the different curves are aligned with the same value and orientation of the active curve.
Author

Added subscriber: @PacoGiner

Added subscriber: @PacoGiner

#53717 was marked as duplicate of this issue

#53717 was marked as duplicate of this issue

Added subscriber: @zeauro

Added subscriber: @zeauro

Surface_Curves_Join.blend

In attached .blend, do Ctrl J to join Surfaces curves to observe the problem.
Surfaces Curves are considered as 2D splines. It looks like they are considered as 3D splines only if they are created in edit mode.

Issue is confirmed for 2.79 and master e5b92cd under ubuntu 16.04

[Surface_Curves_Join.blend](https://archive.blender.org/developer/F1466411/Surface_Curves_Join.blend) In attached .blend, do Ctrl J to join Surfaces curves to observe the problem. Surfaces Curves are considered as 2D splines. It looks like they are considered as 3D splines only if they are created in edit mode. Issue is confirmed for 2.79 and master e5b92cd under ubuntu 16.04

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'

This issue was referenced by 457dc8d12c

This issue was referenced by 457dc8d12ca79247349aa3e76457a9f45e73026e

Added subscribers: @eroMoD, @DuarteRamos

Added subscribers: @eroMoD, @DuarteRamos

Added subscriber: @Miranda

Added subscriber: @Miranda
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#53586
No description provided.