Metadata "Stamp Output" does not show on some effect strips. #53639

Closed
opened 2017-12-26 20:48:36 +01:00 by ChristopherAnderssarian · 8 comments

System Information
Windows 7 Ultimate, 64-bit, 32GB, 5960x (8-core), Nvidia Quadro FX 1800 (Primary) & GeForce 9800 GTX+ (Secondary)
Graphics Tablet: Wacom Bamboo Model: CTF-430 Driver Version 5.2.4-5

Blender Version
Broken: (2.79 2017-09-11 10:43 Hash: 5bd8ac9)
And: blender-2.79-948515c-win64 Tue Dec 26 02:47:33 2017
Worked: (N/A)

Short description of error
Output_Image.png
Metadata "Stamp Output" show's color but not anything else that can be an independent strip.
Doesn't show the correct strip for multi-cam as well.

Exact steps for others to reproduce the error

Hopefully obvious to reproduce:

Seq.Strip.blend

**System Information** Windows 7 Ultimate, 64-bit, 32GB, 5960x (8-core), Nvidia Quadro FX 1800 (Primary) & GeForce 9800 GTX+ (Secondary) Graphics Tablet: Wacom Bamboo Model: CTF-430 Driver Version 5.2.4-5 **Blender Version** Broken: (2.79 2017-09-11 10:43 Hash: 5bd8ac9) And: blender-2.79-948515c-win64 Tue Dec 26 02:47:33 2017 Worked: (N/A) **Short description of error** ![Output_Image.png](https://archive.blender.org/developer/F1537530/Output_Image.png) Metadata "Stamp Output" show's color but not anything else that can be an independent strip. Doesn't show the correct strip for multi-cam as well. **Exact steps for others to reproduce the error** Hopefully obvious to reproduce: [Seq.Strip.blend](https://archive.blender.org/developer/F1537528/Seq.Strip.blend)

Added subscriber: @ChristopherAnderssarian

Added subscriber: @ChristopherAnderssarian
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

can confirm this.
right now only only strips of these types show their strip names: IMAGE, META, SCENE, MOVIE and COLOR.
there's a comment in the code to /* only use elements you can see - not */
I'm not sure yet of the reasoning behind that comment but no matter what I think it is reasonable to include strips of type TEXT, COLORMIX (and maybe MULTICAM as well) in the list for consistency.
fix/patch on the way...

can confirm this. right now only only strips of these types show their strip names: IMAGE, META, SCENE, MOVIE and COLOR. there's a comment in the code to `/* only use elements you can see - not */` I'm not sure yet of the reasoning behind that comment but no matter what I think it is reasonable to include strips of type TEXT, COLORMIX (and maybe MULTICAM as well) in the list for consistency. fix/patch on the way...
Member

patch here D2977: fix #53639
(note: still left out MULTICAM, would like to gather feedback first...)

patch here [D2977: fix #53639](https://archive.blender.org/developer/D2977) (note: still left out MULTICAM, would like to gather feedback first...)

This issue was referenced by 08b063a19f

This issue was referenced by 08b063a19f21cd1bcafc9c0dff70d5ff6f0e099a

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'

Added subscriber: @brecht

Added subscriber: @brecht

MULTICAM is selecting one of multiple channels, if we want to support that then I think it should use the name of the strip in the selected channel.

MULTICAM is selecting one of multiple channels, if we want to support that then I think it should use the name of the strip in the selected channel.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#53639
No description provided.