Island margin in smart UV project issue with scene scale #53678

Closed
opened 2018-01-02 12:33:10 +01:00 by daniel · 3 comments

System Information
win 7 pro 64bit

Blender Version
Broken: (2.79 34fe3f9 )
Worked: (perhaps never)

Short description of error
Island margin in smart UV project does not take into account the scale of a scene set in scene/ units panel.
it only works for "default" units when unit scale is 1.0

Exact steps for others to reproduce the error
1.open blender
2.add default cube (2,2,2)[meters unit] if blender is not in factory settings
3.in edit mode do smart UV project and change island margin to 1 and note the margin between islands
4.now change unit from meters/metric to centimeters/ metric
5.do smart uv project with the same settings as above and note the margin ---> it is ok in both cases (expected result) as in meters unit cube has 2/2/2m and in cm unit has 2/2/2 cm because blender alone changed displaying cube from meters to cm
6.now staying in cm units scale the cube 100x and apply scale to have cube in initial size of 2/2/2 meters, but now in scene scale in cm
7.do smart uv project with island margin with 1 ----> note how small the margin is and it does not correspond with earlier results, it did not take into account the scale change as it should be in my opinion. the effect should be the same no matter scale is set or applied

**System Information** win 7 pro 64bit **Blender Version** Broken: (2.79 34fe3f9 ) Worked: (perhaps never) **Short description of error** Island margin in smart UV project does not take into account the scale of a scene set in scene/ units panel. it only works for "default" units when unit scale is 1.0 **Exact steps for others to reproduce the error** 1.open blender 2.add default cube (2,2,2)[meters unit] if blender is not in factory settings 3.in edit mode do smart UV project and change island margin to 1 and note the margin between islands 4.now change unit from meters/metric to centimeters/ metric 5.do smart uv project with the same settings as above and note the margin ---> it is ok in both cases (expected result) as in meters unit cube has 2/2/2m and in cm unit has 2/2/2 cm because blender alone changed displaying cube from meters to cm 6.now staying in cm units scale the cube 100x and apply scale to have cube in initial size of 2/2/2 meters, but now in scene scale in cm 7.do smart uv project with island margin with 1 ----> note how small the margin is and it does not correspond with earlier results, it did not take into account the scale change as it should be in my opinion. the effect should be the same no matter scale is set or applied
Author

Added subscriber: @midan-3

Added subscriber: @midan-3

This issue was referenced by cbc7aa80d4

This issue was referenced by cbc7aa80d49e3b36c9ecc0e27ec528b34c491fc1

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#53678
No description provided.