Implement Driver Workflow Changes #55145

Open
opened 2018-05-22 14:50:47 +02:00 by Joshua Leung · 4 comments
Member

Followup task to #54653 to work on implementing the workflow changes proposed.
(Note: This is currently a lower priority item than fixing bugs to get 2.8 into a usable state for Spring team. But, I'll be working on this when I get time).

There are the following sub-tasks:

  • Create operator for "Open Drivers Editor" functionality. c685c19df9

    • Basic opening functionality
    • Filtering support to get driven property under mouse at the time the "active" driver
    • Abstract out the "Setup Drivers Editor" and "Show this channel" functionality
    • Sub-editor mode for drivers in the mode selector
  • Eyedropper support for clicking in 3D view and getting menu of common properties to drive, based on item under mouse.

    • Basic object support
    • Investigate possibility of bone support too. (NOTE: Last time this was tried, it turned out being too complex to accomplish)
    • Restore cursor feedback when eyedropper is active (#55147)
    • Solve context/src button problems preventing eyedroppers from working in the popover
  • Clean up drivers editor ui - 57b47ebb28 (and followup commits)

  • Add more space for expressions box

  • Remove "Show Debug Info" checkbox - it's always needed

  • Remove "Update Dependencies" button by making it redundant - Should be ok now without out. It's still in the UI, but will be removed soon

  • Remove "Use Self"? Or rename?

  • Add optional display of useful hints about syntax for expressions and/or what can be used

  • New persistent floating panel UI for editing driver settings

    • Basic layout - 7e7680e33b - Use a modified version of the existing drivers editing panel, and make it a popover
    • Floating panel - 7a88a7742b - This makes the panel a popover. But, it doesn't stay open, or let you open the drivers editor
    • Make floating panel stay open - b11a1d5da2
    • Get "Open Drivers Editor" button working in the popup (i.e probably missing button context info for source property) - 1ff28c2650
    • Get Copy/Paste dvar operator buttons working (currently always greyed out) - 3e086af79c
    • Fix issues where popover still goes away too easily sometimes - Seems to be fixed with 17ee4836ab now. It may still happen, but it happens a whole lot less now.
  • Reduce friction of adding new driver variables / setting up basic single-target drivers

    • ~~Replace 'Add Drivers' Menu with Popover Panel ~~ - 4605e57b0f
    • Remove old (menu-based) operator
    • "Mapping" settings properties (see proposal)
    • Make setting driver input-target easier (i.e. no more need to change default expression first) - 9ab26bec27
    • Eyedropper for populating input variable settings (see above)
Followup task to #54653 to work on implementing the workflow changes proposed. (Note: This is currently a lower priority item than fixing bugs to get 2.8 into a usable state for Spring team. But, I'll be working on this when I get time). There are the following sub-tasks: * ~~**Create operator for "Open Drivers Editor" functionality.**~~ c685c19df9 * ~~Basic opening functionality~~ * ~~Filtering support to get driven property under mouse at the time the "active" driver~~ * Abstract out the "Setup Drivers Editor" and "Show this channel" functionality * Sub-editor mode for drivers in the mode selector * **Eyedropper support for clicking in 3D view and getting menu of common properties to drive, based on item under mouse.** * Basic object support * Investigate possibility of bone support too. (NOTE: Last time this was tried, it turned out being too complex to accomplish) * Restore cursor feedback when eyedropper is active (#55147) * Solve context/src button problems preventing eyedroppers from working in the popover * **Clean up drivers editor ui** - 57b47ebb28 (and followup commits) * ~~Add more space for expressions box~~ * ~~Remove "Show Debug Info" checkbox - it's always needed~~ * ~~Remove "Update Dependencies" button by making it redundant~~ - Should be ok now without out. It's still in the UI, but will be removed soon * Remove "Use Self"? Or rename? * Add optional display of useful hints about syntax for expressions and/or what can be used * **New persistent floating panel UI for editing driver settings** * ~~Basic layout~~ - 7e7680e33b - Use a modified version of the existing drivers editing panel, and make it a popover * ~~Floating panel~~ - 7a88a7742b - This makes the panel a popover. But, it doesn't stay open, or let you open the drivers editor * ~~Make floating panel stay open~~ - b11a1d5da2 * ~~Get "Open Drivers Editor" button working in the popup (i.e probably missing button context info for source property)~~ - 1ff28c2650 * ~~Get Copy/Paste dvar operator buttons working (currently always greyed out)~~ - 3e086af79c * ~~Fix issues where popover still goes away too easily sometimes~~ - Seems to be fixed with 17ee4836ab now. It may still happen, but it happens a whole lot less now. * **Reduce friction of adding new driver variables / setting up basic single-target drivers** * ~~Replace 'Add Drivers' Menu with Popover Panel ~~ - 4605e57b0f * Remove old (menu-based) operator * "Mapping" settings properties (see proposal) * ~~Make setting driver input-target easier~~ (i.e. no more need to change default expression first) - 9ab26bec27 * Eyedropper for populating input variable settings (see above)
Joshua Leung self-assigned this 2018-05-22 14:50:47 +02:00
Author
Member

Added subscriber: @JoshuaLeung

Added subscriber: @JoshuaLeung

Added subscriber: @zebus3dream

Added subscriber: @zebus3dream

Added subscriber: @0o00o0oo

Added subscriber: @0o00o0oo

Added subscriber: @Andersontxr

Added subscriber: @Andersontxr
Joshua Leung was unassigned by Sybren A. Stüvel 2020-11-09 18:37:27 +01:00
Philipp Oeser removed the
Interest
Animation & Rigging
label 2023-02-09 14:36:43 +01:00
Sybren A. Stüvel added this to the Animation & Rigging project 2023-02-14 15:33:20 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#55145
No description provided.