Pose library addon not working #55232

Closed
opened 2018-05-28 19:00:59 +02:00 by Hjalti Hjálmarsson · 15 comments

The addon doesn't seem to apply poses.

https://github.com/sybrenstuvel/pose_thumbnails

  • Apply Pose is broken
  • Mix Pose is semi broken (original value is slightly wrong)
The addon doesn't seem to apply poses. https://github.com/sybrenstuvel/pose_thumbnails * Apply Pose is broken * Mix Pose is semi broken (original value is slightly wrong)
Author
Member

Added subscriber: @Hjalti

Added subscriber: @Hjalti
Member

Added subscribers: @dr.sybren, @JoshuaLeung

Added subscribers: @dr.sybren, @JoshuaLeung
Joshua Leung self-assigned this 2018-05-28 19:23:57 +02:00
Member

This is a blocking issue for Spring animators - particularly as @Hjalti needs it to do facial animation soon.

This is a blocking issue for Spring animators - particularly as @Hjalti needs it to do facial animation soon.
Member

Checking the code, the addon needs to be modified to read the original pose from evaluated data (e.g. context.depsgraph.id_eval_get()). Most likely, we should just modify get_current_pose() (or the store_bone()) inside it.

Checking the code, the addon needs to be modified to read the original pose from evaluated data (e.g. `context.depsgraph.id_eval_get()`). Most likely, we should just modify `get_current_pose()` (or the `store_bone()`) inside it.
Joshua Leung was unassigned by Sybren A. Stüvel 2018-05-31 11:40:43 +02:00
Sybren A. Stüvel self-assigned this 2018-05-31 11:40:43 +02:00

This is not (just) an issue with the add-on; applying a pose from a pose library (which is built-in Blender functionality) also doesn't work with CoW.

This is not (just) an issue with the add-on; applying a pose from a pose library (which is built-in Blender functionality) also doesn't work with CoW.

The add-on seems to work fine when there is no animation data on the armature object (useless for production, I know). The problem seems to be in the application of a pose on top of an already-animated armature, which is what Sergey is working on now.

The add-on seems to work fine when there is no animation data on the armature object (useless for production, I know). The problem seems to be in the application of a pose on top of an already-animated armature, which is what Sergey is working on now.

Seems to be fixed by D3448

Seems to be fixed by [D3448](https://archive.blender.org/developer/D3448)

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'

Yup, it's solved by Sergey's introduction of the active depsgraph.

Yup, it's solved by Sergey's introduction of the active depsgraph.

Added subscriber: @SebastianSanchez

Added subscriber: @SebastianSanchez

Hello Sybren and Hjalti, you say it's fixed by D3448, but so far I've been trying to install it for 3 days, tried to place it in the addons folder direclty, ... with 2.80 and I just get an error: check console. ( I don't manage to open the console like we used to in passed versions ), so if I check the python console, there's no error message. I've been trying other alternatives, Pose Tools addon, and the other version of this addon by Jasper before Sybren adapted it to EEVEE, but nothing seems to work. I checked the video of Pablo and Hjalti but that was before the beta version, and it seemed to work fine. So, could you please point me out to the correct version that works with 2.8, please.

Hello Sybren and Hjalti, you say it's fixed by [D3448](https://archive.blender.org/developer/D3448), but so far I've been trying to install it for 3 days, tried to place it in the addons folder direclty, ... with 2.80 and I just get an error: check console. ( I don't manage to open the console like we used to in passed versions ), so if I check the python console, there's no error message. I've been trying other alternatives, Pose Tools addon, and the other version of this addon by Jasper before Sybren adapted it to EEVEE, but nothing seems to work. I checked the video of Pablo and Hjalti but that was before the beta version, and it seemed to work fine. So, could you please point me out to the correct version that works with 2.8, please.

Added subscriber: @iurimonteiro

Added subscriber: @iurimonteiro

this is still bugged.

"So when you guys use pose library on blender 2.8 does everything work ok or its bugged? Because I select all the bones I create a new pose, I change the pose then try to apply the pose that was storaged and he only applies to 1 controller. And I saved with all controllers selected and I apply with all controllers selected"

this is still bugged. "So when you guys use pose library on blender 2.8 does everything work ok or its bugged? Because I select all the bones I create a new pose, I change the pose then try to apply the pose that was storaged and he only applies to 1 controller. And I saved with all controllers selected and I apply with all controllers selected"

Added subscriber: @brecht

Added subscriber: @brecht

Please create a new report if you think you found a bug, it's unlikely to have the same cause as this old report.

Please create a new report if you think you found a bug, it's unlikely to have the same cause as this old report.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
6 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#55232
No description provided.